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Introduction  

This handbook contains step-by-step guidance for CFD 15 tutorials which should be followed in sequence to guide you 

through the learning outcomes of MECH5770M, Computational Fluid Dynamics Analysis. Note that Tutorial 15 is 

optional and it is designed to show you how to use High Performance Computing (HPC) which is not required for the 

module, however, it may help if you run larger simulations for project work. Each of the tutorials has been written 

using the commercial CFD package, ANSYS. It is important that you complete these tutorials to practice the hands-on 

skills required to become a competent CFD engineer.  

To support this process, there are 10 tasks for you to complete. As you finish the tasks, a series of online Multiple 

Choice Questionnaires (MCQ’s) will be made available at different points in semester 1. These MCQ’s are designed to 

test your knowledge of the tutorials by providing you formative feedback. From 2022 onwards, these MCQs do not 

contribute to your module grade. More details regarding MCQs will be provided in announcements as the module 

progresses. 

To complement this tutorial handbook, the module leader has prepared a video recording with commentary for 

tutorials 1-14 to help support your progress. In addition, you will have support from the module leader and 

demonstrators in online support sessions which will allow you to ask questions if you face difficulties with the content. 

You will also have access to the lecture slides and pre-recorded lectures, the latter released gradually on a week-by-

week basis. The module leader will also deliver a weekly lecture and fortnightly problem-solving sessions to help 

reinforce the module learning outcomes. Finally, extra supporting material is available on MINERVA. All of the above 

information is described in the first set of lecture slides.  

 

 

Software 
As described above, the software you will need access to in order to complete this module is ANSYS. If you have a 

Windows laptop/PC you can download ANSYS Student for free which will enable you to complete the tutorials. This is 

found at: https://www.ansys.com/en-gb/academic/students/ansys-student. If you do choose to download this, please 

make sure that you download ANSYS Student and not Discovery AIM. Unfortunately, ANSYS is not available for MAC 

users, but alternative access is available on some University PCs (e.g. 5th floor cluster in School of Mechanical 

Engineering) and through virtual clusters. The module leader will describe these alternatives early in semester 1.  

This tutorial guide has been written and tested using ANSYS 2020 R2. Some of the images you will see are a legacy 

of older versions of the software (e.g. ANSYS V19.2) so please do not be concerned if the appearance of some 

menus/images are not identical to what you see on your screen as you complete the exercises. Likewise, if you are 

using a later version of ANSYS, there may be some visual differences, however, you should be able to complete the 

exercises without difficulty. If there are any obvious errors or problems, please inform the module leader in the first 

instance.  

  

https://www.ansys.com/en-gb/academic/students/ansys-student


MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               iii 
 

Tutorials/themes 
The table below shows the full list of tutorials including the themes they cover. Task numbers are shown here for 

clarity, noting that some tutorials do not have tasks. Please complete the tutorials in order. You can use the section 

hyperlinks in the content table (page i) to quickly navigate to the tutorials of interest. 

Tutorial 
number 

Title of practical Task 
number 

2D or 
3D 

Themes 

1 Lid-driven cavity (i) - 2D Geometry creation, meshing schemes/quality 

2 Lid-driven cavity (ii)  1 2D Laminar flow simulation, basic postprocessing 

3 Backward-facing step (i) 
- 

2D 
2nd order turbulent flow simulation, 
postprocessing 

4 Backward-facing step (ii)  

2 
2D 

Further post-processing, turbulence model 
comparison 

5 
External aerodynamics: 
NACA0012 (i) 

- 
2D 

Geometry manipulation, meshing near walls, 
monitors 

6 
External aerodynamics: 
NACA0012 (ii)  

3 
2D Custom field functions, postprocessing 

7 Flow over blunt rectangle  

4 
2D 

Mesh control, turbulence model comparison, 
validation 

8 
Flow visualisation around a 
3D tower 

- 
3D Advanced postprocessing 

9 Laminar channel flow  5 2D Mesh control, mesh independence study 

10 
Laminar flow through 
staggered heat exchanger (i)  

6 
2D 

Implement periodic/symmetric boundaries, 
Text User Interface  

11 
Laminar flow through 
staggered heat exchanger (ii)  

7 
2D 

Flow simulations and advanced 
postprocessing 

12 
Compressible flow (i): 
Prandtl-Meyer expansion  

8 
2D Compressible flow simulations 

13 
Compressible flow (ii): 
Double-wedge aerofoil  

9 
2D Mesh adaption 

14 
3D flow in a mechanically 
ventilated room (i)  

10 
3D 

Geometry creation, meshing schemes/quality, 
simulations 

15 
3D flow in a mechanically 
ventilated room (ii) HPC* 

- 
3D Script-writing and HPC job submission 

 

* Tutorial 15 is optional and is not required to complete the module 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 1: CFD Basics – Lid-Driven Cavity (i) 

 

Introduction  

The purpose of this and the subsequent tutorials is to introduce new users to the main concepts of Computational 

Fluid Dynamics (CFD). You should have access to the ANSYS suite of CFD software to enable the analysis of fluid flow 

problems. These tutorials will guide you through the basics of applied CFD using a series of examples which 

progressively increase in complexity. By the end you should be comfortable running basic CFD simulations with an 

understanding of what the various schemes and models do. The procedures and techniques which you will learn are 

equally as applicable to more complicated problems, including your coursework assessments. 

 

Tutorial 1 Outline: 

• Familiarisation with ANSYS software layout and operation 

• Create a basic geometry for the lid-driven cavity 

• Mesh the geometry using various schemes and sizes  

• Export a coarse and a fine mesh for use in Tutorial 2 

 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Open ANSYS Workbench via the Windows start button: In the 

“Search programs and files” field, type “Workbench” then LC 

on the Workbench 2020 R2 icon (Alternatively you can find 

the program in: All Programs → ANSYS 2020 R2 → Click on 

the icon for Workbench 2020 R2).  (Please do not open 

ANSYS AIM, this is not the correct package to complete this 

tutorial).   

 

Wait for the program to load and you will see a window like 

the one below. Note: If the ANSYS Product Improvement 

Program window (shown below) pops up, close the window 

so that you can see only the Workbench window which can 

be seen in Step 3 below.  

 

 

 
 

 

2) You will see the Toolbox on the left side of this window. Depending on the way ANSYS is configured on 

your computer, you should expand Component Systems by clicking on the (+) symbol so that it becomes 

(-) i.e.  

 

3) Similarly, hide the programs under Analysis Systems:                                      See next page. 
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4) Workbench is the program which contains all the details of your model including the geometry, the mesh and the 

CFD results. There are different ways you can model fluid flow within Workbench. You can use a Fluid Flow System 

under Analysis Systems, however, the best way to illustrate the basics is to use the sub-programs. In this tutorial 

you will be using the following three sub-programs: 

a. Design Modeler  – used for geometry creation 

b. Ansys Mesh – used to split up the geometry into a mesh of cells or elements upon which to compute 

solutions 

c. Fluent – the CFD solver which calculates the solution to the engineering problem of interest 

 

 

5) Under Component Systems LC and hold 

the mouse button on the Geometry icon 

and drag across into the top left region 

of project Schematic (you should see a 

red box appear and “Create standalone 

system”) then let go of the mouse: 

 

 

 

 

 

Toolbox 

Component systems 

 

 

Fluent (CFD solver) 

Geometry (CAD generation) 

 

 

 

Mesh (meshing) 
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6) On row 2 of the new geometry box, RC then LC on New DesignModeler Geometry which appears in a menu:  

 

7) This launches Design Modeler. If you are prompted, select metres as the working unit. You should now see a larger 

version of this window: 

 

 

Note the geometry selection filters (1), the view manipulation tools (2) and the triad (3) – you will be using 

these frequently in this program.  

 

 

 

 

 

 

 

 

1 2 

3 
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8) In the Tree Outline box on the left of the window, LC on the XYPlane → LC on sketching tab at the bottom of the 

Tree Outline box → LC Settings → LC Grid → Tick the boxes: Show in 2D and Snap (This draws a grid in the 

graphics window to aid geometry creation) → set Major Grid Spacing to 1m, Minor-Steps per Major to 5.  

 

 

 

 

 

 

 

 

 

 

9) You are going to draw a 2D cavity so you need to view the XY plane. LC on the end of the Triad Z-axis in the bottom 

right corner of the graphics window. Now zoom in by moving the mouse wheel (middle button on your mouse). 

Alternatively you can click on the Zoom Box   → LC and hold the mouse button in the top left, drag and drop 

in the bottom right. Or, you can use the mouse wheel to zoom in (and out). Keep zooming in until the scale at the 

bottom of the graphics window has a range of 0-1m: 
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10) To draw a 1 m2 cavity, Return to Sketching tab (step 8 above) and LC Draw → LC Rectangle → Move mouse into 

Graphics window and LC on the origin (0,0) to start drawing a square (the cursor should now be a pen) → LC again 

for the top right corner at the coordinate (1,1) (Note: in the bottom right hand corner of the program window, the 

X and Y coordinates are shown next to meter as you move the cursor). You can LC the rotate button  and LC 

in the Graphics window to move the square in 3D to make it easier to see. 

 

 

11) To make a surface from this wireframe click on the Modelling tab (next to Sketching tab shown in step 8) → LC 

on the (+) symbol next to the XYPlane → LC Sketch1 under Tree Outline so that the sketch of the cavity turns 

yellow → on the top menu LC Concept → Surfaces from Sketches → LC Apply (in Details View) → LC the Generate 

button: .  

  

 

 

 

 

 

       

 

(0,0) 

(1,1) 

Coordinates 
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You should see a grey square in the Graphics window and the Tree Outline contains more items in the list, 

including 1 Part. You now have your cavity. (Note: whenever you make any change to the geometry, a yellow 

lighting symbol will appear in the Tree Outline: You must then click the generate button to register the change). 

12) It is recommended that you create a folder called Tutorials to save your work in. LC File → Save Project → Save 

the file as cavity ensuring the format is in .wbpj (Workbench Project Files). Close Design modeler.  

 

13) To mesh the square 

you have just created, 

go back to Workbench 

and LC and hold the 

Mesh icon under 

Component Systems, 

then drag and drop this 

onto row 2 of the 

Geometry box (circled 

below) and ensure that 

a link is present 

between Geometry 

and Mesh: 
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14) RC on row 3 of the new Mesh box → LC Edit… → This will launch Ansys Mesh which is the program for meshing 

your geometry as shown below. Note how the layout of Ansys Mesh is similar to Design Modeler with some of 

the same buttons:      

 

15) This step is VERY important. To change 

the physics preference from the default 

of Mechanical to CFD, in the tree outline 

LC on Mesh -> In the Details box click on 

Physics Preference and change to CFD: 

 

16) LC on the end of the Triad Z-axis in the 

bottom right corner of the graphics 

window to view the cavity in 2D. 

 

17) Ansys Mesh generates a default mesh for 

most geometries. To see this LC:    

 

 

 

 

18) To see the mesh, LC on Mesh in the 

Outline window. You should see a mesh 

of quadrilateral elements covering the 

square: 
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19) To change the elements from quad (squares) to tri (triangles) you need to add a method: RC Mesh → Insert → 

Method → LC on volume selection filter   → LC on the cavity in the Graphics Window so that it turns green 

→ LC once on the yellow box containing the words “No Selection” to the right of Geometry → LC   → 

To change the elements to Triangles LC on the box next to Method → LC on the drop-down arrow and select 

Triangles → LC Generate Mesh  → Wait for the mesh to be created → LC Mesh under the Outline (Note, the type 

of element can now easily be changed using this Method, but remember to click Generate Mesh after each 

change). 
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20) In addition to type of elements used, their sizes are equally important in CFD analysis. It is crucial to cluster smaller 

elements in regions of high flow gradients e.g. resolving the wake behind a vehicle or on the exit of an open jet. 

To cluster cells on one corner of the square cavity: RC Mesh → Insert → Sizing → LC vertex selection filter  

→ LC on one of the four corners of the cavity in the Graphics Window (the vertex at the corner should turn green, 

you may need to zoom in to do this) → LC Apply  next to Geometry under Details of “Sizing” (a purple 

label with Vertex Sizing  should appear in the Graphics Window) → LC on Please Define box next to Sphere Radius 

and set this to 0.1 then click Enter on the keyboard (note the red sphere appear in the Graphics Window – this 

shows where the cells will be refined) → LC on Please Define box next to Element Size and set to 0.02  → Generate 

Mesh → Wait for the mesh to be created → You can LC Mesh under the Outline to see the mesh. 
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21) Clustering the elements along edges is also helpful in resolving flow features near to walls. To do this you must 

first supress the vertex sizing from step (20) above and then add a new sizing for the edges (note you must be 

careful not to use too many mesh controls at once, if you try to use multiple controls which influence the same 

vertices/edges/faces simultaneously, often you will see error warnings): In the Outline Tree RC the existing Vertex 

Sizing → LC Supress  

22) To create edge sizing for all four edges: RC Mesh → LC Insert → LC Sizing → LC edge selection filter  → LC top 

edge of the cavity in the Graphics Window (this should turn green) → press and hold the Ctrl key on the keyboard 

and click on the remaining three edges one at a time (they should all appear green and be added to the selection) 

→ LC Apply  next to Geometry under Details of “Edge Sizing” – Sizing → LC Element Size under Type 

→ LC down arrow, LC Number of Divisions → set to 30 in the box immediately below →  LC on No Bias  under 

Bias Type → LC on the down arrow and select the third bias (arrowed below) to cluster cells in the corners → set 

the Bias Factor to 3 and click enter on keyboard → Generate Mesh → Wait for the mesh to be created → LC Mesh 

under the Outline:  
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Now you have more control over the density of elements so 

that they are clustered in areas where you would expect to 

see notable flow gradients. Try changing the various 

parameters in the sizing box and see how it affects the mesh. 

 

23) An important aspect of meshing is to check the 

quality of the elements. If the elements are over-

stretched then the quality degrades, accuracy is 

compromised and simulations may not even 

converge, giving no solution at all. To check the 

element quality: LC on the (+) symbol next to Quality 

in the Details of “Mesh” box → LC on None to the 

right of Mesh Metric → LC the down arrow and 

select Skewness as the quality metric (you may need 

to use the vertical slider bar to find this option – it is 

near the bottom) → LC the Controls button and a 

quality histogram will appear: 
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(Note: See how the quality of the elements has a distribution; most of them are good [skewness = 0] whereas the 

worst element quality is 0.283 for this particular mesh (your mesh might have a slightly different number – this is 

OK!). It is recommended that the maximum skewness should not exceed 0.90; if your mesh fails this criterion, 

investigate the size controls to identify where the mesh is being stretched too much; this is the most common 

problem when generating meshes e.g. large element spacing on one edge and very small spacing on an adjacent 

edge. Another common error is for the physics preference to be set to mechanical instead of CFD – ensure you 

have followed step (15) as this fundamentally changes the mesh. 

By clicking on Controls you can change the axis ranges and include different types of elements in the statistics (if 

you have more than one element type in a mesh). Be careful, some quality criteria are different to skewness – for 

example Element Quality criteria are the opposite i.e. poor = 0, good = 1). 

 

 

24) File → Save Project. To change the elements to quad type whilst retaining the edge sizes from step (22) → RC 

Mesh → Insert → Face Meshing → LC Face selection filter  → LC on the cavity in the Graphics Window → 

LC Apply  → Generate Mesh → Wait for the mesh to be created → LC Mesh under the Outline → In 

the Mesh Metrics window LC the Controls button → set the X-Axis maximum to 1 → Click the cross to return to 

the histogram: 

Good quality                              Poor quality 
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Notice how the skewness distribution is much better for this quad mesh, this is because the elements are not being 

skewed and rotated, all internal angles per element are 90 degrees, therefore the quality is ≈ 0 everywhere. For the 

previous triangular mesh, the elements were skewed in the corners due to the edge size controls and so the internal 

angles were not equal in some elements. 
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25) Now that you have a mesh, you need to assign boundary conditions which consist of a moving upper wall and 

stationary bottom and side walls. To assign the moving wall → LC edge selection filter  → LC on the top edge 

so that it turns green → RC on the selected top edge → LC Create Named Selection (near the bottom of the sub-

menu) → Enter the name wall-moving in the Selection Name box → OK. Repeat this step, selecting both side 

walls and the bottom wall (whilst pressing the Ctrl key) and name these wall-stationary → LC on the (+) symbol 

next to Named Selections in the project Outline to see the list of boundary conditions: 
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26) The final step is to export a coarse and a fine mesh for use in Tutorial 2. For the coarse mesh keep the Mapped 

Face Meshing scheme → LC the Edge Sizing in the Outline menu → change the Number of Divisions to 8 → keep 

the bias factor at 3 → LC Generate Mesh → Wait for the mesh to be created → LC Mesh under the Outline → To 

export the mesh click File → Export → Mesh → FLUENT Input File → Export → You will then see the Save As 

menu box, set the file name to ldc-8x8 (i.e. lid-driven cavity with 8 by 8 elements) → You may wish to select a 

folder to save the file in → Save. Repeat for another (fine) mesh, keeping all settings the same except the number 

of elements which should be 32 and the filename should be ldc-32x32. The two meshes are shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Coarse Mesh (8x8)                  Fine Mesh (32 x 32) 

27) In your own time, try experimenting with various mesh schemes and biases. 

28) Save the project, then close Mesh and Workbench.  
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Tutorial 1 Summary:  

You have:  

• Followed the basics of geometry creation and meshing 

• Implemented structured and unstructured meshes 

• Incorporated meshing controls to vary the element density 

• Investigated element quality 

• Set appropriate boundary conditions 

• There is no task for this tutorial 

 

 

End of Tutorial 1 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 2: Lid-Driven Cavity (ii) Simulations and 

Postprocessing 

 

Tutorial 2 Outline: 

• Requires your two meshes from Tutorial 1 

• Read each one into FLUENT and set up case files 

• Run a laminar flow simulation at a Reynolds number of 100 

• Basic post-processing of the results 

• Compare both results with benchmark solutions by Ghia et al., 1982 

• Complete TASK 1  

 

Prerequisites  

1) Ensure that you have completed Tutorial 1 which taught the basics of CFD pre-processing. You will also be 

using the two mesh files you created in that tutorial.  

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Now that you have completed the 

pre-processing required in Tutorial 1, 

you can use the coarse mesh to set up 

your first simulation. Open FLUENT 

2020 R2 via the Windows start 

button: In the “Search programs and 

files” field, type “Fluent” then LC on 

the Fluent 2020 R2 icon 

(Alternatively you can find the 

program in: All Programs → ANSYS 

2020 R2 → Fluent 2020 R2). When 

the Fluent Launcher appears, select 

Solution, 2D, Double Precision and 

Display Mesh After Reading → Start: 

 

 

2) Read in the coarse mesh: File → Read → Mesh → Select your mesh file ldc-8x8.msh from your Tutorials folder 

→ OK: 

 

  
By launching Fluent in double precision mode, all calculations will be made using 16 significant figures instead of 

the reduced accuracy of 8 significant figures. Using double precision minimises round-off error.  

Now that your mesh file has been read into Fluent, all the models and numerical schemes can be set up by 

progressively moving down the Outline View on the left as well as the Task Page which reveals more options for 

each item selected in the Outline View. It is also possible to set many options using the menus at the top of the 

window. Fluent is a CFD solver and a postprocessor. You will learn more about its capabilities as you complete 

these tutorials. 

 

Menus 
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3) Next you need to check the scale of the mesh to ensure you are solving the flow inside a 1m x 1m square: LC the 

Domain menu → LC on the Scale… button in the Mesh sub-menu → Check that the domain extents are 0 - 1 m in 

the Scale Mesh menu box for both X and Y coordinates:  

 

 

 

 

 

 

 

• If the Domain Extents have incorrect units, click on the down arrow under Mesh Was Created In and LC 

on the appropriate units (in this case, metres).  

• If the scale is incorrect, LC on Specify Scaling Factors and set these manually e.g. if your domain extents 

are 0 – 1000 m, set scaling factors to 0.001 → LC Scale) (Note: ALWAYS check the scale of your mesh, 

incorrect scale selection is a common mistake for new CFD users).  

• If the scale is correct, but your origin is in the wrong location (i.e. not 0,0) LC on the Transform button in 

the Domain menu → LC Translate… → specify appropriate Translation Offsets → LC Translate.  

 

 

4) Change the Viscous model to Laminar: Setup → Models → Double click on Viscous → In the Viscous Model menu 

LC Laminar → OK: 

 

 
 

5) Next, you need to set a translational velocity of 1.4607e-03 m/s to the moving wall (this produces a Reynolds 

Number of 100, which represents a laminar flow regime). In the Outline View LC on the (+) symbol next to 

Boundary Conditions → LC on the (+) symbol next to Wall → Double-click on wall-moving → when the Wall 

boundary condition window appears → select Moving Wall → set Speed = 1.4607e-03 → ensure that the 

translational direction x = 1 and y = 0 → Apply → Close 
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Note: since the lid-driven cavity problem is governed entirely by the motion of the top surface (the lid) all the other 

boundary conditions are defined; by default, the other walls are stationary with the no-slip condition applied.  

 

6) Now that the boundary conditions are 

defined, the next step is to initialise the 

solution in preparation for running the 

simulation. Double-click on Initialization 

which is listed under Solution in the 

Outline View (you may wish to click on  

(-) next to Setup for clarity) → in the 

adjacent Task Page LC Standard 

Initialization → LC down arrow next to 

Compute From → LC wall-moving → LC 

Initialize button at the bottom. If you 

see the message “The current data has 

not been saved. OK to discard?” LC OK 

 

7) Now that the simulation is ready to run, 

you must save a case file. The case saves 

all of the options you have set in Fluent 

so that you can come back to your 

simulation and change parameters and 

models. File → Write → Case → locate 

the directory you are saving to (e.g. 

Tutorials) under Directories → under 

the Case File box enter the name of the 

file as ldc-8x8.cas.h5.  

 

Note: .cas.h5 is the new case file extension format for ANSYS version 2020 or later. This type of extension allows 

the data to be read into different post-processing programs such as Ensight, however, Fluent will be used here.  
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8) To run the simulation: Double click on Run Calculation… in the Outline View → using the keyboard, set Number 

of Iterations to 1000 in the Task Page → Calculate (if the solution converges after 1 iteration, please click the 

Calculate button again; this is apparently a bug in ANSYS Fluent V2020 R2). The simulation will take only a few 

seconds to run in under 40 iterations and you should see a message indicating that the calculation is complete. 

Another message in the console states that the calculation is complete as well: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The plot shown illustrates the Scaled Residuals which are a measure of the error in the solution. Since an iterative 

numerical scheme is employed, the errors progressively reduce in magnitude as the number of iterations 

increases and the solution approaches. The box Calculation Complete indicates that the errors have dropped 

below the default convergence tolerance of 0.001; this will be discussed in more detail in later tutorials.  

 

9) Save the simulation data: File → Write → Data → locate the directory you are saving to (Tutorials) → under the 

Data File box enter the name of the file as ldc-8x8.dat.h5  

 

 

 

 

 

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               23 
 

10) The next stage is to postprocess the results. To show static pressure contour plots → Expand Graphics under 

Results (close to the bottom of the Outline View) and double click on Contours → after the Contours window 

appears select Banded under Coloring → LC Colormap Options → In the Colormap menu change the Colormap 

Size to 20 → LC Apply then LC Close to close the Colormap menu → LC Save/Display in the Contours window → 

The contour plot of static pressure will be visible. You can click on the colourmap and resize it for clarity: 
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11) In the Contours window select contours of Velocity… and ensure Velocity Magnitude is selected immediately 

below → Save/Display. You should see a contour plot which is the same as the ‘Standard contour plot’ shown 

below. This clearly shows that the velocity of the fluid is highest near the top of the cavity (the ‘driven lid’) which 

has a sideways translational velocity (you specified this in step 5). Although this looks physical, the interpolation 

used by the standard contours disguises a poor solution. LC on the box to the left of Node Values to deselect it in 

the Contours menu. Displaying the contours this way shows the actual solution i.e. one numerical value for velocity 

per cell: 

 

 

 

 

 

     

 

12) Now read in the fine mesh: File → Read → Mesh… → Select the option Discard Data, Replace Mesh (this retains 

all the solver settings from the first simulation, but replaces the mesh) → LC Continue… → Locate the fine mesh 

file ldc-32x32.msh → OK: 

 

 

 

 

 

 

 

 

13) Save a new case file which is the same as the previous one, only with a finer mesh. Name the file ldc-32x32.cas.h5 

→ Repeat step (6) to initialise the solution for the larger mesh then repeat step (8) to run the fine mesh simulation 

which will take about 10 seconds to run in around 32 iterations. Save the data file as ldc-32x32.dat.h5.  

 

 

 

 

Standard contour plot Contours of the actual node values 
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14) Display contours of velocity magnitude using both the standard contours and node values. You may need to change 

the number of colormap levels (recall step 10) to 20 because these may default to 100 – feel free to change this 

number to see how different the solution looks depending on the number of bands in the colourmap. You should 

see the following comparison which illustrates how a much finer mesh resolution resolves the flow field in a more 

appropriate level of detail, compared to the 8 x 8 mesh. In later tutorials you will be exploring the concept of grid 

independence (also known as mesh independence) which is essential to obtain accurate solutions.  

   

15) Another way to check the accuracy of a numerical solution is to compare quantitative data against either 

experimental or analytical data. The lid-driven cavity is a simple geometry so comparisons can be made between 

your CFD results above and benchmark analytical results. In the following steps, you will be plotting velocity 

profiles and comparing with the data in: Ghia, U., Ghia, K.N. and Shin, C.T. High-Re Solutions for Incompressible 

Flow Using the Navier-Stokes Equations and a Multigrid Method, Journal of Computational Physics, 48, 387-411, 

1982. Find a copy of this article online (search using the authors names, they are unique enough to locate the 

article) and observe the data in Table I and II in the paper; in a later task you will need to plot the data at Re = 100. 

 

16) Create a vertical line passing through the centre of the cavity: LC on the Results tab at the top of the window → 

under Surface LC Create → Line/Rake… → when the Line/Rake Surface menu box appears set the End Points of 

the line to be (0.5,0.0) and (0.5,1.0), as shown below → Also set the New Surface Name to vertical-line → Create: 
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17) Repeat for the horizontal line which has coordinates of (0.0,0.5) and (1.0,0.5). Name the surface horizontal-line. 

 

18) To show the horizontal velocity profile: LC on the Results tab → XY Plot → Edit… → when the Solution X Y Plot 

menu box appears check that the Plot Direction vectors are set to be X=1 and Y=0 → Select the Y Axis Function 

as Velocity and Y Velocity → Highlight horizontal-line (created in step 17) from the list of Surfaces → Plot: 

 

 

19) The plot can be altered to make it easier to see: LC Curves… at the bottom of the Solution X Y Plot menu box → 

when the Curves - Solution XY Plot menu box appears, under Line Style change the Pattern to --- → under Marker 

Style change the Symbol to o and the Color to foreground → Change the Size to 0.5 → Apply → LC Plot again in 

the Solution X Y Plot menu box: 

 

 

 

 

 

 

 

 

 

Note: You can experiment with the Curves settings to customise your plots and make them easier to interpret; 

default settings are not always the best ones to use. 
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20) To export the data for use in a spreadsheet, click on the Write to File box under Options in the Solution XY Plot 

menu box → Click the Write… button (previously this was the Plot button) → Name the file v-profile-32x32 → 

OK. 

 

 

21) Repeat steps (18) and (20) to plot and the export the X velocity data along the vertical line, being careful to change 

the Plot Direction so that X=0 and Y=1. Call the data u-profile-32x32. 

 

22) Save the case file again, over-writing ldc-32x32.cas.h5 (recall step 13). The new case file will now contain the two 

lines you have created in the previous steps; if you do not save the case file, the lines will not be saved. 

 

23) Read in the case and data file for the coarse simulation which you ran earlier (ldc-8x8.cas.h5 and ldc-8x8.dat.h5). 

Repeat steps (15-20) to generate the vertical and horizontal velocity profiles for the 8 x 8 mesh.  

 

24) Now that you have all four profiles (two per mesh), import these into Excel. To do this: Open Excel → File → Open 

→ Select File Type as “All Files (*,*) → Locate one of your profiles e.g. u-profile-32x32 → Open →  When the Text 

Import Wizard Opens click Next → tick the box next to Space → click Next → Finish. You will now see some text 

above two columns of data, one for position, the other for velocity. You will need to individually open each data 

set and copy the data into a separate Excel file containing all four profiles.  

 

25) Plot the profiles and observe the difference between the fine and coarse solutions.  

 

➔
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26) Before closing Fluent, open the fine case and data file and explore other visualisation tools. Try to generate a 

vector plot and an open contour plot of the stream function to compare with the qualitative results shown in the 

journal article described in step (15): 

      

27) Close Fluent.  

 

 

TASK 1 

 

Using the data you have obtained in this tutorial, please complete the following task. This task may take some time 

but you only need the velocity profiles and a spreadsheet. Carry out the following: 

 

a. Plot the velocity profiles for Re = 100 shown in Tables I and II in the journal article mentioned in step 15 

above (Ghia, U., Ghia, K.N. and Shin, C.T. High-Re Solutions for Incompressible Flow Using the Navier-

Stokes Equations and a Multigrid Method, Journal of Computational Physics, 48, 387-411, 1982.), noting 

that: 

i. The horizontal and vertical velocities are actually presented as normalised values i.e. they are 

divided by the velocity of the lid (this isn’t immediately clear from reading the article).  

ii. The authors only provide selected data points in Tables I and II so the comparison to your CFD 

data is only valid in those regions. Therefore, you should plot these selected data points as a 

scatter plot, without a line connecting them.  

b. In order to make a valid comparison with your CFD data, you will need to normalise the u and v profiles 

which you obtained previously. Do this by dividing the velocities by uref which is the velocity of the lid i.e. 

1.4607 e-3 m/s. 

c. Plot your CFD data as a scatter plot with lines connecting the points. By only showing the lines, it is easier 

to see the data points from Ghia et al., 1982.  

d. How do your results compare? Which is your most accurate mesh? Think about these questions and 

discuss with a demonstrator if you have any doubts. 
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Tutorial 2 Summary:  

You have:  

• Set up a basic flow simulation with appropriate boundary conditions 

• Post-processed the result qualitatively using contour plots 

• Exported flow data and compared with existing benchmark results 

 

End of Tutorial 2 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 3: Backward-Facing Step (i) 

 

 

 

 

Tutorial 3 Outline:  

• Create basic geometry for the backward facing step 

• Explore the dimensioning tools to parameterise the geometry 

• Generate a suitable mesh with relevant cell size controls 

• Run a turbulent flow simulation 

• More advanced post-processing exercises 

 

Prerequisites  

1) Ensure that you have completed Tutorial 1 and 2 which cover the basics of CFD pre and postprocessing. 

 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Open ANSYS Workbench 2020 R2  

2) As you did in Tutorial 1, under Component Systems LC and hold the mouse button on the Geometry icon and drag 

across into the top left region of project Schematic (you should see a red box appear and “create standalone 

system”) then let go of the mouse → To open Design Modeler, RC in row 2 of the Geometry box and LC New 

DesignModeler Geometry… 

 

3) Set the units to mm: LC the top menu Units → select Millimeter  

 

4) In the Tree Outline LC on the XYPlane → LC on sketching  tab at the bottom of the tree outline box → LC Settings 

→ LC Grid → Tick the boxes for Show in 2D and Snap (This draws a grid in the graphics window to aid geometry 

creation) → set Major Grid Spacing to 25 mm, Minor-Steps per Major to 5.  

 

5) LC on the end of the Triad Z-axis to view the XY plane. 

 

6) LC in the graphics window and rotate the mouse wheel forwards or backwards to change the zoom level → zoom 

in on the origin → Keep zooming in until the scale at the bottom of the graphics window has a range of 0-100 mm: 

 

➔

Origin 
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7) Next, you will draw a 2D backward-facing step from the following combination of points: 

 

 

 

 

 

 

 

8) LC Sketching tab under Sketching Toolboxes → LC Draw → LC 

Polyline → Move mouse into Graphics window and LC on the 

origin (0,0) to draw the first point. LC for each of the following 

points (the coordinates can be seen in the bottom right corner 

of the program) in this order: 

(-100,0), (-100,25), (0,25), (100,25), 

(100,0), (100,-25), (0,-25) 

 

To complete the shape, RC on the origin and select Closed End.  

 

 

 

 

 

 

 

 

 

 

 

 

9) To make a surface from this wireframe → LC Modeling tab in the Tree Outline → LC on the (+) symbol next to the 

XYPlane → LC Sketch1 → on the top menu LC Concept → Surfaces from Sketches → LC Apply under Details View 

→ LC the Generate button:  → You should now see the correct shape in the Graphics window. 

(Remember: whenever you make any change to the geometry, a yellow lighting symbol will appear in the Tree 

Outline: You must then click the generate button to register the change). 

 

 

 

 

 

 

10) File save project → Save the file as backstep in a suitable folder (e.g. Tutorials folder). 

 

 

                   A                                         B 

H                                                                                                                  C 

 
                   G                                                                                               D 

 

                   F 

Origin 

                     E 
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11) Next, you will add a dimension to the sketch to change the length of the shape: LC → Sketching tab under Tree 

Outline → LC Dimensions → LC General → Move the mouse into the Graphics window and position over the 

bottom edge (edge E from step (7)) until it changes colour → LC and a pencil should appear, now move the mouse 

downwards and LC below the shape. (Notice that a green dimension with the label H1 appears). LC again on edge 

(G) to add a further dimension, H2:  

            

12) In the details view you will now see Dimensions H1 and H2. Click on the text boxes and change these to: H1 = 300 

mm and H2 = 150 mm → Generate → File, Save project → File, Close DesignModeler. If you make a mistake and 

select the wrong edge, you can delete a dimension by right-clicking on the dimension in the list under the Details 

View menu box → Delete. 

 

Note how the geometry has changed by supplying new dimensions. This can be extended to other shapes to give     

full parametric control over various dimensions. However, be careful not to over-constrain the problem: using too 

many dimensions can lead to conflicts between dimensions.  

 

Edge E 

Edge G 
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13) To mesh this shape, go back to Workbench and LC and hold the Mesh icon under Component Systems, then drag 

and drop this onto row 2 of the Geometry box and ensure that a link is present between Geometry and Mesh: 

 

14) RC on row 3 of the new Mesh box → LC Edit… → This will launch Ansys Mesh. LC on the Z-Axis of the triad to view 

the step from the side. Change the physics preference from the default of Mechanical to CFD, in the tree outline: 

LC on Mesh → In the Details box click on Physics Preference and change to CFD → LC Generate Mesh → Wait for 

the mesh to be created → LC Mesh under the Outline. You will see an initial Cartesian mesh:  

 

15) Clearly, this default mesh is far too coarse to adequately resolve fluid flow. However, because the shape was 

created with a total of 8 edges, it is possible to control the mesh size with edge controls. RC Mesh under Outline 

→ LC Insert → LC Sizing → LC edge selection filter  → LC on edge H (see step 7) in the Graphics Window  (this 

should turn green) → press and hold the Ctrl key on the keyboard and click on edges F, C and D one at a time (they 

should all appear green) → under Details of “Sizing” - Sizing, next to Geometry LC No Selection (highlighted in 

yellow) → Apply  → LC Element Size under Type → LC down arrow, LC Number of Divisions → set to 16 in the 

box immediately below → LC Bias Type, LC on the down arrow → LC on the bias which clusters the cells at the 

ends of the edge (recall step 20 from Tutorial 1) → set bias factor to 3 → LC Generate Mesh  → Wait for the mesh 

to be created → LC Mesh under the Outline: 

➔



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               35 
 

 

16)  The revised mesh is an improvement but now the elements are squashed (skewed) in the corners. As the shape 

is simple, a better solution is to use Face Meshing which consists of a Cartesian grid. RC Mesh under Outline → 

Insert → Face Meshing → LC Face selection filter  → LC on the shape in the Graphics Window → LC Apply  

→ Generate Mesh → Wait for the mesh to be created → LC Mesh under the Outline: 

 

 
 

Note that the mesh is only controlled in the Y-direction because of the controls implemented in step (15) above; 

in the X-direction there are no controls and so the mesh is skewed. 

 

17) Before inserting more edge controls, rename the sizing from step (16): LC on Edge Sizing in the Outline → RC → 

Rename → Enter y-sizing (Note: you should use a continuous name without spaces or symbols): 

 

18) Repeat steps (15) and (17) to insert another edge control and apply to edges A and G. Ensure that the sizing is 

clustered at the righthand ends of the edges (you may need to apply the Reverse Bias option if an edge bias is 

clustered at the wrong end). If you make a mistake, you can delete the bias in the Outline tree by RC on the sizing 

and LC Delete. Set the number of divisions to 50 and a bias factor of 3. Rename the new sizing as x-sizing-

upstream and Generate the mesh; this changes the mesh in the inlet region of the shape: 
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19) The mesh still requires control in the X-axis from the step to the outlet on the right. Add another edge control and 

apply to edges B and E → Ensure that the sizing is clustered to the left: 

 → Set the Number of Divisions to 100 and a Bias Factor of 5. 

→ You will notice that the bias on edges B and E are in opposite directions, therefore you must click on Reverse 

Bias then select edge E → Apply → Rename the sizing to x-sizing-downstream. → Generate:   

 

 
 

Note how the mesh is now fully controlled using the edge controls applied in the steps above. This was made 

possible by creating the geometry using strategically placed points (step 8) which ensured that the following pairs 

of edges were the same length: H and C; F and D; A and G; B and E. 

 

 

 

 

 

 

 

 

➔

➔

➔
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20) For the final meshing stage change the number of divisions to 18 for y-sizing, 100 for x-sizing-upstream and 200 

for x-sizing-downstream → Generate mesh → Repeat step (23) from tutorial 1 to check that the quality of the 

mesh is very good with zero skewness: 

 

 

21) Now that you have a mesh, you need to assign boundary conditions which will consist of an inlet, an outlet and 

walls. To create the inlet → LC edge selection filter  → LC on edge H so that it turns green → RC on the selected 

edge → LC Create Named Selection (N)… (at the bottom) → Enter the name inlet in the Selection Name box → 

OK: 

           

22) Repeat step 21 to create an outlet for the two edges (C and D) ensuring that you hold the Ctrl key to add both 

edges to the selection. Name the selection outlet. 
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23) Create another named selection called walls for all the walls (edges A, B, G, F and E).  

 

24) To check that your boundary conditions are correct → LC on the (+) symbol next to Named Selections → Hold the 

Ctrl key before selecting them: 

 

 

 

 

 

 

         

25) To export the mesh file click File → Export → Mesh → FLUENT Input File → Export → You will then see the Save 

As menu box, set the file name to backstep-1 → You may wish to select a folder to save the file in → Save. Save 

the project and close both Mesh and Workbench.  

 

26) Open Fluent in 2D and Double Precision mode and read in backstep-1.msh.  

 

27) Next you need to check the scale of the mesh to ensure you are solving the correct problem: LC on the Scale… 

button in the Mesh sub-menu under Domain → Check that the domain extents are the same as those shown 

below → Close: 

 

 

 

 

 

 

 

 

 

28) For convenience, the base of the step should be at the 

origin so you need to translate the grid upwards by 0.05 

m: LC Transform → Translate… → insert a Translation 

Offset of 0.025 for Y (m) → Click Translate ONCE and note 

the change in domain extents: 

 

 

➔
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29) In the previous tutorial, you solved a laminar flow case, however in this example you will be simulating turbulent 

flow with a moderately high Reynolds number; air will enter the inlet and spill over the step with the sudden 

expansion at the step inducing flow separation and recirculation behind it. Since the flow is known to be 

turbulent, you need to activate a turbulence model: In the Outline View LC Setup → expand Models → double 

click on Viscous models → when the Viscous Model menu appears, select the k-epsilon (2 eqn) option → OK: 

 

Note that there are three types of k-ε model including the standard k-ε model (selected above), the RNG 

(Renormalized Group Theory) k-ε model and the Realizable k-ε model. Other models are also available including 

k-ω models, Spalart-Allmaras and Reynolds Stress models; these will be explored in later tutorials. A number of 

transitional models also appeared in ANSYS Fluent in about 2016 but these are not explored here. For now, you 

should appreciate that there are a wide range of turbulence models and it is essential to choose appropriate ones, 

depending on the application.  

 

30) With the turbulence model activated the next step is to set the boundary conditions on the inlet and outlet: In the 

Outline View collapse Models and expand Boundary Conditions → double click on the inlet boundary condition 

→ when the Velocity Inlet menu appears, enter 40 in the Velocity Magnitude (m/s) box → Click on the down 

arrow next to Specification Method → select Intensity and Hydraulic Diameter → Enter values of 5% for 

Turbulent Intensity and 0.0476m for the Hydraulic Diameter → OK: 
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Note: both the turbulence intensity, TI, and the hydraulic diameter, DH, are parameters which provide a small 

amount of turbulence on the inlet. In real fluid flows, turbulent fluctuations are often present on entry to a 

particular region and so you should use appropriate values of TI and DH depending on your application. You can 

also specify other parameters instead such as the turbulent length scale, it all depends on the boundary condition 

information you have available prior to running your simulation(s). 

31) Repeat step 30 to set the outlet boundary condition: when the Pressure Outlet menu appears leave the Gauge 

Pressure (pascal) as 0 pa → change the turbulence Specification Method to Intensity and Hydraulic Diameter → 

Enter values of 5% for Backflow Turbulent Intensity and 0.0476m for the Backflow Hydraulic Diameter → OK: 

 

32) In Tutorial 2 you used the default parameters in Fluent, which are designed to handle a wide range of flows. 

However, many of these settings are not always suitable. An important aspect is the order of discretisation used 

by the solver. To view the default schemes: expand Solution in the Outline View → double click Methods → 

Change the schemes to Second Order Upwind for Turbulent Kinetic Energy (k) and Turbulent Dissipation Rate 

(ε):   

 

 

      
 

By default, second order schemes are already selected for the pressure and momentum equations. However, for 

any additional models you select (e.g. turbulence model or species transport) the default discretisation schemes 

are typically first order. The higher the order, the more accurate your solution will be. The drawback with higher-

➔

Default schemes 
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order schemes is that they can be less stable. In general, second order simulations are accurate enough for most 

engineering applications. If your simulation struggles to converge, you can start with first order discretisation then 

switch to second order (or higher) once the residuals have dropped sufficiently.    

 

33) You should also change the Gradient method from the default of Least Squares Cell Based to Green-Gauss Cell 

Based which is also found under Solve → Methods:  

 

The gradient method computes velocity derivatives, secondary diffusion terms and it constructs scalar values at 

cell faces during a given simulation. Of the three methods available, the Green-Gauss Cell Based method is suitable 

for structured hexahedral meshes (as above), the Green-Gauss Node Based method is suited to unstructured 

tetrahedral meshes and Least Squares Cell Based is best for polyhedral meshes. 

 

34) Initialise the solution (recall step 5 in tutorial 

2): Solution → double click Initialization → 

LC Standard Initialization → LC down arrow 

next to Compute From → LC inlet → LC 

Initialize button at the bottom. 

 

35) Save the case file: File → Write → Case → 

save the file as backstep-1.cas.h5 in your 

Tutorials folder. 

 

 

 

 

 

 

 

 

 

 

36) Run the simulation: Solution → Run Calculation → set Number of Iterations to 1000 by clicking in the appropriate 

box and typing 1000 on the keyboard → Calculate → The simulation will take around 1 minute and it should stop 

in the range 40-45 iterations (the exact number can vary depending on the computer):  
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37) Although the calculation is complete, the default residual tolerance of 0.001 is used to stop the calculation once 

continuity, x-velocity, y-velocity, k and epsilon residuals have dropped below this value. It is good practice to drop 

these tolerances: expand Monitors under Solution in the Outline View → double click Residual → in the Residual 

Monitors menu box Change the Absolute Criteria for all quantities from 0.001 to 1e-16: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               43 
 

38) Continue the simulation with revised convergence criteria:  Solution → Run Calculation → set Number of 

Iterations to 300 → Calculate → Wait for the simulation to stop, this will be when ~350 iterations have taken 

place: 

 

 
 

Notice that the solution is converged when the residuals have levelled off i.e. no change in the solution for further 

iterations. In this case, convergence has occurred after approximately 275 iterations; the residuals may be 

oscillating due to numerical noise but they are not reducing as they do earlier in the simulation.  

 

Where possible, it is good practice to lower the residual tolerances (step 37) and run the solution until the residuals 

have levelled off. Note that for complex 3D problems this can be take 1000’s of iterations which take many hours 

to complete.  

 

It is also good practice to use monitors to show how certain parameters vary as the solution progresses. For 

example, you may want to monitor the pressure drop through a pipeline or the drag coefficient of an object. This 

aspect will be covered in later tutorials.  

 

  

39) Having run the simulation, you need to save the data. File → Write → Data → save as backstep-1-k-epsilon-2nd-

order.dat.h5 (Be specific with your data files names so that you remember what settings were used) 

 

 

 

 

 

 

 

 

 

 

Solution is converged after 

~275 iterations because the 

residuals have levelled off  

Solution is NOT 

converged – it is still 

changing here! 
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40) Display the contours of the X-Velocity: Reduce the size of the Setup and Solution menu’s in the Outline View by 

clicking on the (-) symbols → expand Results and Graphics → double click on Contours → in the Contours menu 

ensure that Filled is selected → Select contours of, Velocity, X-Velocity → select Banded under Coloring → LC 

Colormap Options → In the Colormap menu change the Colormap Size to 20 → LC Apply then LC Close to close 

the Colormap menu → LC Save/Display in the Contours window Save/Display: 

 

 

 
 

 

 

 

 
 

Notice how the X-Velocity (i.e. horizontal component of velocity) is negative behind the step; this is because the 

air has separated as it has flowed over the abrupt step and a recirculation region exists with flow opposing the 

free-stream direction.   

 

41) As shown earlier in step 13 of Tutorial 2 it is very important to be aware that by default, Fluent displays contours 

with smoothing and interpolation. In reality, your solution only has one value for each flow parameter (velocity, 

pressure etc.) inside each computational element. To display the element values for X-Velocity: Open the Contours 

window again and deselect Node Values under the Options field → Display. If you now zoom in on the step using 

either the zoom button  or your mouse wheel. The image on the next page shows the difference between the 

default contours node values. To overlay black grid lines see the next step.  
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Be careful when investigating your solution, particularly in regions of high flow gradients, the default contour plots 

do not always show the true solution. Although the solution may look reasonable, your grid may be too coarse 

which is why you should conduct a grid independence study, this will be considered in later tutorials. 

 

42) To overlay black grid lines: Select Draw Mesh under Options in the Contours box → The Mesh Display box will 

appear → Ensure that Edges is selected under Options and All is selected under Edge Type → LC on the Colors... 

button → In the Mesh Colors box LC interior under Types → LC black under Colors → Close the Mesh Colors box 

→ LC Display in the Mesh Display box followed by Close → LC Save/Display in the Contours box: You should now 

have black grid lines overlaid on the contours as shown in the previous step, you may need to zoom in on the step 

to see this.  

 

 

 

 

 

 

 

 

Default contours (20 levels) with 

smoothing and interpolation 

Element values (20 levels) showing 

the ACTUAL solution with grid lines. 
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43) Display velocity vectors: Results → double click Vectors → in the Vectors window change the Style to filled-arrow 

→ change the Scale to 0.003 → click on Vector Options → In the Vector Options menu select the Fixed Length 

option and LC Apply → LC Save/Display in the Vectors window: 

 

 
 

There are many different ways to display vectors so feel free to explore the different options above. If a large 

range of velocities exists then then some options are not suitable and it takes practice to perfect visualisation.  

 

44) Display pathlines which are released from the inlet and coloured by static pressure: Double click Pathlines in the 

Outline View → in the Pathlines menu Select inlet under Release from Surfaces → Select Pressure under Color 

by → Change the number of Steps to 1000 → Save/Display:  

 

         
 

 

 

 

Separation point Reattachment 

Reattachment length, L 

Step 

height, H 

1000 
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Notice how the pathlines are released from the nodes on the inlet face and they indicate where the air flows 

through the domain. The flow can clearly be seen to separate at the top of the step and reattach on the bottom 

wall further downstream. 

 

Steps (40-44) show some of the qualitative visualisation tools available within Fluent, however this must be 

balanced with quantitative analysis. Accordingly, the reattachment length, L, is usually expressed in dimensionless 

form relative to the step height, H. The following reference (B. Ruck and B. Makiola, Particle dispersion in a single-

sided backward-facing step flow, Int. J. Multiphase Flow. Vol 14, No. 6, pp. 787-800, 1988) details an experiment 

which was conducted in the 1980’s for which L/H = 8.1 i.e. the reattachment length is 8.1 greater than the step 

height.  

 

45) To determine the reattachment length from your CFD solution, you need to show contours of the X-Velocity with 

a range limited to positive velocities only: In the Outline View, double click on contours-1 (from step 42, you may 

need to expand Contours in the Outline View) → To display the outline of the domain LC on the Draw Mesh 

option → select Edges under Options, Feature under Edge Type and highlight only the inlet, outlet and walls in 

the Surfaces list → LC Display in the Mesh Display menu → In the Contours window ensure that contours of 

Velocity, X-Velocity is selected → LC the Compute button → uncheck the Auto Range button and ensure that 

Node Values is also unchecked → set the value in the Min (m/s) box to 0 → Save/Display: 
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46) Zoom in on the bottom wall in the region where the contours meets it. The exact point where the X-Velocity is 

zero (arrowed above) denotes the reattachment point.  

 

47) To determine the reattachment length L, create a point: Zoom in on the contours near the reattachment point 

(arrowed below) and right click (RC) where the blue contours are in contact with the bottom wall (you will see a 

small black circle to indicate that you have used the probe tool) → Observe the numbers in the Console.  

 

• The coordinates of the point appear in the Probe position line (here, x = 0.17386882m and y ≈ 0m) and 

from this you should be able to calculate L/H ≈ 6.95 recalling that the step height is 0.025m and the origin 

is at the base of the step from when the mesh was translated. Your simulation may have slightly different 

values but please do not be concerned about this, unless your value for L/H is very different to the figure 

above.  

• You will also see “Contour level 0, value in [0, 2.0874615]“ appears on the second line in the console 

window. This is the exact quantity of the X-velocity in the centre of the cell you have selected; the final 

few decimal points of this value can change slightly in different versions of the software. Again, this should 

not concern you unless your quantities are radically different.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: wherever possible, you should seek to validate your CFD results by comparing with equivalent experimental 

data. In the example above, you have compared the reattachment point for a 2D simulation with 3D experimental 

data. 

 

48) Close Fluent unless you are going straight to attempt Tutorial 4.  
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Tutorial 3 Summary:  

You have:  

• Created a basic geometry and meshed it with a structured hexahedral grid 

• Run a turbulent flow simulation with 2nd order discretisation for all flow equations 

• Explored the concept of convergence and simulation stopping criteria 

• Post-processed the result with contour and vector plots as well as pathlines 

• Compared the reattachment length in your simulation to an experimental result (validation) 

• There is no task for this tutorial 

 

End of Tutorial 3 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 4: Backward-Facing Step (ii) 

 

 

 

 

Tutorial 4 Outline:  

• Further post-processing of the simulation result from Tutorial 3 

• Export a series of velocity data profiles and compare to experimental values 

• Complete TASK 2  

 

 

 

Prerequisites  

1) Ensure that you have completed Tutorials 1-3 which cover the basics of CFD pre and postprocessing. 

 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.   

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Launch Fluent 2020 R2 and read in the case and data file from Tutorial 3. You should have named these:  

• backstep-1.cas.h5  

• backstep-1-k-epsilon-2nd-order.dat.h5 

 

2) By using a k-epsilon type of turbulence model, this typically uses a wall function to model near-wall effects which 

is known as a “wall function approach”.  For this to be valid, a dimensionless parameter, the wall y+ value, is 

measured on wall surfaces and it needs to be in the range 30 to 300, ideally close to the lower end of this range. 

To check this: double click on Surface Integrals under Reports in the Results section of the Outline View → In the 

Surface Integrals menu select Vertex Average under Report Type → Select Turbulence and Wall Yplus under Field 

Variable → Highlight walls under the Surfaces list → Compute → You should see a value of ~37 printed to the 

Console as well as in the Surface Integrals menu: 

 

 

 

 

 

 

 

 

 

 

Note that although this is a 2D simulation you are analysing, each line is considered as a surface by Fluent. The 

average y+ value of ~37 is the average of all computational nodes on the walls of the domain. If this value was 10 

for example, this would mean that the first cell height adjacent to the wall would need to be larger and the 

simulation re-run. Evaluating the y+ value acts as a check to ensure that the correct near-wall treatment is used; 

this is absolutely essential for wall-bounded flows and external aerodynamics cases.  

The alternative approach is the near-wall method which requires a much finer grid. Here, turbulence models 

which do not use wall functions (such as the k-omega model) MUST be used. The requirement for these is y+ ≈ 1. 

Again, the y+ value can be checked after the simulation and if it is close to this value then the result is valid. If the 

y+ value is too high (e.g. 7) then you would need to change your mesh to ensure that the first cell height is smaller.  

Conversely, if the y+ value is too small (e.g. 0.2) you would need to increase the first cell height and re-run the 

simulation until the y+ value is in the correct range. This process is usually iterative and is best achieved using 

inflation layers: this is explored in later tutorials.  
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3) Plot the outlet velocity profile: double click on XY Plot under Plots in the Results section of the Outline View → 

in the Solution XY Plot menu, change the Plot Direction so that it has values of X = 0 and Y = 1 → In the Y Axis 

Function field select Velocity, X Velocity → highlight outlet in the Surfaces list → LC Curves… in the Curves - 

Solution XY Plot menu box change Symbol in the Marker Style list to o and set the Size to be 0.5 → Apply → 

Close the Curves menu box → LC Save/Plot in the Solution XY Plot menu and see the resulting velocity profile in 

the main graphics window: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

 

 

 

 

4) Export the data: LC on the Write to File 

button and see that the “Plot” button 

changes to “Write…” → LC Write… → 

save file as outlet.xy.  

 

5) Create a vertical line to plot the velocity 

profile at the step: LC on the Results 

menu at the top of the main window → 

Surface → Create → Line/Rake… in the 

Line/Rake Surface window, change the 

End Points to: x0=0, x1=0, y0=0, y1=0.05 

→ under New Surface Name change the 

name to line-1 → Create: 
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6) Repeat step (5) and create further lines by changing x0 and x1 for each new line. Create lines for x-coordinates (in 

metres) of 0.025, 0.050, 0.075, 0.100, 0.125, 0.150, 0.175, 0.200, 0.225 and 0.250. Label them line-2, line-3 …. 

Line-11 respectively. This will give you 11 lines in total which represent the normalised distance, x/H, ranging from 

0 to 10 in increments of 1. Recall from Tutorial 3 that H is the step height (0.025 m). 

 

7) Ensure that the lines you have created are in the correct location within the domain: LC on the Domain menu → 

Display… → in the Mesh Display menu box LC Internal in the Surfaces list to deselect this (otherwise the interior 

grid will display, making it very difficult to see your lines) → LC Line-surface to highlight your lines → check that 

Edges is selected under Options, and Outline is selected under Edge Type → Display → you may need to use the 

“zoom-to-fit” button, :  

 

 

 

Your lines are shown in white (note that the duct extends downstream to x/H = 12 from the bottom of the step, 

however, the experimental data you will use for comparison is only available up to x/H = 10) 

8) Save the case file which will now contain the lines you have created steps (5) and (6). 
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9) Plot all 11 profiles together by repeating step (3) but ensure that you LC on all of the line surfaces you created 

earlier:  

 

 

Notice how the velocity profiles change along the length of the channel. Line-1 is positioned vertically on the edge 

of the step and the bucket-shaped velocity profile above it is seen. Moving downstream, negative x-velocities are 

evident at the bottom of the channel (behind the step). At a distance of 10 step lengths downstream (line-11), the 

profile (represented by green symbols) is more smeared due to turbulent mixing, with a lower absolute velocity 

peak. It is good practice to export data and plot in Excel/Matlab (or similar) because Fluent has limited options for 

displaying data; the plot above could be much clearer! 

 

10) Repeat step (4) above and export one data file called backstep-1-profiles.xy ensuring that all 11 lines are 

highlighted under Surfaces.  

 

11) Follow step (23) from Tutorial 2 to read this file into Excel. You should see all 11 sets of data spaced out in the first 

few columns → Scroll down to see each line of data which has the x-coordinate (m) in the first column and the x-

velocity (m/s) in the second column. Note that the order of the lines may be unusual but the labels will help you 

identify each series of data.  
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12) Close Fluent 

 

 

TASK 2 

 

Using the data you have obtained in this tutorial, please complete the following task. Plot all 11 profiles in Excel and 

find the maximum value, umax, per profile. Normalise each maximum value by the inlet velocity, u0, which is 40 m/s. 

Plot x/H against umax /u0 and compare with the table of values below which are taken from Figure 10 in the reference: 

(B. Ruck and B. Makiola, Particle dispersion in a single-sided backward-facing step flow, Int. J. Multiphase Flow. Vol 

14, No. 6, pp. 787-800, 1988).  

a. How do your results compare to the experimental data? What are the possible reasons for the differences? 

Think about these questions and ask a demonstrator if you have any doubts. 

 

Ruck and Makiola (1988) Fig 
10 

x/H umax/u0 

0 0.970 

1 0.985 

2 0.985 

3 0.980 

4 0.970 

5 0.940 

6 0.900 

7 0.850 

8 0.780 

9 0.730 

10 0.660 

  

 

 

 

Tutorial 4 Summary:  

You have:  

• Quantitatively post-processed the result of a turbulent flow simulation 

• Created sampling lines to export velocity data to Excel 

• Compared the variation in the maximum positive stream-wise velocity with experimental data 

 

End of Tutorial 4 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 5: External Aerodynamics: NACA0012 (i) 

 

Tutorial 5 Outline:  

• Use vertex data to construct a symmetric NACA0012 aerofoil 

• Produce a tri mesh with local cell refinement and an inflation layer 

• Run a turbulent flow simulation at 0° angle of attack using a RANS turbulence model 

• Monitor critical solution parameters throughout the simulation 

• Compare quantitative results to experimental data 

 

Prerequisites  

1) Ensure that you have completed Tutorials 1-4 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.   

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Open Design Modeler inside Workbench → Save Project and name it NACA0012.wbpj in your Tutorials folder 

 

2) Locate the file NACA0012.txt in MINERVA → MECH5770M → Learning Resources → Tutorials → Support files 

for Tutorial 5, 8 and 12.  

 

3) Import the vertex data: Concept → 3D Curve → LC on the Not Selected box under the Details View (Highlighted 

in Yellow) → LC on the … button → Locate NACA0012.txt as above → Open → Generate → LC on the z-axis on 

the triad in the bottom right corner of the Graphics window → LC on Curve1 in the Tree Outline and zoom in on 

the imported curve which will be situated in the XYPlane: 

 

 

 
 

4) Mirror the curve: Create → Body 

Transformation → Mirror → the 

body filter  should 

automatically be selected → LC 

on the aerofoil line → LC on 

Apply (to the right of Bodies in 

the Details View) → LC on Not 

Selected to the right of Mirror 

Plane (Highlighted in yellow) → 

LC on ZXPlane in the Tree Outline 

→ Apply → Generate:  

 

➔

➔
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5) Create a surface from the curve: Concept → Surfaces From Edges → The edge filter should automatically be 

selected → LC on both edges of the aerofoil (whilst holding the Ctrl key) → Apply → Generate: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6) Supress the Line Body: LC on the (+) next to Parts at the bottom of the Tree Outline → RC Line Body → Supress 

Body (This measure ensures that Ansys Mesh will only see faces; the lines can interfere with meshing): 
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7) Create a rectangle to represent the domain: Zoom out → LC on the XYPlane → under the Sketching tab LC Settings 

→ LC Grid → Select Show in 2D and Snap → Set the Major Grid Spacing to 1m → Press the Enter key on the 

keyboard → LC Draw tab → LC the Rectangle tool → Click twice in two diagonally opposite corners to create a 

box around the aerofoil (any size is acceptable at this stage):  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8) Dimension the bounding rectangle: LC Dimensions → LC Horizontal → LC on the Green Y-Axis arrow near the 

nose of the aerofoil → LC again on the left edge of the rectangle → move the cursor above the box Notice 

dimension H1 which will determine how far the inlet is from the aerofoil: 

 

 

9) Repeat Step (8) using the Vertical dimension option, clicking on the Red X-Axis Arrow and then the bottom of the 

rectangle. This will determine the distance from the bottom of the rectangle to the aerofoil centreline.  

➔
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10) Create two further dimensions using the General dimension to assign the height and width of the rectangle. You 

should have 4 dimensions in total: 

 

11) Change the dimensions in the Details View so that the rectangle is 40m long, 20m high, the distance from the nose 

of the aerofoil to the left edge is 10m and the bottom of the domain is 10m below the aerofoil: 

 

12) LC Generate 

 

13) Create a surface from the sketch to represent surrounding air: Concept → Surface From Sketches → LC on one of 

the edges of the rectangle (it should turn yellow)  Apply → LC on Add Material under the Details View → Change 

to Add Frozen → Generate → The fluid region should turn olive green: 

 

14) Remove the aerofoil surface from the rectangle to define the fluid shape: Create → Boolean → change the 

Operation from Unite to Subtract → LC on the uppermost Surface Body (aerofoil) in the Tree Outline → LC on 

Not Selected next to Tool Bodies → Apply → LC on the lower Surface Body (rectangle) in the Tree Outline → LC 

on Not Selected next to Target Bodies → Apply → Generate → You will now see only one Surface Body in the 

Tree Outline → Zoom in to see the aerofoil-shaped hole in the domain, as required. Be careful not to confuse the 

tool and target bodies otherwise the operation will not work:  

➔
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15) Save Project and Close Design Modeler 

 

16) Link Ansys Mesh to Geometry under the Workbench Project Schematic → Open Ansys Mesh → LC on the z-axis 

on the triad. 

 

17) Insert a bias for both edges which make up the 

aerofoil: Zoom in on the aerofoil → Mesh → RC 

Insert → LC Sizing → LC edge selection filter  

→ LC top edge of the aerofoil in the Graphics 

Window (this should turn green) → press and 

hold the Ctrl key on the keyboard and click on 

the lower edge of the aerofoil (they should both 

appear green) → LC on No Selection next to 

Geometry in the Details box → Apply → LC 

Element Size under Type → LC down arrow, LC 

Number of Divisions → set to 100 in the box 

immediately below →  LC on No Bias under Bias 

Type → LC on the down arrow and select the 

bias to cluster cells at the ends of the edges → 

set the Bias Factor to 10 and click enter on 

keyboard. 
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18) Zoom out so you can see the whole domain 

and create another sizing for the four outer 

edges of the rectangle, specify Element Size 

as 0.5m (you do not need to apply any 

biases). 

 

19) Insert a Mesh Method and set the Method 

as Triangles 

 

20) Set the mesh parameters: LC on Mesh → In 

the Details box click on Physics Preference 

and change to CFD → LC (+) next to Sizing 

and change Use Adaptive Sizing to Yes → 

Set the Resolution to 2 → Under Mesh 

Defeaturing, change the Defeature Size to 

1e-6m → LC Generate Mesh  → Wait for the 

mesh to be created → LC Mesh under the 

Outline: 

 

Note that you can generate a finer mesh by 

increasing the Resolution number so if you 

want more elements, increase that 

parameter. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

➔

➔
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21) It is possible to display the quality of the elements by colouring the cells according to the quality: In Details of 

“Mesh” LC on Body Color next to Display Style → LC on Skewness near the bottom of the list → Element quality 

can then be evaluated and poor-quality cells identified: 

 

 
 

22) Change the Display Style back to Use Geometry Setting (this reverses step 21). 

 

23) Although the quality of the mesh above is acceptable, it not appropriate for resolving the flow features in the 

boundary layer which will form around the aerofoil. An inflation layer must be created: LC Mesh → RC Insert → 

Inflation → LC on Body filter:  → LC on the air volume so that it turns green  → LC Apply next to Geometry 

under the Details box → LC No Selection next to Boundary → LC edge filter  LC on both edges of the aerofoil 

whilst holding the Ctrl key (they should turn green) → Apply  → Change the Inflation Option to First Layer 

Thickness → Define the First Layer Height as 3e-5m (i.e. 30 microns) → set Maximum Layers to 50 → set Growth 

Rate to 1.12 → Generate Mesh:  

 

24)  
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24) Repeat step (21) to change Display Style to Skewness again → Zoom in on the mesh to view the inflation layer at 

the leading and trailing edges:  

 

 

Note that the inflation layer is designed to resolve the near-wall flow gradients using 50 stacked layers of cells, 

with each layer being 12% greater in height than the one below (Recall that the growth rate is 1.12 from step 23). 

This is not the best mesh, as illustrated by the high maximum skewness of about 0.84 but it is sufficient to illustrate 

the main points of this tutorial. Quality can be markedly improved by implementing C-type meshing which is 

particularly useful for solving flow around cylinders and aerofoils, however, this is beyond the scope of these 

tutorials (you can investigate this technique yourself, if you are interested).  

25) Assign boundary condition for the aerofoil upper surface only: LC edge selection filter  → LC on the upper 

edge of the aerofoil → RC Create Named Selection (N)… (near the bottom of the menu) → Enter the name upper-

surface in the Selection Name box → OK. 
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26) Repeat step (25) to:  

a. Create another boundary condition for the aerofoil lower-surface 

b. Create an outlet boundary condition called outlet on the right edge of the domain 

c. Create a velocity inlet boundary condition called inlet, selecting the remaining three edges of the 

domain i.e. left, top and bottom edges. 

 

27) Save the Project and export the mesh file to your Tutorials folder naming it naca0012.msh before closing Ansys 

Mesh 

 

 

28) Open Fluent in 2D, selecting 

Double Precision mode, set the 

number of Solver Processes to 4 

under the Parallel (Local 

Machine) option and opening in 

parallel with 4 Processors (this will 

speed up computations but 

utilising all four processors on the 

PC/laptop you are using).  

 

29) Read in the mesh file: File → Read 

→ Mesh… → open Read in 

naca0012.msh 

 

 

 

30) Scale the mesh: Domain → Mesh → Scale… → LC Specify Scaling Factors → Input 0.6096 for both X and Y → 

Scale (Only click this once!) verify that the values for the Domain Extents correspond to the image below → Close 

 

 
 

Note: you will be comparing the simulation result with experimental data obtained by the National Advisory 

Committee for Aeronautics (NACA) in the 1930’s and 1940’s. The length of the wing (chord length) was 24” which 

is 0.6096m. It is important to match the scale of the CFD simulation to this, especially when making direct 

comparisons, hence you have used the scaling factor above. 
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31) Enable the SST k-ω turbulence model:   In 

the Outline View → Setup → Models → 

Viscous → select the k-omega (2 eqn) 

option → select the SST option → OK: 

 

32) Set the inlet boundary condition: In the 

Outline View → Setup → Boundary 

Conditions → Double click inlet in the list 

of boundary conditions → In the Velocity 

Inlet menu change the Velocity 

Specification Method to Magnitude and 

Direction → set the Velocity Magnitude 

to 72.9 m/s → Ensure that the X-

Component of Flow Direction is 1 and Y 

is 0 → Click on the down arrow next to 

Specification Method → select Intensity 

and Hydraulic Diameter → Enter values 

of 2.25% for Turbulent Intensity and 

1.306m for the Hydraulic Diameter → 

Apply → Close: 

 

 

 
 

 

 

 

 

 

➔

➔
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33) Set up the outlet boundary condition: Double click on the Outlet in the boundary condition list → Change the 

Turbulence Specification Method to Intensity and Hydraulic Diameter → Enter values of 2.25% for Backflow 

Turbulent Intensity and 1.306m for the Backflow Hydraulic Diameter (these need to match the values on the inlet) 

→ Apply → Close: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

34)  Set up spatial discretization methods: In the Outline View → Solution → Methods → Change the Gradient 

method to Green-Gauss Node Based → Change the schemes for both Turbulent Kinetic Energy (k) and Specific 

Dissipation Rate (ε) to Second Order Upwind: 
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35) Change the reference values so that the drag and lift coefficients are meaningful for this simulation: In the Outline 

View → Setup → Double click on Reference Values → In the Task Page change the Length to 0.6096 (i.e. aerofoil 

chord length) and Velocity to 72.9 m/s (i.e. the free-stream velocity, from the inlet): 

 

 

36) Change the solution stopping criteria: In the Outline View → Solution → Monitors → Residuals → In the Residual 

Monitors menu change the Absolute Criteria for all quantities from 0.001 to 1e-16 → OK: 

 

 

37) Initialise the solution: In the Outline View → Solution → Double click Initialization → In the Task Page ensure 

that Hybrid Initialization is selected → LC Initialize button. 

 

38) Save the case file: File → Write → Case → save the file as naca0012.cas.h5 in your Tutorials folder. 

 

➔

➔
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39) Run the simulation for 40 iterations: In the Outline View → Solution → Run Calculation → In the Task Page set 

the Number of Iterations to 40 → Calculate → the simulation should take under 1 minute run and you will see 

the residual plot: 

 

Note: You can see from the residual plot that the solution is starting to converge. It is good practice to use monitors 

to judge convergence as well to check that flow variables of interest (such as the lift or drag coefficient) are 

converging satisfactorily.  

 

In the next steps, you will set up two monitors which display how the lift and drag coefficients are converging. It 

is usually a good idea to do this after running the simulation for a relatively small number of iterations (40 

iterations in this case) because the solution changes so dramatically in the initial phase. By turning on flow 

monitors after the initial changes in residuals, it is then easier to judge convergence from the plots; the solution 

values are much closer together for further iterations. This will become clear in the next steps. 

 

40) Set up a drag coefficient monitor: In the Outline View → Solution → Monitors → Double click on Report Plots 

→ In the Report Plot Definitions menu LC on New…  → In the New Report Plot menu LC on New… → Force 

Report → Drag… → In the Drag Report Definition menu highlight lower-surface and upper-surface in the Wall 

Zones list → Set the Name to drag-coefficient → OK → In the New Report Plot menu change the Name to cd → 

Change the Plot Title and the Y-Axis Label to Drag monitor and Cd, respectively → Select the option for Print to 

Console → OK: 
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41) Repeat the previous step to create a lift coefficient monitor. Make sure that you select Lift… under the Force Report 

and set names and axis titles to cl and lift coefficient in a similar way to the previous step → when you have created 

lift and drag monitors Close the Report Plot Definitions menu box. 

 

42) Run the simulation for a further 460 iterations which will take up to 5 minutes. You do not need to initialise again 

because you already have an existing solution which you previously stopped at 40 iterations. 

 

43) You will now be able to see the residual plot or either of the force coefficient monitors. You will see different tabs 

to look at each plot individually. It is evident that the lift and drag coefficients have converged indicating that the 

solution is stable. The numerical values are also shown in the console which you can also write to a monitor file, 

although this is beyond the scope of this tutorial.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Note how the drag monitor 

(top left) has converged after 

about 75 iterations 

(qualitatively) but the lift 

monitor (top right) takes more 

iterations (about 100 in this 

case). These can be related 

back to the residual monitors 

(shown left), giving an 

indication of how low the 

residual monitors need to be 

before accurate results are 

obtained.  

The numerical values for these 

(as well as the force coefficient 

monitors) can be seen in the 

console. You should judge 

convergence based on the 

combination of the residual 

history and other relevant 

monitors, depending on the 

problem you are trying to solve.   
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44) Save the data: File → Write → Data → save as naca0012-0-degrees-k-omega-2nd-order.dat.h5 (Remember to be 

specific about data file names. This name tells you that you ran a turbulent flow case with the SST k-omega model 

and second order spatial discretisation, for an angle of attack of the aerofoil of 0 degrees i.e. parallel to the 

aerofoil). 

 

45) Print the drag force: In the Outline View → Results → Reports → Forces → In the Force Reports menu ensure 

that the Option is set to Forces, the Direction Vectors are X=1, Y=0 and highlight lower-surface and upper-surface 

in the list of Wall Zones → LC Print to show the forces in the X-direction:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

The results show that the total drag force is 19.02 N which is made up of 14.69 N of viscous (skin friction) drag and 

4.33 N of pressure (form) drag. Now you can calculate the drag coefficient, C
D
 from the following formula: 

 

SUρ

D
CD 25.0 

=             (1) 

 

where: D is the drag force (calculated to be 19.02N above), ρ is the air density, U
∞ is the free-stream velocity 

(72.9 m/s) and S is the plan view wing area (this is assumed to be the chord length in 2D simulations i.e. 0.6096 

m).  
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46) You can check the fluid material properties in the Materials menu: In the Outline View → Setup → Materials → 

Fluid → Air → Check that ρ = 1.225 kg/m3 (Ensure that you check this – never assume the properties, always 

check them!): 

 

 
 

Using equation (1) on the previous page, you should be able to calculate the drag coefficient which is 

approximately 0.0096 (you may have a slightly different answer if your mesh is different).  

 

This can be compared to the experimental data from page 463 of: Theory of Wing Sections, I. H. Abbott and A. E. 

Von Doenhoff, Dover Publications, 1949. This is shown on the next page.  

 

You will see that the drag coefficient plot shows different curves which depend on the Reynolds number and 

surface roughness. The simulation you have run has a Reynolds number of 3 million and so the drag coefficient 

that you have calculated, relates to the plot with circles (o) for an angle of attack of 0°. The experimental drag 

coefficient is approximately 0.006 (indicated by a red X) and so the CFD simulation over-predicts drag by 60% in 

this case. The reasons for this include the coarseness of the mesh (particularly away from the aerofoil surfaces), 

the type of turbulence model employed, the fact that you are comparing a 2D simulation data to 3D experimental 

results etc.  
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47) Print the lift force: Repeat step 45, ensuring that the Direction Vectors are set to X=0, Y=1: 

 

 

 

 

 

You can calculate the lift coefficient, C
L
 from: 

SUρ

L
CL 25.0 

=             (2) 

where L is the lift force. You will notice that because the aerofoil has a zero angle of attack, the lift force is very 

small leading to a lift coefficient which is negligible. This is not the case when the angle of attack increases and    

L >> D as will be shown in the next tutorial. In theory, the lift should be zero for a symmetrical aerofoil but 

asymmetry in the unstructured mesh (above and below the aerofoil) means that a non-zero value usually results.  

 

48) Save your case and data files if you haven’t already done so. 

 

49) Close Fluent 

 

 

 

Tutorial 5 Summary:  

You have:  

• Created an aerofoil shape from vertex data. 

• Used a boolean operation to generate an external aerodynamics solution domain, which is parameterised 

using dimensions.  

• Generated an unstructured mesh with cell refinement along the chord length of the aerofoil.  

• Implemented an inflation layer to resolve the boundary layer velocity profile all the way to the wall (non-wall 

function approach). 

• Set up and run a turbulent flow simulation using the SST k-ω model with lift and drag solution monitors. 

• Completed some quantitative post-processing to compare C
D
 and C

L
 with experimental data (validation).  

• There is no task for this tutorial. 

 

End of Tutorial 5 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 6: External Aerodynamics: NACA0012 (ii) 

 

Tutorial 6 Outline:  

• Continue quantitative analysis of the flow simulation from Tutorial 5. 

• Use the Custom Field Function calculator to define the pressure coefficient, CP. 

• Plot CP profiles and export the data. 

• Carry out qualitative post-processing of the flow field. 

• Modify the boundary conditions to simulate different angles of attack. 

• Compare results from different angles of attack with experimental data. 

• Complete TASK 3  

 

Prerequisites  

1) Ensure that you have completed Tutorials 1-5 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) As you did in Tutorial 5, open Fluent in 2D, selecting Double Precision mode and opening in parallel with 4 

Processors (this will speed up computations but utilising all four processors on the PC).  

 

2) Read in the case file from Tutorial 5: File → Read → Case → open naca0012.cas.h5 in your Tutorials folder. 

 

3) Read in the data file from Tutorial 5: File → Read → Data → open naca0012-0-degrees-k-omega-2nd-order.dat.h5 

 

4) Display contours of the velocity magnitude: In the Outline View → Results → Graphics → Double click on 

Contours icon → after the Contours window appears select Filled → Select contours of, Velocity, X-Velocity → 

Change the Coloring to Banded and ensure there are 20 levels in the colormap → Save/Display → Zoom in on the 

aerofoil, you may also wish to resize the colourmap by clicking on it and dragging the bottom corner down: 

 

 

Note: You do not need to select any surfaces to show contours in 2D because the flow is constrained to one plane. 

However, to show contours in 3D, you would need to specify which surfaces to display the contours on; this will 

be covered in later tutorials.  
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5) Display the vector plot and zoom in on the leading edge of the aerofoil: In 

the Outline View → Results → Graphics → Double click on Vectors icon → 

after the Vectors window appears change Style to Filled Arrow and set the 

Scale to 0.1 → To display the outline of the aerofoil LC on the Draw Mesh 

option → select Edges under Options, Feature under Edge Type and 

highlight only the lower-surface and the upper-surface in the Surfaces list 

→ LC Display followed by Close in the Mesh Display menu → In the Vectors 

window LC Colormap Options → In the Colourmap menu LC on the down 

arrow for the Currently  Defined colourmap and select blue from the list → 

Apply → Close → In the Vectors window LC Save/Display → Zoom in on 

the front of the aerofoil surface which is known as the leading edge (you 

may need to search around for the aerofoil). You may also wish to reposition 

the colourmap by clicking, dragging and dropping it where needed: 

 

 
 

Note that the velocity profile in the boundary layer has been 

resolved all the way to the wall. You need to zoom a long way 

into the image to see this. It illustrates how small the viscosity 

affected region of the flow is, in this case. You can also 

experiment with the different types of colourmap to illustrate 

your results with clarity. 

 

 

 

6) Create a reference point upstream of 

the aerofoil: On the top menu ribbon, 

LC Results → Under the Surface 

menu LC on the down arrow next to 

Create → Point → In the Point 

Surface menu change the X-

coordinate to -6.0 m and the Y-

coordinate to 0.0 m → Set the Name 

to ref  → Create: 
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7) Calculate the free-stream static pressure using the reference point you have just created: In the Outline View → 

Results → Reports → Double click on Surface Integrals → In the Surface Integrals menu select Vertex Average 

from the list of options under Report Type → Select Static Pressure as the Field Variable → Select ref from the 

list of surfaces → Compute. 

 

 

 

 

 

 

 

 

 

 

 

 

The static pressure will now 

appear in the console. For 

the simulation shown here, 

the pressure is approx. 2.5 

pa. Your simulation may 

show a slightly different 

value, depending on how 

close your mesh is to the one 

shown in Tutorial 5. You need 

to know the value of this 

reference pressure to 

calculate the pressure 

coefficient in step 9 below. 

 

8) Repeat step (7) above for the Velocity Field Variable and verify that the velocity magnitude at the reference point 

is, to one d.p., 72.9 m/s i.e. the same as the inlet boundary condition value which is the free-stream velocity. 

 

9) Create a Custom Field Function of the pressure coefficient, C
P
 which is given by: 

 

25.0 

−
=

Uρ

pp
Cp             (1) 

 

where: p is the local static pressure, p
∞ is the free-stream static pressure (calculated to be 2.5 pa above), ρ is the 

air density and U
∞ is the free-stream velocity (72.9 m/s) also checked above.  

 

On the top menu ribbon, LC User Defined → Under the Field Functions tab LC on Custom… → In the Custom Field 

Functions Calculator menu box you will need to create a function to represent the pressure coefficient from the 

values found in steps (7) and (8). You need to click on the buttons on the calculator (the keyboard cannot be used). 

First click on ( to open a set of brackets, next you need to select the local static pressure which is the default 

function under Select Operand Field Functions, LC on the select button and note that p has now appeared in the 

Definition field, now complete the function using equation (1) and the values you already know → set the New 

Function Name to cp to denote the pressure coefficient (capital letters are not permitted) → Define:      
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10) Repeat step (4) to display contours of the pressure coefficient. You will need to select contours of, Custom Field 

Functions and select cp → Save/Display: 

 

 
 

Note that the highest pressure coefficient of 0.994 is close to the maximum physical value of 1 (for incompressible 

flow) which denotes a stagnation condition, where the fluid is brought to rest. Where C
P
 = 0, the flow speed matches 

the free-stream value and for C
P
 < 0, the airflow velocity is greater than that of the free-stream.  
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11) Plot the pressure coefficient from 

data points on the surface of the 

aerofoil (Recall steps 16 and 17 

from Tutorial 2): On the top menu 

ribbon, LC on the Results tab → XY 

Plot → Edit… → when the Solution 

X Y Plot menu box appears ensure 

that the Plot Direction vectors are 

X=1 and Y=0 → Select the Y Axis 

Function as Custom Field Functions 

and cp → Highlight the lower-

surface and upper-surface from the 

list of Surfaces → Click Plot: 

 

 

 

 

 

 

 

 

 

 

 

12) Export this data for use in a spreadsheet later: LC on the Write to File 

box under Options in the Solution XY Plot window → Click the Write… 

button (in the previous step this was the Plot button) → Name the file 

cp-0-degrees → OK. 

 

Note: Sometimes the data files exported by Fluent do not show the 

rows of data in a logical order. If you use Excel to processes the data, 

you may need to sort the data in order of smallest first. This prevents 

issues when you use line plots to display the profiles.  

 

The next stage of the tutorial requires changes to the boundary conditions to simulate different angles of attack. 

The aerofoil will be at the same angle in the domain, however, the boundary conditions can be manipulated to 

change the angle at which the air enters the domain, which has the same overall effect as changing the angle of 

attack of the aerofoil itself. The advantage of this is that the same mesh can be used, for consistency.  
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13) Change the angle of the air entering the domain to 4  :ͦ In the Outline View → Setup → Boundary Conditions → 

Double click on inlet → In the Velocity Inlet menu box ensure that the Velocity Specification Method is set to 

Magnitude and Direction → Check that the Velocity Magnitude is 72.9 m/s → Ensure that the X-Component of 

Flow Direction is 1 and set the Y-Component of Flow Direction to 0.0699 (this produces an angle of attack of 4  ͦ) 

→ Ensure that the Turbulent Intensity is 2.25% and the Hydraulic Diameter is 1.306m → Apply: 

 

14) As you already have the data file for the 0 degree solution (step 3) you can use this as the starting point of the 4 

degree simulation: In the Outline View → Solution → Run Calculation → In the Task Page set the Number of 

Iterations to 2000 → Calculate:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Please note: if you have convergence difficulties then you will need to initialize again using Hybrid Initialization. 

In some instances, this step is necessary to ensure convergence, because the mesh may have some poor-quality 

cells a maximum skewness of > 0.9.  

The simulation will take up to 5 minutes to complete. Notice how the residuals are still dropping after 1000 

iterations and they have not fully converged, unlike the first simulation (0-500 iterations). However, if you look in 

First simulation 

(Tutorial 5)   

i.e. α = 0  ͦ 
Second 

simulation    

i.e. α = 4  ͦ 
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the Console you will see that both lift and drag coefficients have converged to 4 decimal places after ~565 

iterations so the flow can be considered to be converged; check this yourself by scrolling up through the data in 

the console window.  

An important point is that the lift and drag coefficients, as predicted by Fluent, are incorrect if the flow direction 

is not in the x-direction! Drag is the force parallel to the free-stream direction and lift is perpendicular to it. 

Remember, you have effectively changed the free-stream flow direction (step 13) and because Fluent calculates 

forces in a fixed frame of reference, you will need to use trigonometry in step 17 to obtain correct lift and drag 

coefficients.  

15) Display contours of the velocity magnitude, 

you should see something similar to the 

image to the right. Note that the airflow is 

faster over the suction (upper) surface. 

 

 

 

 

 

 

16) Calculate the forces acting on the aerofoil in the X and Y direction (Recall steps 45 and 47 from Tutorial 5) and 

record them in a spreadsheet.  

 

Verify that the X-force, F
X = -36.8 N and the Y-force, F

Y
 = 832.1 N (or close to these values). 

 

17) As explained in step (15), the X and Y forces produced by Fluent do not account for the change in inlet flow 

direction. Therefore, Fluent’s force output of F
X
 and F

Y
 need to be processed using trigonometry to convert to 

drag, D and lift, L. To do this, use the following relationships: 

 

αFαFD XY cossin +=                               (2) 

αFαFL XY sincos −=                 (3) 

 

 

 

 

 

 

 

 

 

 

 

Verify that D =21.6 N and L = 832.6 N (or close to these values). 

Free-stream flow 

direction (not to 

scale) 

F
X  

F
X 

sin α 
α=4˚ 

Free-stream flow 

direction 

α=4   ͦ

F
Y  

F
Y 
cos α 

F
Y 
sin α 

F
X 

cos α 
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18) Save the data file with file name: naca0012-4-degrees-k-omega-2nd-order.dat.h5 

 

19) Repeat steps (11) and (12) to generate the pressure coefficient distribution and export the data:  

 

Note how the pressure distribution on the upper and lower surfaces are now different, whereas they were the 

same for the symmetrical case i.e. α = 0  .ͦ This is expected because an angle of attack induces asymmetry in the 

flow field with a suction peak occurring over the leading edge; this is seen in the figure above by the lowest 

pressure coefficient (red data series). In aeronautics, it is conventional to invert pressure coefficient plots 

vertically such that negative pressure coefficients occur at the top of the plot but this is beyond the scope of this 

tutorial.  

20) Repeat steps (13-19) for an angle of attack of 8˚. To do this, you will need to set the Y-Component of Flow Direction 

to 0.1405. Ensure you save the data file (step 19) with an appropriate name.  

 

21) Repeat steps (13-19) again, this time for an angle of attack of 12˚. To do this, you will need to set the Y-Component 

of Flow Direction to 0.2126. 

 

You should see a residual history similar to the plot on the next page. Notice how convergence proves to be more 

difficult, with higher residual values, as the angle of attack increases; this is because flow gradients are higher and 

the flow is more complicated to resolve. One way to minimise this is to use a good quality mesh i.e. better than 

the one used in this tutorial.  

 

22) Save your case file, which will contain boundary conditions for the 12˚ case.  

 

23) Close Fluent and complete Task 3. 
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TASK 3 

Using the data you have obtained in this tutorial, please complete the following task. Using equations (1) and (2) in 

Tutorial (5), convert the force data to lift and drag coefficients, based on your CFD results. You should be able to 

complete the table below to compare your simulation data with the experimental results which have been provided 

for you. Once you have completed the table, plot: 

a) The lift polar which has the angle of attack, α, on the x-axis and the lift coefficient, C
L
, on the y-axis. Include 

both CFD and experimental data on the same plot. 

b) The drag polar which has the lift coefficient, C
L
, on the x-axis and the drag coefficient, C

D
, on the y-axis. Include 

both CFD and experimental data again. 

α Fx (N) Fy (N) D (N) L (N)  CD CFD  CD Exp  CL CFD  CL Exp 

0      0.0060  0.00 

4      0.0063  0.45 

8      0.0070  0.88 

12      0.0084  1.25 

 

If you have any doubts about your results, please speak to a demonstrator.  
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Tutorial 6 Summary:  

You have:  

• Examined the flow field for the zero angle of attack case using contour and vector plots. 

• Created a reference point from which to obtain free-stream flow quantities 

• Created a custom field function to represent the pressure coefficient 

• Generated plots of the C
P
 distribution and exported the data. 

• Manipulated the boundary conditions to simulate different angles of attack, without having to re-mesh the 

geometry. 

• Processed the forces obtained by fluent into lift and drag coefficients for comparison with experimental data.   

• Compared the pressure distributions at different angles of attack. 

 

End of Tutorial 6 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 7: Flow Over Blunt Rectangle 

Tutorial 7 Outline:  

• Build 2D geometry based on knowledge from previous tutorials, add edge splits up to aid meshing. 

• Quadrilateral mesh created with strategic cell clustering. 

• Simulations carried out using three k-ε turbulence models. 

• Custom Field Function calculator used to define the friction coefficient, Cf. 

• Cf profiles plotted, exported and compared to experimental data. 

• Fundamental principles of visualisation explored.  

• Complete TASK 4  

 

Prerequisites  

1) Ensure that you have completed Tutorials 1-6 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) The purpose of this tutorial is to simulate airflow over a blunt-edged rectangle, based on physical experiments 

conducted in a wind tunnel from: N. Jjilali and I. S. Gartshore. Turbulent Flow Around a Bluff Rectangular Plate. 

Part I: Experimental Investigation. Journal of Fluids Engineering, 113, pp. 51-59, 1991. The geometry of the shape 

is represented in 2D with a symmetry plane (blue line) as shown below: 

 

 

 

 

 

 

2) Open ANSYS Workbench.  

 

3) Open Design Modeler, (also called Geometry). 

 

4) In the Tree Outline LC on the XYPlane → LC on sketching tab at the bottom of the tree outline box → LC Settings 

→ LC Grid → Tick the boxes for Show in 2D and Snap (This draws a grid in the graphics window to aid geometry 

creation) → set Major Grid Spacing to 0.4 m, Minor-Steps per Major to 4.  

 

5) LC on the end of the Triad Z-axis to view the XY plane as illustrated to the 

right → Zoom in on the grid using the mouse wheel. 

 

6) Use a Polyline (recall Tutorial 3, step 8) to create the shape shown above 

with points at the following locations and in the following order: (0,0), (-

2.4,0), (-2.4, 0.8), (0, 0.8), (1.6, 0.8), (1.6, 0.1), (0, 0.1), RC Close End. 

 

7) Make a surface from this Polyline → LC Modeling tab under Sketching Toolboxes → LC on the (+) symbol next to 

the XYPlane → LC Sketch1 under Tree Outline → on the top menu LC Concept → Surfaces from Sketches → LC 

Apply under Details View → Generate: 

 

 
 

 

 

 

 

 

0.8 m 0.755 m 

1.60 m 2.40 m 

Height = 0.045 m 

Airflow 

direction 
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8) Add a General dimension to the short 

edge at the front of the object and set 

the height to 0.045 m (recall Tutorial 

3, step 11).  

 

 

 

 

9) Use the split tool to add a strategic 

point on the left edge to aid meshing: 

LC Sketching tab under Sketching 

Toolboxes → LC Modify → LC on the 

Split icon LC near the bottom of the 

edge (shown as circled below): 

 

 
 

10) Add a General dimension to the short edge and set the edge length as 0.045 m to match the height of the blunt 

object further downstream: 
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11) Repeat steps (9) and (10) to create two further points which are both 0.4 m downstream of the blunt object as 

arrowed below (note you may need to click the Generate button for the first point, before you can create the 

second one): 

 

Your dimensions may have different labels to those shown in the image above, this will not cause you any 

problems.  

12) Save the project and name the file blunt-rectangle.wbpj 

  

13) Close Design Modeler → Link Ansys Mesh to Geometry in Workbench → Open Ansys Mesh. 

 

14) LC on Mesh in the Tree → in the Details of Mesh box LC on Mechanical next to the Physics Preference and change 

to CFD. 

 

15) Using the layout of edges and the details in Table 1 below, insert edge biases (recall Tutorial 3)   

 

 

 

 

 

 

 

Edges Number of Divisions Bias Factor Bias Type 

AB  and  IH 120 15 
 

BC  and  GF 40 10 
 

CD  and  FE 70 15 
 

AJ  and  DE 50 10 
 

JI  and  GH 10 1.5   

Table 1: Mesh parameters 

 

 

➔

A                                                                                                B              C                                 D 

E 

G              F                                  

I                                                                                                 H                                  

J 
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16) Insert Face Meshing as the mesh method → Generate: 

 

 

 

 

 

 

 

 

 

 

17) Insert Named Selections to set the boundary conditions using Table 2 below → You can click on the (+) symbol 

next to Named Selections in the Tree and highlight all the boundaries in the list whilst holding the Ctrl key: 

 

Edges Name 

AB, BC and CD top-wall 

AJ and JI inlet 

DE outlet 

IH symmetry 

GH blunt-rectangle-front 

GF and FE blunt-rectangle-top 

                                                                            Table 2: Boundary Conditions 
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18) Save the Project and Export a mesh file 

called blunt-rectangle.msh 

 

19) Close Ansys Mesh. 

 

20) Open Fluent in 2D, selecting Double 

Precision mode and opening in parallel 

with 4 Processors. 

 

21) Read in the mesh file generated in step 

(18).  

 

22) Activate the standard k-ε turbulence 

model: Setup → Models → Viscous → 

Select the Standard k-epsilon (2 eqn) 

model ensuring that non-equilibrium wall 

functions are enabled:  

 

23) Ensure that the Pressure-velocity 

Coupling Scheme is SIMPLE, that the 

Gradient scheme is Green-Gauss Cell 

Based and all Spatial Discretisation 

schemes are 2nd order, (Solution → 

Methods): 

 

24) Set the inlet boundary condition (Setup → Boundary 

Conditions) so that the velocity is 8.113 m/s and normal to the 

boundary, set the Turbulence Specification Method to 

Intensity and Hydraulic Diameter and set intensity to 1% and 

hydraulic diameter to 1.92m: 

 

25) Reduce the Absolute Criteria convergence tolerance for 

continuity to 1e-16 (Solution → Monitors → Residual). 

 

26) Initialize the solution using the Hybrid Initialisation scheme 

(Solution → Initialization). 

 

27) Run the simulation for 600 iterations which should 

take no more than a few minutes (Solution → Run 

Calculation). Notice how the solution is converged 

after 500 iterations.  

 

28) Save the case file: File → Write → Case… → Save 

the case file with the name blunt-

rectangle.cas.h5. 

 

29) Save the data file for this standard k-epsilon (ske) 

solution: File → Write → Data… → Save the data 

file with the name blunt-rectangle-ske.dat.h5. 
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30) Change the view to reflect the results about the symmetry plane: On the top menu ribbon, LC View → Under the 

Display tab LC on Views → In the Views menu box highlight symmetry under the Mirror Planes list → Apply → 

Close:   

 
 

31) Display pathlines which are released from the front face of the blunt rectangle: In the Outline View → Results → 

Graphics → Double click on Pathlines → In the Pathlines menu change the number of Steps to 1000 → Change 

Color by to Velocity Magnitude → Highlight blunt-rectangle-front in the Release from Surfaces list → To display 

the outline of the domain LC on the Draw Mesh option → select Edges under Options, Feature under Edge Type 

and highlight only the blunt-rectangle faces in the Surfaces list → LC Display in the Mesh Display menu → In the 

Pathlines window LC → Save/Display → Zoom in on the rectangle in the graphics window: 
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The pathlines are released from the front of the rectangle and they move downstream highlighting the primary 

flow feature; flow separation. The flow reattaches further downstream and from this point the pathlines become 

entrained in the free-stream, just above the boundary layer until they exit the domain.      

 

32) Display pathlines again but release them from the inlet and blunt-rectangle-front as well as blunt-rectangle-top 

to reveal a more complete flow field:  
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33) Display contours of the Turbulent Kinetic Energy (k) ensuring the rgb-modern colourmap is selected with 20 levels 

of banded colouring and the mesh outline is on to show the blunt object: Results → Graphics → Contours: 

 

        
 

 

 

 

 

34) Create a Custom field Function (recall step 10 in Tutorial 6) of the skin friction coefficient, Cf, which is given by: 

 

25.0 

=
Uρ

τ
C w

f             (1) 

 

where: τ
w
 (tau-w) is the local wall shear stress, ρ is the air density (1.225 kg/m3) and U

∞ is the free-stream velocity 

(8.113 m/s). Note: the denominator of equation (1) is 0.5*1.225*8.113
2 = 40.315.  

 

On the main menu ribbon LC User Defined → Under the Field Functions tab LC on Custom… → In the Select 

Operand Field Functions area of the Custom Field Function Calculator menu box, select Wall Fluxes and X-Wall 

Shear Stress as the sub-category → LC select so that x-wall-shear appears in the definition box → Select the divide 

button followed by 40.315 to complete the function → set the New Function Name to cf to denote the skin friction 

coefficient (remember, capital letters are not permitted) → Define:      
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35) Using the cf function defined in the previous step, plot the friction coefficient using the surface blunt-rectangle-

top which is one of the wall-type boundary conditions you defined in step (17) (Results → Plots → XY Plot): 

  

 
 

 

 
 

Note: the horizontal location which coincides with C
f = 0 is the position where the airflow reattaches to the 

bluff shape, having separated around the leading edge further upstream. This point is located at approximately 

x = 0.14m or three times the height of the rectangle.  

 

 

36) Export the friction coefficient data using the Write to File option in the Solution XY Plot menu box (recall step 4 in 

Tutorial 4). Save the file as blunt-rectangle-ske-cf-plot.xy  
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37) Recalling step (22), change the turbulence model to the RNG k-ε (retain the option for non-equilibrium wall 

functions) → Run a new simulation for 1000 iterations using the previous solution as a starting point (you do not 

need to initialize because you already have an existing solution (from the previous simulation) which is a very good 

initial guess; initialization is only necessary when you do not have a solution) → Save the data file with filename: 

blunt-rectangle-RNG-ke.dat.h5 → Repeat steps (35) and (36) to generate the cf plot data for the RNG k-ε model, 

saving it as: blunt-rectangle-RNG-cf-plot.xy  

 

38) Repeat step (37) but with the Realizable k-ε model activated (also retaining non-equilibrium wall functions) → 

Run the simulation for 1000 iterations saving the resulting data file as: blunt-rectangle-realizable-ke.dat.gz → Plot 

and export the cf plot data for the Realizable k-ε model, saving it as: blunt-rectangle-rke-cf-plot.xy  

 

39) Display contours of the Turbulent Intensity → In the Contours menu uncheck Auto Range under Options and 

change the Min to 0 % and the Max to 400 % → Show the mesh outline for the blunt object → LC on the Colormap 

Options… button → Set a banded rgb-modern colourmap with only 10 levels in the Colormap Size and Apply → 

Close the Colormap menu → Save/Display: 

 

 

 

 

 

 

 

 

 

 

Notice how the number of colours 

in the colourmap has changed to 10 

due to the changes made in 

Colormap Options above. You are 

encouraged to explore the other 

options including different 

colourmaps (see Currently Defined 

option) to tailor your visualisations.  

Note: sometimes you may need to 

switch between different 

colourmap options otherwise the 

scales can be difficult to see; the 

onus is on you as the CFD engineer 

to present data clearly. 
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40) Repeat the previous step for the other two data files (blunt-rectangle-RNG-ke.dat.gz and blunt-rectangle-

realizable-ke.dat.gz) and compare all three as shown below. You will need to read each data file before displaying 

the contours (File → Read → Data…): 

    

 

Notice how the three contour 

plots to the right can be 

compared to each other 

because, for consistency, they 

have the same colourmap 

scales; it is very important to 

do this for a fair comparison.  

 

By default, Fluent uses the 

Autoscale function which is 

rarely suitable for comparing 

different results. By specifying 

the minimum and maximum 

value for the turbulence 

intensity in step (39), this 

captures the full range of 

values seen in all three contour 

plots, and, more importantly, it 

overrides the Autoscale 

function. This range can only be 

determined by systematically 

visualising all data sets first to 

find the overall minimum and 

maximum values, then use this 

range for a fair comparison.  

 

Another point of note is the vast 

difference in results shown to 

the right, especially considering 

that they were all obtained from 

variations of the k-ε RANS 

turbulence model. It shows just 

how different certain flow 

parameters can be, depending 

on the choice of turbulence 

model. If you were to look at 

contours of velocity magnitude, 

the flow looks practically the 

same for all cases, yet 

turbulence levels, skin friction 

coefficients and separation 

points occur in completely 

different locations.  

Standard k-ε 

 

 

 

 

 

 

 

 

 

RNG k-ε 

 

 

 

 

 

 

 

 

Realizable k-ε 
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41) Using any three of the data 

files, display contours of the 

Velocity Magnitude → 

Disable the Autoscale 

function and set minimum 

and maximum values to 0 

m/s and 11 m/s, 

respectively → Change the 

Colormap Size to 11 → 

Display the contours → 

Then change the Colouring 

from Banded to Smooth → 

Display the contours again, 

noting the change in 

appearance of the contour 

plot → Now deselect Node 

Values (recall step 10 in 

tutorial 2) and Display the 

contours for a final time: 

You should see similar 

results to those shown to 

the right (these are 

obtained from the standard 

k-ε model results). They 

show just how misleading 

smooth contours can be, 

especially compared to the 

actual flow result (seen by 

the solver) which is in the 

bottom right plot. 

Smooth contours do not tell 

you anything about the grid 

resolution, whereas node 

values do. Although smooth 

contours may look visually 

appealing, having a sensible 

number of colour bands also 

makes it easier to identify 

flow parameters in any 

particular location, within 

the domain. Smooth colour 

maps make it far more 

challenging to pinpoint a 

particular colour (flow 

quantity) on the scale. 

Therefore, only use smooth contours with extreme caution! 

 

Banded contours: 11 contour levels 

 

 

 

 

 

 

 

 

 

Smooth (unbanded) contours: continuous colour map 

 

 

 

 

 

 

 

 

Banded contours of node values: 11 contour levels 
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42) Save your case file.   

 

43) Close Fluent 

 

 

 

TASK 4 

Using the data you have obtained in this tutorial, please complete the following task. Using the exported skin friction 

coefficient data, plot the profiles for all three turbulence models on the same graph. You should plot C
f
 on the y-axis 

and the dimensionless distance, X/D, on the x-axis, where X is the X-coordinate in each exported data file and D = 

0.09 (this is the height of the rectangle from the physical experiments). Please also include the experimental data 

points (from the original wind tunnel data) to validate your CFD results; these data are shown in the bottom row of 

the table below:   

 

X/D 1.00 1.40 1.80 2.20 2.60 3.00 3.40 3.80 4.20 4.60 4.80 5.20 5.45 5.80 

Cf x 10-3  -0.40 -1.00 -1.50 -1.90 -2.30 -2.35 -2.10 -1.60 -1.00 -0.30 0.10 0.90 1.40 1.80 

 

Think about which turbulence model has the best match with the experimental data. Is the performance between 

models comparable? Which turbulence model would you trust the most?  

If you have any doubts about your results, please speak to a demonstrator.  

 

 

 

Tutorial 7 Summary:  

You have:  

• Created the geometry of a 2D domain containing a blunt rectangular shape. 

• Generated a structured quadrilateral mesh with cell refinement in suitable locations. 

• Conducted three simulations using all three variants of the k-ε turbulence model. 

• Made use of the Custom Field Function calculator to plot friction coefficient data. 

• Explored some of the fundamental principles of visualisation. 

 

 

End of Tutorial 7 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 8: Flow Visualisation Around a 3D Tower 

 

Tutorial 8 Outline:  

• You are provided with a case and data file containing simulation results of airflow around a 3D tower.  

• You will explore the range of post-processing tools available in the 3D Fluent solver to illustrate the capability 

of contour and vector plots, oil-flow plots, pathlines and iso-surfaces. 

  

Prerequisites  

1) Ensure that you have completed Tutorials 1-7 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Open Fluent in 3D, selecting Double 

Precision mode and open in Serial mode 

(not parallel) with only 1 Solver Process:  

 

2) Locate the files tower.cas.gz and 

tower.dat.gz on MINERVA → 

MECH5770M → Learning Resources → 

Tutorials → Support files for Tutorial 5, 

8 and 12.  

 

 

 

3) Read in the above case and data files: File → Read → Case & Data → Select the case file tower.cas.gz → OK. 

Note that because the case and data files have the same name (with a different extension), the data file will 

automatically read in after the case file if you specify Case & Data as above. Also, these files have the extension 

.gz instead of .h5 this is a legacy of older versions of Fluent (V19 and earlier) but they will read into Fluent 2020 

R2 and later versions without difficulty.  

 

4) Explore the grid: On the top menu ribbon, LC 

Domain → Display… → In the Mesh submenu,  

LC Display… to open the Mesh Display menu 

box → Ensure that all the surfaces except 

default-interior are selected → Under Option 

ensure that Faces is deselected and All Edges 

are selected → Display: 

 

 
 

Note that you should never select default-interior, otherwise you will see every single grid line (including the 

interior lines) and this often causes the computer to crash, especially if the mesh is large. You will see that the grid 

lines above are coloured with the following conventions: grey = wall; yellow = symmetry; inlet = blue and outlet 

= red. This is helpful if you wish to quickly see which boundary conditions have been assigned.   



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               103 
 

5) Show grid lines of the ground plane and the tower only: In the Mesh Display menu box LC Faces → LC the deselect 

all button next to Surfaces          → LC on wall-floor and wall-tower → Display: 

 

 

 

Note that you can change the orientation of the view by zooming with the mouse wheel, 

panning the view by clicking and holding the left mouse button and rotating by pressing 

and holding the mouse wheel. You can also use the viewing tools down the left side of 

the Graphics window shown above. You can click on the small horizontal buttons to 

expand the options, for example, see image to the right:  

                                          

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               104 
 

6) Display the surfaces of the ground 

plane and the tower without grid 

lines: Display → Mesh… → In the 

Mesh Display menu box uncheck 

Edges and Faces under Options → 

Display: 

 

 

 

 

 

 

 

7) Change the lighting to Flat mode: → On the top menu ribbon, LC View → Options → In the Display Options menu 

LC Lights… → In the Lights menu box change the Lighting Method to Flat → Apply: 
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8) Change the direction of the light source: LC and hold the left mouse button to rotate the globe shape under Active 

Lights → Move the globe until the axes are in a similar orientation to the ground plane and tower (in the graphics 

window) now use the right mouse button to press and hold the light source indicated by a circle with a cross in it 

→ move the light source to any location on the globe → Apply → Keep moving the light source until you are 

happy with it.  

 

 

             

 

9) Reflect the display about the symmetry plane (recall step 30 in Tutorial 7): On the top menu ribbon, LC View → 

Under the Display tab LC on Views → In the Views menu box highlight symmetry under the Mirror Planes list → 

Apply → Close:   

 

 
 

 

 

 

 

 

 

Light 

source 

Default globe view                           New globe orientation                        Light source relocated 
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10) Display contours of velocity magnitude inside the domain: Results → Double click on Graphics so the Task Page 

updates → In the Task Page double click on Sweep Surface → In the Sweep Surface menu change the Display 

Type to Contours → When the Contours menu box appears select Velocity… and Velocity Magnitude, select Filled 

contours, a banded colourmap with 20 levels and select the Draw Mesh option  → In the Mesh Display menu LC 

Display… → Close → in the Contours LC OK → Return to the Sweep Surface menu box and LC and hold the slider 

bar to show the contours in the X-plane: 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If the contours are not clear then you may need to turn off the lights and turn them on again (View → Options 

→ Lights…) or display the mesh again before moving the slider bar in the Sweep Surface window.  

 

 

 

Slider bar 

moves left 

to right  
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11) Create an X-plane at X=0: Using the Sweep Surface 

menu box change the number in the Value box to 0 

→ press the Enter key → LC the Create… button → 

when the Create Surface menu box appears enter 

the name x=0 → OK 

 

12) Repeat step (11) to create two further surfaces, one 

at X=1m and another at X=2m with corresponding 

names. 

 

 

13) Display contours of velocity magnitude on the symmetry plane and the three planes you have created: Results → 

Graphics → Double click on the Contours icon → after the Contours window ensure that the Filled option appears 

and a banded colourmap with 20 levels is selected → Select contours of, Velocity, Velocity Magnitude → Highlight 

symmetry and x=0, x=1 and x=2 in the Surfaces list → Select the Draw Mesh option and LC Display when the 

Mesh Display menu appears → Close the Mesh Display menu → In the Contours menu LC Save/Display →  

Manipulate the view to your liking (recall step 5). 

 

 
 

Note: You can use the slider bar in the Sweep Surfaces menu box to explore the flow field. By changing the Sweep 

Axis in the Sweep Surface menu, then you can create other surfaces (in any plane). For 3D cases, by default you 

are only provided with the boundaries in the domain to use as surfaces for post-processing, hence you need to 

create your own planes to view what is happening inside the domain. Obviously for 2D cases, the solution domain 

is in a single plane, so there is no need to create planes for visualisation purposes.  

 

14) Display vectors on the symmetry plane and the three planes created above: Results → Graphics → Double click 

on the Vectors icon → after the Vectors window appears select Draw Mesh under Options → When the Mesh 

Display menu box appears LC Display then LC Close → Return to the Vectors menu box and highlight symmetry 

and x=0, x=1 and x=2 in the Surfaces list → Set the Scale to 0.5 → Save/Display → Zoom in on the tower (you 

may wish to reposition the colormap as shown in the following image: 
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15) Display an oil-flow plot on the ground plane: In the Tree → Results → Graphics → Double click on the Pathlines 

icon → Select Draw Mesh under Options → When the Mesh Display menu box appears LC Display then Close → 

Return to the Pathlines menu box → Select Oil Flow under Options → Select coarse-cylinder under Style → LC 

the Attributes… button and set the width to 0.002 m → OK → Change the number of Steps to 5 → Select 

Velocity… and Velocity Magnitude under the Color by menu → Select wall-floor under On Zone → Select  wall-

floor under Release from Surfaces → Display: 
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16) Create an upstream line to show pathlines in the 

core region of the flow: In the main ribbon menu 

LC Results → Create a Line/Rake → Set the 

coordinates of the two ends of the lines to: (-0.5, 

-0.15, -0.025) and (-0.5, 1.35, -0.025), as shown 

to the right → Set the New Surface Name to 

line-1 → Create: 

 

17) Display pathlines, released from line-1 only: 

Repeat step (15) but deselect Oil Flow → change 

the number of Steps to 1000 → Under Release 

from Surfaces deselect wall-floor and select 

line-1 instead → Display:  

 

Note you may need to display the mesh again 

and ensure that wall-floor and wall-tower are 

selected. 
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18) Remove pathlines from the display: In the 

main ribbon menu LC View → Graphics → 

Compose… → In the Scene Description 

menu under Names highlight the name of 

the pathlines object (in this case pathlines-

2, yours may have a different name) → LC 

the Delete Geometry button → LC Apply 

→ Close. 

  

19) Create a surface at Y=0 (recall step 11): 

Open the Sweep Surface menu box again 

→ Change the Sweep Axis so that X=0, Z=0 

and Y=1 → LC the Compute button → 

Enter 0 in the Value field and press Enter 

→ Create… set the Surface Name to y=0 

→ OK: 

 
 

20) Display contours of velocity magnitude on the symmetry plane and y=0 → Change the view to see the tower from 

behind: 
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21) Enable overlays so that other visualisations can be 

over-laid on the contour plots: In the main ribbon 

menu LC View → Graphics → Compose… → In the 

Scene Description menu tick the Overlays box 

under Scene Composition → Apply → Close. 

 

22) Display the pathlines from step (17): Results → 

Graphics → Double click on pathlines-2 

(remember yours may have a slightly different 

name) which should be immediately under 

Pathlines in the Tree → Open the Pathlines menu 

box again → Save/Display (all the previous 

information from step (17) will have been saved:  

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

➔
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23) Change the transparency of the contour plots and show grid lines on those planes: In the main ribbon menu LC 

View → Graphics → Compose… → In the list of Names in the Scene Description menu, highlight the two items 

with names beginning contour → LC the Display… button → In the Display Properties menu box select Edges, 

ensure that Outer Faces, Perimeter Edges, Feature Edges and Nodes are all deselected and change the 

transparency to 20% by changing the slider bar (you can use the arrow keys on the keyboard to help you) → LC 

Apply in both the Display Properties and Scene Description menu boxes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Note: If you wish to display further visualisations such as vector plots, they will be overlaid onto the image above. 

To prevent this, you can disable overlays in the Scene Description box. You can also delete specific items from the 

scene using the Delete Geometry button if you know their names, to construct a particular visualisation. 

 

24) Repeat step (18) to delete all items from the scene → Deselect Overlays → Close.  
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25) Create an iso-surface of constant static pressure: In the main ribbon menu LC Results → Create → Iso-Surface → 

Change Surface of Constant to Pressure → LC the Compute button → Move the slider bar until the Iso-Value 

changes to a non-zero value → type in the value -10 as the pressure in pascals → Select air in From Zones → Set 

the name of the surface to iso-surface-1 in the New Surface Name → Create.  

     

26) Display contour plots coloured by the static pressure on the symmetry plane, the wall-floor and iso-surface-1 

making sure you display the mesh faces (you may wish to change the direction of the light source, recall step 8):  

 

 
 

Note: the iso-surface is useful as you can use this as a surface to display contours of any variable available in the 

simulation data set. The method can be applied to other variables as well as pressure. The image on the next page 

shows what an iso-surface of velocity magnitude = 2 m/s looks like; this is a good way of visualising low-velocity 

wakes.  
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27) Finally you can display the residuals to see how the solution was obtained and whether or not is was converged: 

In the main ribbon menu LC Results → Plots → Residuals… → LC the Plot button in the Residual Monitors menu 

box:  

        

 

28) Save the case file.   

 

29) Close Fluent 
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Tutorial 8 Summary:  

You have:  

• Displayed the grid and rendered the tower and ground plane using the lighting tool. 

• Created surfaces within the domain in various planes, in addition to iso-surfaces to aid visualisation. 

• Generated contour plots with and without transparency to reveal flow features. 

• Displayed vector plots, pathlines and oil-flow plots to highlight flow behaviour. 

• Arranged a scene combining multiple plots into one image. 

• Displayed the residuals from the solution. 

• You are now able to explore these techniques further to characterise flow fields.  

• There is no task for this tutorial. 

 

End of Tutorial 8 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 9: Laminar Channel Flow 

 

Tutorial 9 Outline:  

• Run a laminar flow case through a pipe for various grid densities. 

• Export flow data for each grid. 

• Use the Grid Convergence Index (GCI) to evaluate discretisation error. 

• Compare CFD data with analytical solution. 

• Complete TASK 5  

  

Prerequisites  

1) Ensure that you have completed Tutorials 1-8 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly, but you should still be able 

to complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Open ANSYS Workbench.  

 

2) Within ANSYS Workbench open Design Modeler, (also called Geometry) → Save Project and name it 

channel.wbpj in your Tutorials folder 

 

3) In the XYplane create a 2D sketch of the rectangular domain 0.1m high and 1.0m in length. You may wish to use 

the grid (sketching tab → Settings → Grid) to assist you with this (Recall tutorials 1,3 and 7). Ensure that the origin 

is at the bottom left corner of the domain. 

 

 

 

 

 

 

Figure 1: Solution domain. 

 

4) Create a surface from sketch: Concept → Surfaces From Sketches → Select one of the edges → Apply → 

Generate: 

 

 

5) Close Design Modeler → Link Ansys Mesh to Geometry in Workbench → Open Ansys Mesh. 

 

6) LC on Mesh in the Tree → Set the Physics Preference to CFD. 

 

 

 

 

H = 0.1 m 

L = 1.0 m 

wall-top 

wall-bottom 

inlet outlet Flow direction 
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7) Insert a uniform edge sizing (i.e. no bias) for the two vertical edges and set the Number of Divisions to 5 → Set 

the Behavior of the sizing to Hard → Set the name of the sizing to y-sizing: 

 

The Hard setting forces Ansys to follow your requirements. If the setting is left as the default of Soft then ANSYS 

often adjusts the spacing/biases to effectively ignore your mesh settings. This isn’t a problem for most meshes as 

it allows greater node flexibility, however, a rigid Cartesian mesh structure is required for this tutorial so the Hard 

setting is appropriate.  

 

8) Insert another uniform edge sizing (i.e. no bias) for the two horizontal edges and set the Number of Divisions to 

10 → Set the Behavior of the sizing to Hard → Set the name of the sizing to x-sizing. 

 

9) Insert a Face Meshing method → Generate: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

10) Insert boundary condition names using the labels in Figure 1 (recall step 3). 

 

11) Save the Project and Export a mesh file called channel-5x10.msh 
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12) Change the Number of Divisions on the vertical and horizontal edges to 10 and 20 elements, respectively → 

Generate. 

 

13) Export another mesh file called channel-10x20.msh 

 

14) Change the Number of Divisions on the vertical and horizontal edges to 20 and 40 elements, respectively → 

Generate. 

 

15) Export another mesh file called channel-20x40.msh 

 

16) Change the Number of Divisions on the vertical and horizontal edges to 40 and 80 elements, respectively → 

Generate. 

 

17) Export another mesh file called channel-40x80.msh. The image below shows what the four meshes should look 

like: 

 

 

 

 

18) Close Ansys Mesh → Close ANSYS Workbench. 

 

19) Open Fluent in 2D, selecting Double Precision mode and opening 

in parallel with 4 Processors.  

 

20) Read in the coarse mesh file, channel-5x10.msh, generated in step 

(12).  

 

21) Change the viscous model to Laminar: Setup → Models → 

Viscous: 

 

 

5 x 10  

 

 

 

10 x 20 

 

 

20 x 40 

 

 

40 x 80 

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               120 
 

22) Set the inlet boundary condition to have a velocity magnitude of 0.01 m/s which leads to Re = 30.  

 

This Reynolds number is in the fully laminar regime so there is no requirement for a turbulence model. 

Furthermore, you will see that the turbulence specification parameters (e.g. turbulence intensity) are unavailable 

in the boundary conditions menus when the laminar viscous model is selected.   

 

23) As this is an incompressible flow case set the Pressure-

Velocity Coupling scheme to SIMPLE (Solution → 

Methods). 

 

24) Since you are using structured quad cells, set the Gradient 

method to Green-Gauss Cell Based (Solution → Methods).  

 

25) Ensure that all discretisation schemes (Solution → 

Methods) are 2nd order. 

 

26) Reduce the convergence tolerance for continuity to 1e-16 

(Solution → Monitors → Residuals). 

 

27) Initialise the solution using Hybrid Initialization (Solution → Initialization), set number of iterations to 200 and 

run the simulation until it is converged (this should take about 105 iterations). 

 

28) Save Case & Data files as: channel-5x10-laminar.cas.h5 and channel-5x10-laminar.dat.h5. 

 

29) Plot the X-Velocity at the outlet: On the top ribbon LC Results → Plots → XY Plot → Edit… → Ensure the Plot 

Direction vectors are X=0 and Y=1 → Select the Y Axis Function as Velocity and X Velocity → Highlight the outlet 

from the list of Surfaces → Uncheck the Node Values box to ensure cell centre values are plotted (this step is 

important!) → LC Curves… → In the Curves – Solution XY Plot menu change Size to 0.5 → Plot:  
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You should see that there are only 5 

points on the plot because this coarse 

mesh only has 5 cells in the vertical 

direction.  

30) Export these data points: LC on the 

Write to File box under Options in the 

Solution XY Plot menu → Click the 

Write… button → Name the file u-vel-

5x10 → OK. 

 

 

 

 

31) Now read in the mesh file channel-10x20.msh → File 

→ Read → Mesh → In the Read Mesh Options menu 

select the option Discard Data, Replace Mesh → 

Continue… → Select the file channel-10x20.msh (this 

retains all the case file settings and only replaces the 

mesh). If you select the other option, you will need to 

set the whole case file up again. 

 

32) Initialise and run simulation as in step (27) (you don’t 

need to do anything else with the setup). 

 

33) Once the simulation has converged, save Case & Data files as: channel-10x20-laminar.cas.h5 and channel-10x20-

laminar.dat.h5. 

 

34) Plot and export the data at the outlet and save as u-vel-10x20 

 

35) Repeat steps (31)-(33) for the two finest grids (channel-20x40.msh and channel-40x80.msh) and name the files 

accordingly. 

 

36) Using the four case and data files, investigate the contour plots of velocity magnitude for all cases; they should 

look the same as those in the figure below. For consistency, ensure that you use the same scale to compare these 

plots. Note that these images were generated in an older version of Fluent which is why the background colour is 

black, however, the data is identical.  
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37) Using a spreadsheet plot the outlet velocity profiles. Compare these to the exact (analytical) formula which 

describes how the horizontal velocity, u, varies as a function of the height, h, in the channel. This is given by: 
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            (1) 

 

where: UIN is the inlet velocity (0.01 m/s), h is the height in the channel and H is the maximum channel height 

(0.1 m). Note that this formula assumes that h = 0 is in the centre of the channel, whereas your simulations assume 

that h = 0 is at the bottom of the channel. Therefore, you will need to input a height range of h = –0.05 to h = +0.05 

to obtain the correct analytical profile.  

 

It is recommended that you evaluate the analytical function (equation 1) for step height increments of 0.005 m to 

cover the vertical range with sufficient data points. Once you have the velocities, plot these as a function of the 

same height range as the CFD data i.e. h = 0 to h = 0.1 m. Figure 2 on the next page shows what the results should 

look like. You will notice that even the coarsest mesh exhibits reasonable results, although the higher mesh 

resolutions are more accurate for computations.  

 

0                        0.005                     0.010                       0.015 

u (m/s) 

5 x 10  

 

 

10 x 20 

 

 

20 x 40 

 

 

40 x 80 

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               123 
 

 
 

Figure 2: Outlet velocity profiles comparing various CFD results with the analytical solution. 

 

38) Using the profiles from the previous step, find 

the maximum velocity, per profile. These 

should be the same as the results shown in 

Table 1 (right). Note that the analytical value is 

0.015 m/s which allows for quantitative 

comparison.  

 

39) Using the data in Table 1, plot the global cell count, N, as a function of umax. Also plot the horizontal grid spacing, 

Δx, (remember the channel is 1 m in length) as a function of umax. These two plots are shown in Figure 3 below and 

they demonstrate whether or not grid independence has been achieved. You can apply the same principles to 

other problems.  Note that on the plots shown, the y-axis scale is zoomed into the range of the data points for 

clarity. In reality, the differences in solutions are much closer, if you were to set the y-axis minimum to zero.   
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u
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m
/s

)

Channel height, h (m)

5x10 grid

10x20 grid

20x40 grid

40x80 grid

Exact solution

Grid umax (m/s) 

5 x 10 0.014418 

10 x 20 0.014696 

20 x 40 0.014922 

40 x 80 0.014980 

Table 1: Grid statistics and velocity data. 
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Figure 3: Grid sensitivity plots. 

 

40) Complete task 5 on the next page. 
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TASK 5 

Using the data you have obtained in this tutorial, please complete the following task. This task involves you calculating 

the discretisation error of umax using the Grid Convergence Index (GCI). To do this firstly calculate the error, e, between 

successive grids using equation (2): 

 

( )

1

12

f

ff
e

−
=             (2) 

where: f1 is the fine grid solution and f2 is the coarse grid solution. For example, to calculate e between the coarsest 

grid (5x10) and the next finest one (10x20), f1 = 0.014696 and f2= 0.014418. Once you have found e for each pair of 

successive grids, GCI can be found from equation (3): 

( )1−
=

p

s

r

eF
GCI             (3) 

 

where FS is the factor of safety which you can assume to be 3, r is the grid refinement ratio which is 2 because the grid 

was doubled in all directions between successive grid refinements, and p is the order of discretisation which you can 

assume to be 2 because you computed second order solutions (in reality, p < 2, and so peff has to be calculated, as 

described in the lecture slides on Verification and Validation, however, assume p = 2 here). Note that the numbers 

obtained from the GCI equation should be multiplied by 100 to obtain the percentage discretisation error. 

Using your calculations, you should be able to complete the table below. You will note that because the results from 

two grids have to be compared to find the error between them, there are only three errors for the four grids 

considered (this will be clear when you do the calculations) 

Grid umax (m/s) e GCI (%) 

5 x 10 0.014418 N/A N/A 

10 x 20 0.014696 ? ? 

20 x 40 0.014922 ? ? 

40 x 80 0.014980 ? ? 

 

Think about which is the most accurate solution and why. Why is the result so important when thinking about the 

application of CFD more generally? If you have any doubts, please discuss these with a demostrator.  

 

 

Tutorial 9 Summary:  

You have: 

• Created four different grids with uniform vertical and horizontal spacing for a straight channel. 

• Run laminar flow simulations and exported the fully-developed flow profile at the outlet, for each grid. 

• Compared these velocity profiles against the analytical case. 

• Investigated grid independence using the Grid Convergence Index and grid sensitivity plots. 

End of Tutorial 9 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 10: Laminar Flow Through Staggered Heat Exchanger (i) 

 

Tutorial 10 Outline:  

• Create a solution domain featuring a staggered tube arrangement. 

• Implement walls, symmetry and periodic boundary conditions. 

• Implement heat transfer so that energy from the tubes is transferred to the fluid which is water. 

• Calculate the Reynolds number from the flow solution and visualise the temperature distribution. 

• Complete TASK 6  

  

Prerequisites  

1) Ensure that you have completed Tutorials 1-9 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly, but you should still be able 

to complete the tutorial.   

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click 

LC = Left mouse button click 

MC = Middle mouse button click 
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1) Open ANSYS Workbench.  

 

2) Open Design Modeler, (also called Geometry) → Save Project and name it heat-exchanger.wbpj in your Tutorials 

folder. 

 

3) Change units to mm: Units → Millimetre. 

 

4) In the XYplane create a 2D sketch of the rectangle (only) shown in Figure 1(a) with the bottom left corner as the 

origin (0,0). Using General dimensions set the height to 11.125 mm and the width to 25 mm. You will find it helpful 

to use a grid (sketching tab → Settings → Grid → Set the Major Grid Spacing to 10 mm and 5 Minor-Steps per 

Major).  

 

 

 

 

 

 

 

 

 

 

 

Figure 1: (a) Construction shapes for the solution domain and (b) final shape and boundary condition names. 

 

 

5) Create a surface from the rectangle sketch: Concept → Surfaces from Sketches → Change the Operation to Add 

Frozen → Generate: 
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6) LC XYPlane in the Tree Outline and insert a new sketch, sketch2, using the Create New Sketch button: . This 

step is important so that the Boolean operation can be implemented later; the circles must belong to a separate 

sketch to the rectangle sketch.  

 

7) Create two circles, both of diameter, D = 10mm, and with their respective centres at (6.125, 11.125) and (18.875, 

0). You will need to use the Diameter dimension to specify the diameter of each tube. The General dimension is 

suitable for specifying both the horizontal and vertical coordinates of each circle centre; for example, to set the 

horizontal distance of the left circle centre (6.125 mm), you will need to click the centre of the left circle until it 

turns yellow, then click on the vertical axis at x = 0 mm until it also turns yellow then LC to add your dimension.  

 

Note that you may not need to specify the vertical position of the centre of the circles if you drew them in the 

correct position at the top and/or bottom of the rectangle. You may find it difficult to set vertical dimensions in 

this case so there is no need for them. If you make a mistake with your dimensions or a message appears indicating 

an “over-constrained” geometry, LC the undo button:  

 

 

8) Create a surface from sketch → Ensure that the Add Material Operation is selected → Generate: 

 

 

9) Create a Boolean operation using the Subtract operation to subtract both circles from the rectangle: Create  → 

Boolean → Change the Operation to Subtract → Select the rectangle as the Target Body and both circles as the 

Tool Bodies (remember to press the Ctrl key to select both circles) → Generate: 
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10) Save the Project → Close Design Modeler → Link Ansys Mesh to Geometry in Workbench → Open Ansys Mesh. 

 

11) Set the Physics Preference to CFD. 

 

12) LC on the z-axis of the triad (bottom right corner) to view the domain from the side → Zoom in so that the whole 

domain is visible. 

 

13) Insert a uniform edge sizing (i.e. no bias) and apply to both wall-cylinder edges and all four symmetry edges (refer 

to Figure 1b): Mesh → Insert → LC Sizing → LC on the edge selection filter:   → LC on both wall-cylinder and 

all four symmetry edges (keeping the Ctrl key pressed so that you can add them all to the selection) → Apply → 

Set the Element Size to 3.5e-04 m. Note that the default units are metres in ANSYS Mesh; you can change this 

under the Units option on the top ribbon. 

 

14) Insert another uniform edge sizing to the left and right edges which form the periodic boundaries: Mesh → Insert 

→ LC Sizing → LC on the edge selection filter:   → LC on the left and right edges → Apply → Set the Type to 

Number of Divisions and set to 35 → Set the Behavior to Hard to make sure Ansys Mesh enforces your exact 

requirement.  

 

Note that it is important that these two edges have the same number of elements as they will share common data 

during the simulation. If you specify element size  as you do in step (13) above, then there is a risk that the number 

of elements may be mismatched (known as a non-conformal mesh) in some instances i.e. for long edges. You can 

mitigate against this by precisely specifying the number of elements.  

 

15) Insert a Triangular mesh method: Inset → Method → Select the solution domain → Apply → Change the Method 

to Triangles. 
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16) Refine the Mesh settings: LC on mesh in the Outline → LC on the (+) sign next to Sizing under Details of “Mesh” 

→ Change the Use Adaptive Sizing to Yes → Set the Resolution to 3 → LC on the (+) sign next to Quality → Change 

Smoothing to High → Generate: 

 

 

 

 

 

 

 

 

 

 

 

Note: High smoothing helps reduce skewness (i.e. improves quality) and a fine relevance centre limits the degree 

of mesh coarsening in the central region of the domain. You may wish to change these settings to explore the 

effect they have on the resulting mesh.  

17) Insert an inflation layer: Mesh → Insert → Inflation → LC the domain so it turns green → Apply → LC No Selection 

to the right of Boundary and LC both edges (holding the Ctrl key) → Select both circular edges so that the inflation 

layer is applied to the cylinder surfaces only → Apply → Change the Inflation Option to Total Thickness → Select 

5 layers, a Growth Rate of 1.1 and a Maximum Thickness of 6.e-04 m → Generate: 
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18) Assign a periodic boundary condition to the left edge: LC edge selection filter  → LC on the left edge of the 

solution domain → RC Create Named Selection (at the bottom) → Enter the name periodic-left in the Selection 

Name box → OK. 

 

19) Repeat step (18) using the labels in Figure 1(b) to:  

a. Create another periodic boundary condition called periodic-right 

b. Create wall boundary conditions on the cylinder surfaces named wall-top-cylinder and wall-bottom-

cylinder. 

c. Create symmetry boundary conditions for the four relevant edges shown in Figure 1(b). You can either 

label these as four separate symmetry faces or group them all onto one selection:  

 

 
 

To see the named selections and to check them you can LC on each one in the Outline view. If you want to show 

them all, hold the Ctrl key on the keyboard and LC on each one. 

 

20) Check the quality of the mesh by colouring the cells by skewness (Recall step 21 in Tutorial 5). You should see that 

the maximum skewness is around 0.65 which is reasonable in quality (the exact number may differ, depending on 

small variations in the unstructured mesh): 
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21) Save the Project → Export the mesh file and call it heat-exchanger → Close Ansys Mesh and Workbench. 

 

22) Open Fluent in 2D, selecting Double Precision mode and opening in parallel with 4 Processors. 

 

23) Read in the coarse mesh file, heat-exchanger.msh, generated in step (21). 

 

24) Find the boundary ID number for the periodic boundary conditions: In the Outline View → Setup → Double-click 

Boundary Conditions until the Boundary Conditions show in the Task Page → LC to highlight periodic-left → Take 

note of the ID number assigned by Fluent which in this case is 5 (your ID number may be different if you created 

your boundary conditions in a different order to that described previously) → Repeat for periodic-right which in 

this case is 6 (there is nothing else to do for this step, you just need to know these two ID numbers): 

 

       
 

Note: It is important to know the ID numbers so that the two boundaries can be linked in the next step; this is the 

essence of the periodic boundary condition, the flow conditions on the left boundary match those on the right due 

to the repetitive nature of the flow field. This is different to some of the earlier tutorials such as the backward-

facing step and the aerofoil where the flow was not repetitive in the streamwise direction.  

 

 

 

 

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               133 
 

25) Link the periodic-left and periodic-right boundary conditions. This is a special type of boundary condition and 

requires a number of steps and the Text User Interface (TUI) described below. Before completing these steps, if 

you make a mistake at any point press Ctrl + C to cancel the instructions.  

 

a. LC in the TUI which is below the graphics display and press the Enter key on your keyboard. You will see a 

list of menu options: 

 

 
 

b. Type the following and press Enter: mesh/modify-zones/make-periodic: 

 

c. You are now required to enter the ID number of the Periodic zone: Type the value of the ID number you 

have identified for periodic-left in step (24) above and press Enter: 

 

 
 

d. Next, you are required to enter the ID number of the Shadow zone (i.e. the right boundary): Type the value 

of the ID number for periodic-right in step (24) above and press Enter: 

 

 
 

e. In the following order type no and press Enter (this activates translational periodicity which is required for 

this problem), yes and press Enter (this confirms that periodic zones are required) and yes and press Enter 

(this ensures that direction vectors between the left and right boundaries are shared). You will then see a 

message stating that one of the zones (ID’s) has been deleted; in other words the left and right boundaries 

have been merged into one because the boundary conditions must be identical: 
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26) Enable heat transfer by activating the Energy equation: In the 

Outline View → Setup → Models → Double-click Energy → 

Tick the Energy Equation box → OK. 

 

27) Add water to the list of fluids available: In the Outline View 

→ Setup → Materials → Fluid → Double-click air → In the 

Create/Edit Materials menu box LC the Fluent Database… 

button → In the Fluent Database Materials menu box, scroll 

down the list of materials until you find water liquid (h2o<l>) 

and highlight it → LC the Copy button (this now copies all the 

material properties for water to be used as the working 

fluid): → Close the Fluent Database Materials menu box → 

LC the Change/Create button → Close: 
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28) Change the continuum from air to water: In the Outline View → Setup → Cell Zone Conditions → Fluid → 

Highlight and double click the surface_body cell zone → In the Fluid menu box change the Material Name to 

water-liquid → Apply → Close: 

 

 

29) Set periodic conditions: In the Outline 

View → Setup → Double click on 

Boundary Conditions → At the bottom of 

the Task Page LC on the Periodic 

Conditions… button → In the Periodic 

Conditions menu change the Type to 

Specify Mass Flow → Set the Mass Flow 

Rate to 0.05 kg/s → Set the Upstream 

Bulk Temperature to 298 K → OK:  
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30) Specify the temperature on the bottom cylinder: In the Task Page double click on wall-bottom-cylinder → In the 

Wall boundary condition menu LC on the Thermal tab → Set the Thermal Conditions to Temperature → Set the 

temperature of the wall to 343 K → Apply → Close → Repeat this step for wall-top-cylinder. 

 

 
 

 

31) Change the viscous model to Laminar 

(Setup → Models → Viscous). 

 

32) Change the Pressure-Velocity coupling 

algorithm from SIMPLE to Coupled 

(Solution → Methods).  

 

33) Unstructured triangular cells are being 

used so set the Gradient method to 

Green-Gauss Node Based (Solution → 

Methods).  

 

34) Ensure that all discretisation schemes 

are 2nd order (Solution → Methods). 

 

35) Enable Pseudo Transient: Tick the 

Pseudo Transient box (Solution → 

Methods). 

 

36) Reduce the convergence tolerance for 

both continuity and energy to 1e-16 

and set the number of iterations to 

plot and store to 2000 (Solution → 

Monitors → Residual). 
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37) Initialise the solution using Hybrid Initialization and Patch the solution to the bulk temperature to aid convergence: 

Solution → Initialization → Select Hybrid Initialization → LC on the Initialize button → LC the Patch… button → 

In the Patch menu box highlight Temperature in the Variable list → Highlight surface_body in the Zones to Patch 

list and enter a temperature Value of 298 K  → LC the Patch button → Close:  

 

 
 

Note: Using the pseudo transient option adds an unsteady term to the flow equations which helps convergence 

and stability in some cases, including the one considered in this tutorial (see Ansys Fluent User and Theory Guides 

for more details about this algorithm). 

 

38) Save the Case file as heat-exchanger.cas.h5 

 

39) Run the simulation for 1000 iterations: Solution → Run Calculation → Set the number of iterations to 1000, leave 

all other settings as the default → Calculate. The solution should converge in around 800 iterations. 

 

40) Save Data file as: heat-exchanger-low-Re.dat.h5  

 

In the case of heat exchangers, the Reynolds Number is given by:  

 

μ

DUρ
ReD

max=             (1) 

 

where: ρ is the water density (998.2 kg/m3), U
max is the maximum velocity in between both cylinders, D is the 

diameter of the cylinders (0.01 m) and μ is the water viscosity (0.001003 kg/ms).    

 

41) Find U
max from the resulting flow field: In the Outline View → Results → Reports → Surface Integrals → Change 

Report Type to Vertex Maximum → Change the Field Variable to Velocity and Velocity Magnitude → In the 

Surfaces list highlight interior-surface_body → Compute. You should see a value of around 0.0128 m/s.  

 

42) Using equation (1) and the value you have just found, calculate the Reynolds number which should be 

approximately 128. This confirms that for the given boundary conditions, the flow is laminar in nature and so a 

turbulence model would be inappropriate, justifying the use of the laminar model in the simulation (set in step 

31). 
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43) Display contours of the Velocity Magnitude being careful to include a banded colourmap with 20 levels: 

 

 
 

44) Display contours of the Static Temperature → In the Contours menu box, uncheck Auto Range → Change the Max 

value to 343 (this is the boundary condition value for temperature at the cylinder walls): 

 

 
 

  

TASK 6 

Using the two contour plots that you have obtained, please complete the following task.  

Carefully observe the contour plots of fluid velocity and temperature. Think about the flow patterns, focusing on 

regions of high and low velocity and temperature. You should also think about the relationship between velocity and 

temperature, which explains the flow physics observed in your CFD solution. What are your conclusions?  

Think about these questions and ask a demonstrator if you have any doubts.  
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Tutorial 10 Summary:  

You have:  

• Created a domain shape which is repetitive in nature and composed of wall, symmetry and periodic boundary 

conditions. 

• Set up the special case of the periodic boundary condition, linking the left and right boundaries. 

• Used the Pseudo Transient algorithm in conjunction with a Patch to initialise the flow field. 

• Run a laminar flow simulation and calculated the Reynolds Number of the laminar flow regime.    

 

End of Tutorial 10 

 

 
 

 

 

  



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               140 
 

 

 

 

 

MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 11: Laminar Flow Through Staggered Heat Exchanger (ii) 

 

Tutorial 11 Outline:  

• Continuing from Tutorial 10, run two further flow simulations for higher mass flow rates. 

• Obtain heat transfer coefficients to determine the Nusselt number, Nu. 

• Compare flow behaviour using consistent post-processing with identical colour map scales. 

• Export and compare thermal data for the three flow rates considered.  

• Complete TASK 7  

  

Prerequisites  

1) Ensure that you have completed Tutorials 1-10 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click  LC = Left mouse button click 

MC = Middle mouse button click 
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1) In tutorial 10 you obtained a flow field for a heat exchanger. Open the case and data files from this simulation i.e.  

heat-exchanger.cas.h5 and heat-exchanger-low-Re.dat.h5  

 

2) Display the velocity magnitude contour plot again → Reflect the results about the symmetry plane: View → 

Display → Views… → In the Mirror Planes list highlight any symmetry planes shown → Apply: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note how the repetitive nature of 

the flow field has allowed only a 

small segment to be modelled. The 

repetition is confined to reflecting 

the results about the symmetry 

planes in Fluent, however, the 

repetition would naturally continue 

both vertically and horizontally since 

heat exchangers typically contain 

hundreds of tubes. You may see 

more reflections if you created 

separate top and bottom symmetry 

planes. 

 

 

3) The Reynolds number, ReD, has already been found in Tutorial 10 and it is approximately 128 for the flow field 

shown above, justifying the use of the laminar model i.e. no turbulence model is required.  

 

For heat transfer applications, another important parameter is the Prandtl number named after the famous Ludvig 

Prandtl. This number depends only on the fluid properties and is defined as: 

 

k

μc
Pr

p
==

rate diffusion Thermal

rate diffusion Viscous
          (1) 

 

where: cp is the specific heat capacity (J/kg-K), μ is the dynamic viscosity (kg/m-s) and k is the thermal 

conductivity (W/m-K). 

 

Verify that Pr ≈ 7 Using equation (1) and the water properties used by Fluent (found in: Setup → Materials → 

Fluid → water-liquid). This value means that the momentum of the fluid dominates and thermal effects do not 

alter material properties. This justifies the constant values of cp, μ and k used in the simulation. This would not be 

valid if the fluid was Mercury for example; here the material properties are highly dependent on the heat input 
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and so the thermal dependence on the fluid properties would need to be considered. Note that Pr ≈ 0.015 for 

Mercury and so fluids like this which have small Prandtl numbers would need thermal effects embedded in material 

properties, however, this is no applicable to this tutorial. 

 

4) Obtain the heat transfer 

coefficient, h, from the flow field:  

Results → Reports → Double click 

on Surface Integrals → Change 

Report Type to Vertex Average → 

Change the Field Variable to Wall 

Fluxes… and Surface Heat 

Transfer Coef. → In the Surfaces 

list highlight wall—top-cylinder 

and wall-bottom-cylinder → 

Compute:  

 

You should see values of around 

414 for the bottom cylinder and 

457 for the top cylinder, with a net 

average of 435; check the Console 

to see the breakdown. Note that 

these values are highly dependent 

on the mesh density so if your 

mesh is different to the one 

described in this tutorial, you are 

likely to have similar but different 

results. This is to be expected and 

the only way to confirm the 

answer would be to carry out a 

grid independence study which is 

not studied in this tutorial. 

 

5) Another useful parameter in heat transfer calculations is the Nusselt number, Nu, named after Wilhelm Nusselt. 

This is defined as 

k

hL
Nu ==

Transfer Heat Conductive

Transfer Heat Convective
          (2) 

 

where: h is the heat transfer coefficient (W/m2-K), L is the characteristic length of the system (m) and k is the 

thermal conductivity (W/m-K). 

 

Verify that Nu ≈ 7.3 using: equation (2), the mean heat transfer coefficient (step 4), the diameter, D, as the 

characteristic length (recall from Tutorial 10 that this is 0.01m) and the thermal conductivity of water (0.6W/m-K). 

 

6) Change the mass flow rate to 0.1 kg/s in the periodic conditions (Recall step 29 in Tutorial 10): Setup → Double 

click on Boundary Conditions → At the bottom of the Task Page LC on the Periodic Conditions… button → Set the 

Mass Flow Rate to 0.1 kg/s  → OK. 

 

7) Run a simulation for 1300 iterations: Solve → Run Calculation → Set the number of iterations to 1300, leave all 

other settings as the default → Calculate. The solution should converge from about 1200 iterations. 
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8) Save Data file as: heat-exchanger-medium-Re.dat.h5   

 

9) Repeat steps (6-8) for one final simulation with a mass flow rate of 0.15 kg/s. The simulation will require 2000 

iterations to converge as the higher mass flow rate puts greater demands on the solver due to higher flow 

gradients. Name the data file as: heat-exchanger-high-Re.dat.h5   

 

10) For each of the simulation results, find Umax and h in order to calculate ReD (recall Tutorial 10, steps 39-41) and Nu 

(step 5 above). You will need to systematically read in each data file and extract the required quantities (see step 

12 on the next page). Your results should be close to the values shown in Table 1 below. In some instances, the 

maximum temperatures are over-predicted; this only occurs in a few cells due to the limited mesh resolution. 

However, the bulk values are representative of the problem.   

m  (kg/s) Umax (m/s) ReD h (W/m2-K) Nu Tmin (⁰C) Tmax (⁰C) 

0.05 0.01281 127.5 435.5 7.3 10.4 71.4 

0.10 0.02935 292.1 518.3 8.6 12.4 70.9 

0.15 0.05425 539.9 760.2 12.7 13.2 70.0 

Table 1 

 

Note that the highest Reynolds number for the three cases is 540 which is still relatively low. The filenames used 

in steps (8) and (9) are helpful to indicate the order of which Reynolds number is highest. 

 

11) Create a Custom Field Function to convert the standard unit of temperature in Fluent (Kelvin) to degrees Celsius: 

In the top ribbon User Defined → Field Functions → Custom… → Under Select Operand Field Functions, change 

the Field Functions to Temperature… and Static Temperature → LC on the select button and complete the 

function which simple requires “ – 273” to be entered into the Definition box → Set the New Function Name to 

degrees-celsius → Define:      
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12) For each simulation result, calculate, to the nearest decimal place, the minimum and maximum temperatures 

seen in the flow: Reports → Double click on Surface Integrals → Change Report Type to Vertex Minimum → 

Change the Field Variable to Custom Field Functions… and degrees-celsius → In the Surfaces list highlight 

interior-surface_body → Compute. Repeat using Vertex Maximum as the Report Type to find the maximum 

temperature.  

 

 

 

 

 

 

 

 

 

 

The correct values are shown in Table 1 on the previous page. You will notice that at lower mass flow rates the 

maximum temperature is higher because the energy is not taken away by the fluid as quickly. Another observation 

is that at low mass flow rates the velocities are also lower so the residence time is higher and the fluid heats up 

more. These trends become clearer with qualitative post processing in the next steps.  
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13) For each simulation result, display contour plots of the temperature in degrees Celsius with a specified minimum 

and maximum range: Results → Graphics → Contours → Select contours of Custom Field Functions… and 

degrees-celsius (the function you defined in step 11) → LC the Compute button → Uncheck the Auto Range button 

→ change the min and max values to 10 and 72, respectively → Display: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note that the contour plots shown are done in a consistent manner because the temperature range on the colour map 

is the same. Clearly, as the flow rate increases, the width of the low temperature ‘snake’ of fluid is narrower and the 

flow becomes more direct with smaller curvature as it passes around the cylinders. 

 

m = 0.05 kg/s 

m = 0.10 kg/s 

m = 0.15 kg/s 
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14) Repeat step (13) to generate contour plots of the velocity magnitude with minimum and maximum values of 0 and 

0.055 m/s, respectively. The value 0.055 m/s is slightly higher than Umax for the high mass flow rate case and is 

given in Table 1.  

 

The resulting contour plots are on the left below and contrasted against the default (auto range) contours on the 

right. It is essential to have the same specified range when making direct comparisons between flow fields. Note 

that the Colour maps have been removed for clarity but this is not good practice when presenting CFD results!  

 

 

                          

                          

                          

 

15) Identify the separation points on both the cylinders for the high mass flow rate case: Ensure that the data file heat-

exchanger-high-Re.dat.gz is read into Fluent → Display contours of the X-velocity → Ensure Auto Range is ticked 

→ LC Compute button → now uncheck Auto Range, set the minimum to 0 and leave the maximum value → Ensure 

Draw Mesh is selected in the Contours menu box → In the Mesh Display menu box highlight all surfaces → LC on 

the Colors… button → In the Mesh Colors menu box highlight interior and change the Color to black → Close the 

Mesh Colors menu box → In the Mesh Display menu box LC Display then LC Close →  in the Contours menu box 

LC Save/Display: 

 

m = 0.05 kg/s 

m = 0.10 kg/s 

m = 0.15 kg/s 

Specified range Auto range 
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Separation 

points 

Separation 

points 
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16) Repeat step (15) for the other two flow cases and compare all three results:  

 

 
 

 
 

 
 

Note: The separation points shift further around the circumference of the cylinder for the high flow cases which 

coincides with the recirculating eddies and corresponding reversed flow. These regions are denoted by the cells 

which are not coloured above. The arrows indicate the location of separation points.   

 

 

 

 

 

 

 

 

m = 0.05 kg/s 

m = 0.10 kg/s 

m = 0.15 kg/s 
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17) Use an Isosurface to create a line at x = 6.125mm, coinciding with the centre of the top cylinder: In the Results tab 

in the top ribbon → Surface → Create → Iso-surface…  → Change the Surface of Constant to Mesh… and X-

Coordinate → LC the Compute button → Move the slider bar until you see the value for Iso-Values (m) changing 

→ Input a value of 0.006125 m → Press the Enter button the keyboard → Set the New Surface Name to 

x=6.125mm → Create: 

 

 
 

18) Display the mesh outline including the line you have just created: Results → Graphics → Mesh → In the Mesh 

Display menu box alter Options so that only Edges are highlighted → Ensure Feature is the only Edge Type → 

Highlight all surfaces in the Surfaces list, excluding interior-surface_body and surface_body → Save/Display (you 

may also wish to change the line thickness to 2 in Display Options): 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note that the vertical white line 

(arrowed) is the one created in step (17). 

This will now be used for post-

processing. 
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19) Read in the low mass flow rate simulation result: File → Read → heat-exchanger-low-Re.dat.h5   

 

20) Plot the temperature along the line you have just created: Results → Plots… → Highlight XY Plot and click the Edit 

button → Ensure the Plot Direction vectors are X=0 and Y=1 → Select the Y Axis Function as Custom Field 

Functions… and degrees-celsius → Highlight x=6.125mm from the list of Surfaces → Click Plot → Tick the Write 

to File button → Write → Save the data with filename: temp-profile-low-Re 

 

21) Repeat step (20) for the other two flow fields so that you have three sets of temperature data to plot. 

 

22) Write the case file again (overwriting the previous one) to save the line from step (17) → Close Fluent 

TASK 7 

Using the data that you have obtained, please complete the following task. From your data obtained in steps (20) and 

(21), plot the temperature as a function of the vertical distance (y) in the fluid domain, for all three cases. Ensure all 

data is on one plot.  

Think about the results and what the different temperature distributions mean. Can you explain the flow features or 

the flow physics from these plots? Think about these questions and ask a demonstrator if you have any doubts.  

 

 

Tutorial 11 Summary:  

You have:  

• Completed three simulations of water flow through a staggered heat exchanger with different mass flow 

rates. 

• Calculated Reynolds and Nusselt numbers, both of which are dependent on flow variables found using the 

surface integrals panel. 

• Presented contour plots for each flow field using a consistent method suitable for comparisons. 

• Identified separation points in the flow field and exported temperature profiles, for each simulation.   

 

End of Tutorial 11 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 12: Compressible Flow (i): Prandtl-Meyer Expansion 

 

Tutorial 12 Outline:  

• Generate three uniform, structured grids for the Prandtl-Meyer expansion with a turn angle of 10⁰. 

• Set up compressible flow simulations with a free-stream Mach number of 2. 

• Analyse the expansion wave for results obtained from each grid. 

• Compare numerical predictions to analytical results. 

• Complete TASK 8 

 

Prerequisites  

1) Ensure that you have completed Tutorials 1-11 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.   

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click  LC = Left mouse button click 

MC = Middle mouse button click 
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The purpose of this tutorial is to simulate supersonic airflow over sudden divergence for a given free-stream Mach 

number. This is based on the analytical and CFD results in: U. Ghia et al. The AIAA Code Verification Project – Test 

Cases for CFD Code Verification. AIAA Paper No. 2010-0125. 48th AIAA Aerospace Sciences Meeting and Exhibit, 

Orlando, Florida, January 2010. The geometry of the shape is illustrated in Figure 1 below which consists of a wall 

angled at δ = 10⁰ with a free-stream Mach number of 2. As the flow passes the angle at the wall, an expansion wave 

is produced with significant changes in pressure, density and temperature evident; these will become apparent 

throughout this tutorial. At either side of the expansion fan, the flow is uniform: 

 

 

 

 

 

 

 

 

Figure 1: Computational domain for the Prandtl-Meyer expansion. 

 

1) Open ANSYS Workbench.  

 

2) Open Design Modeler, (also called Geometry) → Save Project and name it expansion.wbpj in your Tutorials folder. 

 

3) Change units to cm: Units → Centimetre. 

 

4) In the Tree Outline LC on the XYPlane → LC on sketching tab at the bottom of the tree outline box → LC Settings 

→ LC Grid → Tick the boxes for Show in 2D and Snap → set Major Grid Spacing to 10 cm and the Minor-Steps 

per Major to 10.  

 

5) LC on the end of the Triad Z-

axis to view the XY plane. 

 

6) Use a Polyline (recall 

Tutorial 3, step 8) to create 

the shape shown in Figure 1 

with points at the following 

locations and in the 

following order: (0,0), (-

10,0), (-10,15), (0, 15), 

(20,10), (20,-5), RC Close 

End: 

 

M1 

p1 

T1 

ρ1 

 

 

 

M2 

p2 

T2 

ρ2 

 

 

 

A                                   B 

F                                   E 

C 

  

 

 

 

D 

δ 
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7) Insert an Angle dimension to define the angle of the wall after the sudden divergence. You will need to Select 

Angle in the list of dimension types, then LC on the bottom edge ED followed by the X-axis. Enter an angle of 190⁰ 

which is equivalent to δ = 10⁰:   

 

 
 

 

8) Add a vertical dimension to the left edge (AF) and set to 15 cm in height → Create a surface from sketch → Ensure 

that the Add Material Operation is selected → Generate: 

 

9) Save the Project → Close Design Modeler → Link Ansys Mesh to Geometry in Workbench → Open Ansys Mesh. 

 

10) Set the Physics Preference to CFD. 

 

11) LC on the z-axis of the triad (bottom right corner) to view the domain from the side → Zoom in so that the whole 

domain is visible. 
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12) Insert a uniform edge sizing to the two horizontal edges (AB and FE): Mesh → Insert → LC on the edge selection 

filter:   → LC on edges AB and FE (See Figure 1) → Apply → Set the Type to Number of Divisions and set to 

10 → Set the Behavior to Hard → Rename the sizing as upstream-sizing 

 

13) Repeat step 12 with 15 elements on both vertical edges AF and CD → Rename the sizing as vertical-sizing 

 

14) Repeat step (13) with 20 elements on both inclined edges BC and ED → Rename the sizing as downstream-sizing 

 

15) Insert a Face Meshing method → Generate: 

 

 

 

16) Insert a boundary condition called walls consisting of edges FE and ED, and another one called farfield attaching 

to the remaining four edges (AF, AB, BC, CD):  
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17) Export the mesh file and name it expansion-30x15.msh which is indicative of the total number of x and y elements 

i.e. 30 and 15. 

 

18) Multiply the number of divisions in the edge sizings by a factor of 4 i.e. for the sizing defined in steps (12), (13) 

and (14), change to 40, 60 and 80, respectively → Generate the mesh → Export the mesh file and name it 

expansion-120x60.msh. 

 

19) Change the number of divisions in the edge sizing defined in steps (12), (13) and (14), to 160, 240 and 320, 

respectively → Generate the mesh → Export the mesh file and name it expansion-480x240.msh.  

 

20) Save Project → Close Ansys Mesh → Close Workbench. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

30 x 15 mesh 

120 x 60 mesh 

480 x 240 mesh 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               156 
 

21) Open Fluent in 2D, selecting Double Precision mode and opening in parallel with 4 Processors. 

 

22) Read in the coarse mesh file, expansion-30x15.msh, generated in step (17). 

 

23) Turn on the energy equation (Setup → Models → Energy) and ensure that the viscous model is inviscid (Setup 

→ Models → Viscous). 

 

Note: the use of the inviscid method is valid because viscosity only affects the very-near wall region in the laminar 

sublayer which is so small that it can be neglected for a problem like this; the expansion fan is of interest (i.e. far 

away from the wall). Furthermore, this is an isentropic problem, whereby energy losses due to viscosity are 

neglected.  

 

24) Change the solver to density-based: In the Outline View → Setup → General → In the Task Page change the 

Solver to Density-Based. 

 

 
 

25) Change material properties: In the Outline View → Setup → Materials → Fluid → Air → Change the Density 

method to ideal-gas → ensure that Cp = 1006.43 J/kg-K and that the molecular weight is 28.966 kg/kgmol → 

Change/Create → Close: 
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Note: It is necessary to activate the density-based solver because substantial density changes will take place in the 

expansion fan. The temperature and pressure will also change significantly and so the ideal gas law is required as 

the equation of state in the calculation of density. This is given by: 

 

nRTpV =                     (1) 

 

where: p is the pressure, V is the volume, n is the number of moles, R is the Universal Gas Constant and T is the 

absolute temperature. 

 

26) Change the farfield boundary condition from wall to pressure-far-field and set the relevant boundary conditions: 

In the Outline View → Setup → Double click Boundary Conditions → Under the Wall list select farfield RC → 

Change the Type to pressure-far-field → In the Pressure Far-Field menu box set the Gauge Pressure to 101325 

pascals (i.e. 1 atmosphere) → Set the Mach Number to 2 and ensure that the X-Component of Flow Direction = 1 

and the Y-Component of Flow Direction = 0 → Apply: 
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27) Set the operating pressure to zero: In the 

Outline View → Setup → Double click on Cell 

Zone Conditions → In in the Task Page LC on 

Operating Conditions… near the bottom of the 

Task Page → Set the Operating Pressure to 0 

pascals  → OK: 

 

Note: In compressible flow problems, the 

absolute pressure is required in the 

computation of density via the ideal gas law 

(equation 1). Therefore, to minimise errors, it 

is good practice to set the operating pressure 

to 0 Pa, then specify the absolute pressure 

(typically 101325 Pa) as the gauge pressure in 

the farfield boundary condition.  

 

For incompressible flow, the opposite is true i.e. the operating pressure is typically set to the absolute pressure 

(101325 Pa, if the ambient pressure in your problem is 1 atmosphere) and gauge pressure of 0 Pa is typically 

prescribed on pressure inlets and outlets. 

 

28) Set the correct reference values: In the Outline View 

→ Setup → Double click on Reference Values → In the 

Task Page → Select farfield in the Compute from menu 

and check that the values correspond to the boundary 

condition values. Note: the velocity will be specified in 

(m/s) instead of the Mach number. The velocity should 

be 694.1754 m/s: 

 

29) Ensure that the gradient method is Green-Gauss Cell 

Based and that the flow equation is discretised using 

Second Order Upwind (Solution → Methods). 

 

30) Lower the residual tolerance for continuity to 1e-16 

(Solution → Monitors → Residuals). 

 

31) Initialise the solution: Solution → Initialization → 

Select Standard Initialization → Compute from farfield 

→ Initialize. 

 

32) Save the case file as expansion-30x15.cas.h5 

 

33) Run the simulation for 500 iterations (Solution → Run Calculation)., you should observe convergence after 

300 of these.  

 

34) Save the data file as expansion-30x15-2nd-order.dat.h5 
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35) Create 4 lines to assist with post-processing using a journal file: Locate the file lines-tutorial-12.txt on MINERVA 

→ MECH5770M → Learning Resources → Slides, Tutorials and Extra info → Tutorials → Support files for 

Tutorial 5, 8 and 12. In Fluent LC File → Read → Journal… → Change Files of type from Journal Files to All files 

→ Browse for and select the file lines-tutorial-12.txt → OK: 

 

 
 

The file you have just read into Fluent has already been created in a text editor. The list of commands can be seen 

in the console below the graphics window once the file has been read in. Fluent ignores any line beginning with 

“;” which is used for adding comments. Fluent only recognises the four commands which start with the word 

“surface” (each written on a separate line).  

 

Each command utilises the Text User Interface (TUI) to create a line, assign a surface name and set the x and y 

coordinates for each end of the line, as highlighted above. Reading lists of commands into Fluent like this can be 

much quicker and more reliable than manually creating lines, as you have done in previous tutorials. Note: you can 

only read the journal file into each case once, doing this more than once causes conflicts due to repeated surface 

names. 

 

You can use this technique to change boundary conditions, turbulence models, discretisation schemes and just 

about anything which can be done in the Graphical User Interface (GUI). The exact commands can be explored and 

refined in the TUI first to find out the commands, depending on your requirements.  

 

The four lines described above are labelled in Figure 2 on the next page. Both Mach lines (coloured blue) are used 

purely for visualisation purposes in later steps. Their angle of inclination was determined from equations (2) and 

(3) below, which simply required the local Mach number. Note, the angle of mach-line-2 is calculated w.r.t the 

angle of the wall downstream of the turn. Hence the angle of mach-line-2 w.r.t the horizontal axis is calculated 

from: μ2 – δ.  
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The lines streamline-part-1 and streamline-part-2 are used to plot pressure data in later steps and to compare 

against analytical data. 

 

 

 

 

 

 

 

 

Figure 2: Illustration of the computational domain with four key lines labelled in addition to important angles. 
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36) Re-save the case file so that the four lines are saved as part of the case file as well. 

 

37) Display of the Mach number with both mach lines overlaid: In the Outline View → Results → Graphics → Double-

click Contours →  In the Contour menu box ensure that Filled selected under Options → Deselect Node Values 

→ Select contours of Velocity  and Mach Number → Select Draw Mesh under Options → The Mesh Display menu 

box will appear → Ensure that Edges is selected under Options and All is selected under Edge Type → Select 

mach-line-1 and mach-line-2 in the list of Surfaces → LC on the Colors... button → In the Mesh Colors menu box 

LC Surface (at the bottom) under Types → LC black under Colors → Close the Mesh Colors menu box → LC Display 

then Close in the Mesh Display menu box → LC Save/Display in the Contours menu box:  
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38) Plot the static pressure along the streamline indicated in Figure 2: In the main ribbon LC Result → XY Plot… → 

Edit… → In the Solution XY Plot ensure that the Plot Direction vectors are X=1 and Y=0 → Select the Y Axis 

Function as Pressure… and Static Pressure → Highlight the lines streamline-part-1 and streamline-part-2 in the 

list of Surfaces → Ensure that the Node Values option is checked → Plot → Click on the Write to File option and 

save the data as pressure-30x15 so that this can be plotted in Excel later. 
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39) Find the maximum and minimum values in the domain for the Mach number, static pressure and density using 

Surface Integrals. Compare your results with those in row 2 of the Table 1 below. You will need to calculate the 

isentropic property ratios i.e. p1 / p2 and ρ1 / ρ2. If you are using a different version of software (not ANSYS Fluent 

2020R2) then you may see slightly different results, however, the isentropic property ratios should be very similar 

to those in the table. 

Grid M1 M2 p1 p2 p1 / p2 ρ1 ρ2 ρ1 / ρ2 

30 x 15 1.9999 2.3830 55535.2 101331.8 0.5480 0.7454 1.1767 0.6335 

120 x 60 2.0000 2.3843 55535.7 101326.2 0.5481 0.7454 1.1767 0.6335 

480 x 240 2.0000 2.3844 55535.7 101325.2 0.5481 0.7454 1.1767 0.6336 

Analytical result 2.0000 2.3830 - - 0.5471 - - 0.6500 

 

Table 1 

 

40) Read in expansion-120x60.msh: File → Read → Mesh → Select the mesh file expansion-120x60.msh when 

prompted select the option Replace Data and Mesh (this ensures that the case file doesn’t need to be set up 

again).  

 

41) Initialise and run the simulation and repeat steps (37-39) using appropriate file names. Remember to save the 

case and data files. You can compare your CFD results to the analytical ones on the bottom row of Table 1. 

 

42) Repeat steps (40) and (41) using the mesh file expansion-480x240.msh. Compare your results for the Mach 

number contours to those below:  

 

 

 
 

 

 

 

30 x 15 grid 120 x 60 grid 

480 x 240 grid 
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TASK 8 

Using the data that you have obtained, please complete the following task. For each pressure plot you have exported, 

plot pressure as a function of horizontal distance (x). Also plot the analytical solution which is made of the four points 

shown in Table 2 below.  

 

 

 

 

 

 

 

 

 

• How do your results compare to the analytical solution?  

• Why might there be differences between them?  

• Which is the main factor which determines accuracy?  

Think about these questions and ask a demonstrator if you have any doubts.  

 

 

Tutorial 12 Summary:  

You have:  

• Generated three uniform, structured grids for the Prandtl-Meyer expansion with a turn angle of 10⁰. 

• Set up compressible flow simulations with a free-stream Mach number of 2. 

• Analysed the expansion wave both qualitatively and quantitatively and compared to analytical results. 

 

End of Tutorial 12 

 

 

 

 

 

 

 

 

 

 

 

 

    

Analytical 

x (m) p (pa) 

-0.10000 101325 

0.08660 101325 

0.14800 55435 

0.20086 55435 

Table 2 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 13: Compressible Flow (ii): Double-Wedge Aerofoil 

 

Tutorial 13 Outline:  

• Create a solution domain containing a double-wedge supersonic aerofoil. 

• Run an initial simulation on a coarse triangular mesh at a free-stream Mach number of 3. 

• Successively refine the grid by adapting cells to pressure gradients. 

• Compare results with and without grid adaption.  

• Complete TASK 9  

 

Prerequisites  

1) Ensure that you have completed Tutorials 1-12 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click  LC = Left mouse button click 

MC = Middle mouse button click 
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1) This tutorial involves simulations of supersonic airflow over a symmetric double-wedge shaped aerofoil at a free-

stream Mach number of 3. The purpose is to introduce mesh adaption, highlighting the benefits for resolving flow 

fields with sudden changes in flow properties. The principles can be extended to virtually any other flow case, 

whether compressible or incompressible. The geometry of the aerofoil and the domain is illustrated in Figure 1 

below with dimensions included (note, the aerofoil scale is exaggerated for clarity).  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1: Computational domain containing the double-wedge aerofoil. 

 

2) Open ANSYS Workbench.  

 

3) Open Design Modeler, (also called Geometry) → Save Project and name it supersonic-aerofoil.wbpj in your 

Tutorials folder. 

 

4) Using the dimensions shown in figure 1, create two sketches in the XYPlane, one comprising of the aerofoil (you 

can use a polyline) and another of the rectangular domain. You will need to use dimensions and the grid to aid 

sketching.  

 

5) From each sketch, create a surface and use a Boolean operation to subtract the aerofoil from the domain. 

Remember that at least one of the surfaces should be of type Add Frozen: 

 

15 m 

15 m 
10 m 

50 m 

2 m 

0.3 m 

Aerofoil 
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6) Save the Project → Close Design Modeler → Link Ansys Mesh to Geometry in Workbench → Open Ansys Mesh. 

 

7) Set the Physics Preference to CFD. 

 

8) Insert a uniform edge sizing to the four outer edges of the domain: Mesh → Insert → LC on the edge selection 

filter:   → LC on all four outer edges (See Figure 1) → Apply → Set the Type to Element Size and set to 1 m. 

 

9) Repeat step (8) to create another sizing, applying it to the four edges of the aerofoil and setting the Element Size 

to 0.01 m.   

 

10) Insert a Mesh Method, set the Method to Triangles → LC on Mesh in the Tree Outline → Under Sizing ensure 

that Use Adaptive Sizing is set to No, set the Growth Rate to be 1.07, Mesh Defeaturing is set to No, Capture 

Curvature is set to No and Capture Proximity is set to Yes → Leave all other settings as default values → Generate: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11) Insert a boundary condition called walls-wing to the four edges of the aerofoil. 

 

12) Insert another boundary condition called pressure-far-field to the four outer edges of the solution domain. 

 

13) Export the mesh file and name it supersonic-aerofoil.msh. 

 

14) Save the Project and close Ansys Mesh. 

 

15) Open Fluent in 2D, selecting Double Precision mode and opening in parallel with 4 Processors. 

 

16) Read in the mesh file generated in step (13). 

 

17) Turn on the energy equation and ensure that the viscous model is inviscid (Setup → Models). 

 

18) Change the solver to density-based (Setup → General). 

 

19) Change material properties: Setup → Materials → Fluid → Air → Change density method to ideal-gas → ensure 

that Cp = 1006.43 J/kg-K and that the molecular weight is 28.966 kg/kgmol → Change/Create → Close: 
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20) Set the pressure-far-field boundary conditions: Setup → Boundary Conditions → Double click pressure-far-field 

from the list of boundary conditions → In the Pressure Far-Field menu box set the Gauge Pressure to 101325 

pascals (i.e. 1 atmosphere) → Set the Mach Number to 3 and ensure that the X-Component of Flow Direction = 1 

and the Y-Component of Flow Direction = 0 → Apply.  

 

21) Set the operating pressure to zero: In the Tree → Setup → Double click on Cell Zone Conditions → In in the Task 

Page LC on Operating Conditions… → Set the Operating Pressure to 0 pascals → OK: 

 

22) Set the correct reference values: Setup → Reference Values… → Select pressure-far-field in the Compute from 

menu and check that the values correspond to the boundary condition values.  

 

23) Ensure that the gradient method is Green-Gauss Node Based and that the flow equation is discretised using 

Second Order Upwind (Solve → Methods). 

 

24) Lower the residual tolerance for continuity to 1e-16 (Solution → Monitors → Residuals). 

 

25) Initialise the solution: Solution → Initialization → Select Standard Initialization → Compute from pressure-far-

field → Initialize. 

 

26) Save the case file as supersonic-aerofoil-initial-mesh.cas.h5 

 

27) Run the simulation for 400 iterations and save the data file as supersonic-aerofoil-initial-mesh.dat.h5 

 

28) Display filled contours of the Mach number with Node Values deselected. Ensure the colourmap is Banded with 

20 levels and select the colourmap to be rgb under the Colormap Options: 

 

You should see some shock and expansion waves in the flow. Note that the mesh is very coarse in places and so 

the shock/expansion waves are not very well predicted further away from the aerofoil, therefore, mesh adaption 

is required. 
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29) Mark cells to be adapted based on velocity gradient: In the main ribbon LC Domain → Adapt → LC on the 

Refine/Coarsen… button → In the Adaption Controls menu box LC on Cell Registers → New → Field Variable… 

→ In the Field Variable Register menu change the Type to Top Value Cells, set the Derivative Option to Gradient, 

set the Gradient of to Velocity… and Mach Number → LC Compute → set the Cells having value in top n % to 90 

→ LC Save/Display and see the cells marked for adaption in the graphics window as well as a message in the 

Console showing how many cells have been refined (your number may be different to the one below, this is not a 

problem). Note, you may see a warning dialogue box describing the PUMA-2.5 adaption method: ignore it.   
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30) Adapt the marked cells: In the Adapt Controls menu box select gradient_0 as the option for Refinement Criterion 

→ Adapt → OK. Your mesh will now have refined cells in the adapted region. Note that these cells represent the 

top 90% of all cells in the domain with the highest velocity gradient. There are many other ways to adapt the mesh 

which you can explore. 

 

 
 

 

31) Run the calculation for a further 400 iterations. Note that the residuals history has changed due to the mesh 

changes: 

 

 
 

 

32)  Write the case and data files and save them as: supersonic-aerofoil-adapted-mesh.cas.h5. and supersonic-

aerofoil-adapted-mesh.dat.h5. 

 

Note: every time you adapt the mesh, this is a non-reversible process. If you do not save the case file before 

adaption, you will need to read in the original mesh file and start again.  

Residual history for 

simulation using the 

initial mesh 

Residual history for 

simulation using the 

adapted mesh 
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33) Now explore the differences between the initial and the adapted mesh and results. Some comparisons are given 

below: 

 

 
 

 
 

 

 

 

 

 

 

Initial Mesh 

Adapted Mesh 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               171 
 

 
 

 
 

Adapted Mesh 

Initial Mesh 
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Adapted Mesh 

Initial Mesh 
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TASK 9 

Using the results that you have obtained, please complete the following task. Observing the differences between the 

initial and the final mesh, think about the following questions: 

• Which mesh is better and why? 

• Where are the improvements seen in the solution domain? 

• Do you think mesh adaption is important for compressible flow cases? If so, why?    

Think about these questions and ask a demonstrator if you have any doubts. 

 

 

 

Tutorial 13 Summary:  

You have:  

• Run supersonic compressible flow cases for external aerodynamics of a double-wedge shaped aerofoil. 

• Implemented mesh adaption and explored the resulting flow fields with and without the adaption process.  

 

End of Tutorial 13 
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MECH5770M: Computational Fluid Dynamics Analysis 

 

Tutorial 14: 3D Flow in a Mechanically Ventilated Room (i) 

 

Tutorial 14 Outline:  

• Create a 3D solution domain of a small room with an occupant, an inlet and an outlet.  

• Generate a tetrahedral mesh including a boundary layer mesh on the occupant. 

• Set up a flow simulation including species transport to represent relative humidity in the room. 

• The resulting case file is saved for use in tutorial 15 (optional).  

• Complete TASK 10  

Prerequisites  

1) Ensure that you have completed Tutorials 1-13 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS 2020 R2, however, you may have access to other versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.   

4) The following acronyms are used throughout this document: 

 

RC = Right mouse button click  LC = Left mouse button click 

MC = Middle mouse button click 
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1) This tutorial is concerned with a small room which is supplied with fresh air through an inlet, see Figure 1. The bulk 

airflow exits the room through a diagonally opposing outlet. In the centre of the room, a cylinder is located to 

represent a very basic manikin shape. This has a surface temperature of 310 K and a heat generation rate of 20 

W/m2 and produces 0.005 kg/m2/h of water vapour (this represents perspiration). The ambient temperature in 

the room is 293 K and the relative humidity is 50%. Setting this problem up used the species transport model which 

is detailed in the steps below.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1: Computational domain consisting of a mechanically ventilated room. 

 

2) Open ANSYS Workbench.  

 

3) Open Design Modeler, (also called Geometry) → Save Project and name it room.wbpj in your Tutorials folder. 

 

4) Create a 3D box to represent the room: Create → Primitives → Box → In the Details View change the Operation 

to Add Frozen → Ensure that FD3, FD4 and FD5 are all set to 0 m (this is the origin of the box) → Set FD6 = 4.2 m, 

FD7 = 2.4 m and FD8 = 3.6 m (these are the dimensions of the walls in the three coordinate directions) → Generate: 

 

High Inlet                                                                                                                                            

 

 

Low Outlet                                                                                                                                            

 

 
3.6 m 

 

 

4.2 m 

 

 

2.4 m 

 

 

Cylindrical Manikin 
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5) Create a rectangular sketch on the XYPlane to represent the inlet: LC on XYPlane in the Tree Outline → LC on the 

blue Z-Axis on the triad (arrowed on in the image in step 4 above) → Use the Grid with a Major Grid Spacing of 1 

m and 10 Minor-Steps per Major to create a rectangle with the Rectangle tool → The rectangle should be created 

with two points located at (3.2,1.8) and (3.7,2.1) – remember you can see the coordinate in the bottom right 

corner of the Graphics window: 

 

 

6) Create a surface from the sketch: Concept → Surfaces From Sketches → LC on Sketch1 below XYPlane in the Tree 

Outline (you may need to click on the (+) sign below it) → LC Apply next to Base Objects in the Details View menu 

→ Change the Operation to Add Frozen → Generate: 

  

 

 

 

 

➔

Inlet Face 

(3.2,1.8) 

(3.7,2.1) 
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7) Use the Boolean tool to imprint the face created above onto the room air volume: Create → Boolean → Change 

the Operation to Imprint Faces → LC on Not Selected next to Target Bodies → LC on the room air volume → 

Apply (the volume should change colour to turquoise) → LC on Not Selected next to Tool Bodies → LC on the (+) 

symbol next to 2 part, 2 bodies → LC on Surface Body at the bottom of the tree → Apply → Generate: 
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If you now rotate the geometry using the Rotate tool  

and click on faces using the face selection tool , you 

will see that the inlet face is now part of the domain which 

allows the inlet boundary condition to be applied here in 

later steps. Note that there is now only 1 body, as required. 

8) Create another XYPlane which is coplanar with the wall 

opposite the inlet: LC on the New Plane button   which 

is above the Tree Outline → In the Details View change the 

Type to From Plane → Ensure that XYPlane is selected as 

the Base Plane (if not, LC XYPlane from the Tree Outline → 

Apply) → For the option Transform 1 (RMB) select Offset Z 

→ Specify a value of 3.6 m in the box below → Generate:   

 

 
 

Origin of the new 

plane, Plane4 
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9) Rotate the view and zoom into the origin of Plane4 to create the outlet face → LC on Plane4 in the Tree Outline 

to create a sketch on the correct wall of the domain → Repeat steps (5-7) to create another rectangular face (the 

outlet) with rectangle coordinates of (0.4,0.3) and (0.9,0.6), create a surface from Sketch2 and imprint the face on 

the wall of the room: 

 

 
 

 

10)   Create another sketch but this time create a circle on the ZXPlane (i.e. the bottom of the room) with the centre 

in the centre of the room at (1.8,2.1) (Note that these coordinates are in the form (z,x) because they relate to the 

ZXPlane). Use a Diameter dimension to set the diameter to 0.4m. You will need to view the correct plane by clicking 

on the Y-axis on the Triad. 

 

 
 

Outlet Face 

(1.8,2.1) 

(0.4,0.3) 

(0.9,0.6) 

Plane4 Origin 
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11) Extrude the circular sketch to create a cylinder and remove this material from the room volume: Create → Extrude 

→ Ensure that the name of the sketch used to create the cylinder (Sketch3 in this case) is selected next to the 

Geometry box → Change the Operation to Slice Material → Set FD1, Depth (>0) to 1.6 m → Generate:  

 

 
 

 

12) Supress the bodies not required for meshing: 

At the bottom of the Tree Outline LC on the (+) 

symbol next to 2 Parts, 2 Bodies → LC on the 

Solid in the list which is the cylinder (this should 

change colour in the Graphics Window) → RC 

→ Suppress Body → Repeat for any Surface 

Bodies which may be in the list (e.g. the circle 

used to create the cylinder). You should now be 

left with just the room air volume remaining. 

 

13) Save the Project → Close Design Modeler → 

Link Ansys Mesh to Geometry in Workbench 

→ Open Ansys Mesh. 

 

14) Set the Physics preference to CFD. 

 

15) Insert a face sizing on both of the rectangular faces created previously, i.e. the inlet and the outlet: Rotate the 

geometry until you can see the inlet face → LC the Face Sizing tool  → LC the inlet face (it should turn green) 

→ LC the Rotate tool  and rotate the geometry until you can see the outlet on the opposite side → LC the 

Face Sizing tool  again → Hold the Ctrl key and LC the outlet face to add this to the selection → RC Mesh→ 

Insert → Sizing → In the Details box set the Element Size to 0.04 m:    

 

 

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               181 
 

   
 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

16) Repeat step (15) to insert a face sizing of 0.08 m on the 6 large outer walls of the domain. You will need to 

rotate the geometry to highlight all 6 walls: 
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17) Repeat step (15) again to insert a face sizing of 0.04 m on both surfaces of the cylinder. You will need to 

rotate the geometry to view both faces of the cylinder: 

 

18) Insert an inflation layer to the two surfaces of the cylinder: LC Mesh in the Outline Tree → RC → Insert → Inflation 

→ LC on the main volume → Apply → Rotate the volume until you can see both surfaces of the cylinder → LC on 

No Selection next to Boundary → Select both surfaces → Apply → Set the number of Maximum Layers to 10 and 

set the Growth Rate to 1.15:  

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

19) Generate the mesh: LC Generate button. 

 

20) Examine the mesh quality: LC Mesh in the Outline → LC the (+) symbol next to Quality which is in the Details of 

“Mesh” menu box → Change the Mesh Metric to Skewness:   

 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               183 
 

 
 

Note: As described in step (23) of Tutorial 1, it is essential to keep the maximum skewness below 0.9. This requirement 

is satisfied above as the maximum skewness is approximately 0.84 which is typical for a reasonable quality 3D mesh. 

The total number of elements is approximately 0.29 million (you can check this by clicking on the (+) symbol next to 

Statistics which is in the Details of “Mesh” menu box). 

 

21) Create a Selection Plane to slice through the domain: LC on the Z-axis of the triad so that the room is viewed 

perpendicular to the inlet wall → In the top menu → Mesh → Insert → Section Plane → LC to the left of the air 

volume (in line with the inlet vent) and keep hold of the mouse button then drag to the other side of the room, 

this creates a horizontal line which slices through the geometry. 

 

 

 

 

 

 

 

 

 

 

 

 

Click here first and 

hold mouse button 

Let go of 

mouse 

button here 
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22) Examine the mesh: Rotate the geometry to view the top of the slice → LC the Show Whole Elements button   

which is situated in the Selection Planes menu → Zoom in on the cylinder and the inlet regions: 

 

 

    

Standard 

selection 

plane 

Selection 

plane with 

whole 

elements 

shown 
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23) Move the selection plane upwards to examine the mesh higher in the volume: LC the Edit Selection Plane button 

in the Selection Planes menu → You should see a blue slider button appear in the Graphics Window LC and hold 

the square to drag it upwards and thus move the slice so it is higher in the volume:  

 

Note: You can add multiple Section Planes in any orientation and they can all be used at once to show various slices 

of the mesh. Each Section Plane can be turned off by unchecking the box to the left of each one (arrowed above).  

24) Set the outlet boundary condition: Turn off the Section Plane by unchecking the box to the left of Section Plane 1 

→ In the main menu LC Display → LC Show Mesh button to hide the mesh → LC the Face Sizing tool  → LC 

the outlet face → RC → Create Named Selection → Set the name to outlet.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Slider can 

be moved 

up or down 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               186 
 

25) Repeat step (24) to create a boundary condition named walls which includes the four side walls, the floor and the 

ceiling of the domain.  

 

26) Create another boundary condition named inlet for the inlet face and a further one for the two faces of the 

cylinder, named cylinder (you will need to view the room from underneath to see these faces). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

27) Export the mesh file and name it room.msh  

 

28) Close Ansys Mesh. 

 

29) Open Fluent in 3D, selecting Double Precision mode and opening in parallel with 4 Processors. 

 

30) Read in the coarse mesh file, room.msh, generated in step (28). 

 

31) Turn on the Energy Equation and set the Standard k-ω model as the Viscous Model. 

 

32) Turn on the Species 

transport model: Setup 

→ Models → Double 

click on Species (Off) → 

In the Species Model 

menu box set the Model 

option to Species 

Transport → OK (leave 

all other settings as 

default) → You may see 

a warning that materials 

properties have 

changed, if so, LC OK: 
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33) Set up species material properties to simulate moisture production in later steps: Setup → Materials → Mixture 

→ Double click mixture-template → In the Create/Edit Materials menu box ensure that the Material Type is 

mixture → In the Properties list LC the Edit… button next to Mixture Species names → In the Species menu box 

LC oxygen (o2) in the Selected Species box → Remove → Repeat for nitrogen (n2) → LC air in the list of Available 

Materials → Add → Check that h2o and air are the only Selected Species and that h2o is at the top → OK → In 

the Create/Edit Materials menu box change the Density method from incompressible-ideal-gas to volume-

weighted-mixing-law → Also change both Thermal Conductivity and Viscosity methods from constant to mass-

weighted-mixing-law → LC the Change/Create button → Close: 
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Note: By default Fluent contains air, water, oxygen and nitrogen when the mixture template is used in the species 

transport model. If you require other species (e.g. CO2) then you can access this using the Fluent Database… button 

in the materials menu box, then find the species you want and copy across from the database. Also, the density, 

thermal conductivity and viscosity weighting laws specified above are suitable for species transport. You can find 

more details about the various methods in the Fluent User and Theory Guides.  

 

34) Set the Gradient method to Green-Gauss Node Based and set discretisation schemes for Pressure, Momentum, 

Turbulent Kinetic Energy, Specific Dissipation Rate, h2o and Energy to 2nd order (Solution → Methods). 

 

35) Lower the residual tolerance for continuity to 1e-16 and set the number of Iterations to Plot and Store to 10000 

(Solution → Monitors → Residual). 

 

36) Set the inlet boundary conditions: Setup → Boundary Conditions  → Double click inlet from the list to open the 

Velocity Inlet boundary condition menu box  → Set the Velocity Magnitude to 0.432 m/s → Change the 

Turbulence Specification Method to Intensity and Hydraulic Diameter → Set the Turbulent Intensity to 5% and 

Hydraulic Diameter to 0.375 m → LC on the Thermal tab → Set the Temperature to 293 K (This is the ambient 

temperature) →  LC on the Species tab → Set the Species Mass Fraction for h2o to 0.007 (This is the fraction of 

water found in the air at an ambient temperature of 293 K and 50% relative humidity: this was obtained from a 

Psychrometric Chart) → Apply → Close.  

 

37) Set the outlet boundary conditions: Setup → Boundary Conditions  → Double click outlet from the list to open 

the Pressure Outlet boundary condition menu box → Change the Turbulence Specification Method to Intensity 

and Hydraulic Diameter → Set the Backflow Turbulent Intensity to 5% and Backflow Hydraulic Diameter to 0.375 

m → LC on the Thermal tab → Set the Temperature to 293 K →  LC on the Species tab → Set the Species Mass 

Fraction for h2o to 0.007 (The temperature and humidity is the same as the inlet condition which has the effect 

setting the room ambient conditions to 293 K and 50% respectively) → Apply → Close.   

 

38) Set the wall temperature: Setup → Boundary Conditions → Open walls boundary condition menu box (this should 

consist of all walls except the cylinder) → LC on the Thermal tab → Select Temperature as the option for Thermal 

Conditions → Set the Temperature to 293 K → Apply → Close.  
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39) Identify a volume consisting of the first two layers of cells surrounding the cylinder from which to produce moisture 

(i.e. perspiration): In the main ribbon LC Domain → Adapt → Refine/Coarsening… → In the Adaption Controls 

menu → Cell Registers → New → Boundary… → In the Boundary Register menu box highlight cylinder in the 

Boundary Zones list → Ensure the Option is Cell Distance → Set the Number of Cells to 2 → LC the Save/Display 

button (You should see a message with the number of cells marked for adaption in the TUI, this should be around 

6250 cells) → Close: 

 

40) Separate the marked 

cells: In the main ribbon 

LC Domain → Zones → 

Separate → Cells… → 

Highlight both 

boundary_0 and solid in 

the two lists → Separate 

→  Close:  

 

Note: you should now see 

two zones in the list of Cell 

Zones Conditions in 

Setup: solid is the main air 

volume and solid:011 (the 

number may be different 

for you) is the tiny air 

volume of two cells in 

thickness surrounding the 

cylinder. 

 

 

 

 

41) Initialise the flow using Standard Initialization and Compute From the Inlet (Solution → Initialization…). 

 

42) Rename the cell zones: In the Setup → Double click Cell Zone Conditions → Double click solid from the list → In 

the Fluid boundary condition menu change the Zone Name from solid to air-room → Apply → Close → Repeat 

to change the name of the other zone to air-cylinder. 

 

43) Calculate the volume of air-cylinder: Results → Reports → Double click Volume Integrals → Change the Report 

Type to Volume → Highlight both air-cylinder and air-room in the list of Cell Zones → Compute → Close (you 

should see the two air volumes printed in the Console):    
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44) Verify that the surface area of the cylinder is 2.133 m2 using Surface Integrals. 

 

45) Set source terms to represent heat and moisture production from the cylinder which is considered a simplified 

manikin: Setup → Cell Zone Conditions → Double click on air-cylinder → In the Fluid menu box tick the box for 

Source Terms → LC the Source Terms tab → LC the Edit… button next to Mass → In the Mass Sources menu box 

increase the Number of Mass Sources to 1 → Change the option from none to constant and set the value to 

0.0002325 kg/m3s → OK → Return to the Fluid menu box and use the vertical slider bar to locate h2o sources  → 

Set the Number of h2o sources to 1 and change the value to constant, setting this to 0.0002325 kg/m3s → OK → 

Return to the Fluid menu box once more and locate Energy sources → Set the Number of Energy sources to 1 and 

change the value to constant, setting this to 2.788 W/m3 (i.e. approximately 4 orders of magnitude greater than 

the mass and h2o sources) → OK → LC Apply in the Fluid menu box → Close: 

 

 
 

 

 

 

 

Note: The mass and h2o (species) sources are calculated based on an assumed moisture production rate of 0.005 

kg/m2/h which is typical for a human. The energy source accounts for the fact that the moisture will enter the solution 

domain at the same temperature as the cylinder surface at 310 K (representing a human). More details of how to 

calculate these sources is given in the Multi-Physics lecture slides. 
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46) Set the wall boundary conditions on the cylinder surfaces: Setup → Boundary Conditions → Double click cylinder 

→ In the Wall boundary condition menu box → LC on the Thermal tab → Select Temperature as the option for 

Thermal Conditions → Set the Temperature to 310 K → Set the Heat Generation Rate to 20 W/m3 → Apply → 

Close. 

 

47) Save the case file as room.cas.h5 in your Tutorials folder. 

 

48) Run the simulation for 10 iterations and save the data file as room.dat.h5  

 

Note how much longer the simulation takes compared to the 2D simulations you have run in previous tutorials. 

You can use this case and data file to run a parallel computation on men-comp2 in the next tutorial to illustrate 

the power and the benefits of High Performance Computing. It is not essential for you to do this as part of the 

MECH5770M module; the final task below only relates to the mesh. 

 

49) Close Fluent. 

 

 

TASK 10 

Using the outputs from this tutorial, please complete the following task. Looking back at the mesh you created in steps 

(22) and (23), think about the following questions: 

• Thinking critically, how can the mesh be improved? 

• How could you assess the accuracy of solutions computed on this mesh? 

• What tools do you have within ANSYS which can be used to improve the mesh?    

Think about these questions and ask a demonstrator if you have any doubts. 

 

 

Tutorial 14 Summary:  

You have:  

• Created a 3D solution domain using the Extrude operation to subtract volumes and imprint faces.  

• Generated a tetrahedral mesh including a boundary layer mesh on the occupant. 

• Separated a cell zone using the Adapt functionality.  

• Set up a flow simulation including species transport to represent moisture production and relative humidity 

in the room. 

• Run the simulation for 10 iterations and saved the data for use in the next (optional) tutorial. 

 

End of Tutorial 14 
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MECH5770M: Computational Fluid Dynamics Analysis 

   

Tutorial 15 (OPTIONAL): 3D Flow in a Mechanically Ventilated 

Room (ii) High Performance Computing 

 

Tutorial 15 Outline:  

• Use the case and data files created in Tutorial 14 to run High Performance Computing (HPC) simulation 

• Modify a generic job submission script relating to the room case and data files. 

• Create an input script which contains all the simulation commands. 

• Log onto the School of Mechanical Engineering HPC cluster, men-comp2. 

• Submit a job to men-comp2 and monitor it. 

• Briefly post-process the results after the simulation has run. 

Prerequisites  

1) Ensure that you have completed Tutorials 1-14 which cover the basics of CFD pre and postprocessing. 

Notes 

1) You MUST complete the tutorials in order otherwise you will struggle to complete later exercises. 

2) Regularly save your work – programs do crash and you will lose unsaved work! 

3) This document is written using ANSYS version 19.1, however, you may have access to different versions of the 

software.  If this is the case, some menus and screen outputs may differ slightly but you should still be able to 

complete the tutorial.  

4) The following acronyms are used throughout this document: 
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1) This is an OPTIONAL tutorial which is not part of the assessment of MECH5770M. If you wish to undertake this 

tutorial, then you will need to submit an I.T. request to ask for an account to be set up for you on the HPC cluster, 

men-comp2. You can only complete this tutorial after you have an account on men-comp2. 

 

2) men-comp2 is a resource specifically for undergraduates and MSc students to run simulations quickly, for example 

as part of projects.  men-comp2 allows you to run parallel CFD simulations which are much faster to run than on 

an ordinary PC or laptop. The purpose of this tutorial is to introduce you to men-comp2 and use it to run a 

simulation with 8 processors (also known as cores). In total, men-comp2 has 268 cores split over 21 nodes (as of 

November 2017), each containing between 4 and 32 cores each. In order to run a simulation you will need: 

 

i. A Fluent case file which contains your mesh and has your boundary conditions and solver settings 

prepared. 

ii. A Fluent data file (unless you have no data and wish to initialise, as you have done in many of the previous 

tutorials). 

iii. A job submission script which specifies the resources i.e. job name, number of cores and memory 

requirements (RAM). 

iv. An input script containing the list of simulation commands. 

 

 

3) You only need to complete this step if you are on campus, if you are using your own machine this step is not 

necessary and you should go to step (5). Map a network drive to access men-comp2: From the Windows start 

menu open My Computer (this may be the name of the PC you are working on e.g. MEN-PC1234) → To map the 

network drive to men-comp2, type: \\men-comp2\username into the location box then press the Enter key 

(username is your username e.g. mn00abcd, a different one is shown below):  

 

 
 

 
 

Note: For the remainder of this tutorial, you will see cencag as the username in many of the images, however, you 

will see your own username on your computer screen.  

 

4) Once you have successfully mapped the network drive to your folder on men-comp2, create a sub-folder called 

room: this will contain your simulation files. 

 

5) In your Tutorials folder locate the files room.cas.h5 and room.dat.h5 which you created in Tutorial 14 and copy 

them to the room folder created in step (3) above.  
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Note: If you haven’t completed Tutorial 14, a copy of these files are available on MINERVA → MECH5770M → 

Learning Resources → Slides, Tutorials and Extra info → Support files for Tutorial 15 (OPTIONAL).  

 

Note 2: As of September 2020, the most up-to-date version of ANSYS available on men-comp2 is ANSYS V19. 

Therefore, you will not be able to use the files you created in Tutorial 14. However, the sample files described 

above will allow you do complete this tutorial. I.T. will be updating men-comp2 with ANSYS 2020 R2 at some 

point in October/November 2020 so your own files will probably work by then. If you do use the files provided 

(created in ANSYS V19), you will notice that the file extension is .cas.gz whereas this is now .cas.h5 (in ANSYS 

2020 R2 or later versions). 

 

6) Copy the generic job submission script called men-comp2-fluent-script.sh to your room folder which is on 

MINERVA → MECH5770M → Learning Resources → Slides, Tutorials and Extra info → Support files for Tutorial 

15 (OPTIONAL): You may need to unzip the file before you can use it. This script is shown below: 

 

#!/bin/sh 

# ------------------------------------------------- 

# This is a script for running Fluent on men-comp2 

# ------------------------------------------------- 

#$ -S /bin/sh 

# ------------------------------------------------- 

# Name of your simulation given after "-N" below.  

# Ensure this begins with a character and NOT a  

# number and make sure there are no spaces: use  

# dashes and underscores otherwise the job will  

# fail. 

# ------------------------------------------------- 

#$ -N job-name 

#$ -cwd 

#$ -j y 

# ------------------------------------------------- 

# Line below specifies the amount of RAM per core.  

# Use 1 for small jobs and 2 for larger ones. 

# ONLY use 1 or 2 - jobs will NOT RUN with more. 

# ------------------------------------------------- 

#$ -l h_vmem=1G 

# ------------------------------------------------- 

# Line below specifies the number of cores for your  

# simulation. This script is set up for 8 cores. 

# Try to use 4,8 or 12. Maximum of 12 cores  

# permitted otherwsie simulation will not run. 

# ------------------------------------------------- 

#$ -pe smp 4 

# ------------------------------------------------- 

# This script is for 3d models. If you are running  

# in 2d, change "3ddp" to "2ddp" below. Finally,  

# "input" is your input file for controlling the  

# fluent job. Make sure you include this in the same  

# directory as your Fluent case file. 

# ------------------------------------------------- 

fluent 3ddp -g -i input.txt 
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Note: The script on the previous page contains comments explaining what some of the commands actually do. You 

will notice that 5 parts of the script are highlighted above. These are the only parts of the script you should change. 

They are: 

 

job-name The name of the simulation or job which you submit. Always begin the job name with 
characters (never numbers) and use a continuous name e.g. fluent-job-001. 

1G This is the amount of RAM per processor or core. Only ever use 1G (1 Gigabyte) or 2G 
4 This is the number of processors or cores which you will use. Always use at least 4 cores but 

specifying any more than 32 will mean the job never runs. It is recommended that you specify 8, 
12, 16 or 20 cores. Remember, this is a shared machine so respect other users and refrain from 
hogging all the resources!  

3ddp This requests the 3D double precision Fluent solver. Change to 2ddp for 2D simulations. 
input.txt This is the name of the input file which contains the list of commands used to run your Fluent 

CFD simulation. You can change this name, but make sure it is a continuous file name (e.g. input-
12) with the extension .txt at the end and make sure you have an input file with that name. 
 

 

7) In your room folder, change the filename of your job submission script from men-comp2-fluent-script.sh to job.sh. 
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8) Open job.sh in a text editor and change job-name to room-sim and change the number of cores to 8. It is 

recommended that the text editor you use is Notepad++ and to find this you can highlight the file job.sh →   right 

click the mouse → LC on Edit with Notepad++  → Change the job name and number of cores → File → Save 

(Note: Alternatively you can also use the text editor Wordpad to make the necessary changes):  
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9) Create the input file which controls the simulation: To do this, highlight the text below → copy → Open either 

Notepad++ or Wordpad → paste → save the file as input.txt 

 

; An input script for running Fluent CFD Simulations 

; Written by Dr Carl Gilkeson 13/11/2017 

; 

; Any line which starts with ; is not recognised by fluent 

; and so you can add comments to your script 

; -------------------------------------------------- 

; Read in the case file 

; -------------------------------------------------- 

file/read-case room.cas.gz 

; -------------------------------------------------- 

; Read in the existing data file 

; -------------------------------------------------- 

file/read-data room.dat.gz 

; -------------------------------------------------- 

; Run the simulation for 490 iterations 

; -------------------------------------------------- 

solve/iterate 490 

; -------------------------------------------------- 

; Write the data file by over-writing the one you  

; read in earlier. 

; -------------------------------------------------- 

file/write-data room.dat.gz 

yes 

; -------------------------------------------------- 

; Exit Fluent and complete the job 

; -------------------------------------------------- 

exit yes 

; -------------------------------------------------- 

; Note: if you have no data file to read in before  

; you start the simulation, then you will need to 

; include the initialise command. This is given  

; below (remember to remove the ; symbol if you use 

; this command): 

; solve/initialize/initialize-flow 

 

 

10) If you are using your own machine, go to the next step. If you are on campus, check that your room folder on men-

comp2 contains the four files: input.txt, job.sh, room.cas.gz and room.dat.gz as shown below. Note that the case and 

data file has the extension .gz but this is .h5 for any files created in ANSYS 2020 R2 or later.  
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11) Download the portable version of MobaXterm: In a web browser search for https://mobaxterm.mobatek.net/ → 

LC on the link to GET MOBAXTERM NOW! → LC on the Download link for the Home Edition → In the next window 

click on the for the Portable Edition → After you have saved the zipped folder, open it and double click on the 

executable which will look something like this: MobaXterm_Personal_10.4.exe → Whether you unzip the file so 

or not, LC on the Run button → Now the MobaXterm program will open which allows you to access men-comp2: 

            

 

12) LC on the New session button → Enter men-comp2 into the Remote host field → LC on the OK button: 

                        

https://mobaxterm.mobatek.net/
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13) You will then see a black window (called a terminal) and you are asked to login as: so enter your username and 

press Enter on the keyboard. You may also be asked to enter your password then you will be logged into men-

comp2: 

 

 
 

 
 

14) If you are using a machine on campus, go to the next step. If you are using your own machine, drag and drop the 

room folder from your computer to the file area within MobaXTerm shown with the red box above. This will ensure 

that all files are copied to your home area on men-comp2. 
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15) Display the resources available on men-comp2: In the terminal type qstat –f and press Enter on the keyboard: 

 

 
 

You should see the table above which is referred to as the queue. The first column, queuename, lists the identification 

of each node in the queue. The third column lists the status of the cores in the form reserved/used/total; total is the 

number of cores on each node and used is the number of those cores which are currently in use (you can see that the 

user, menblh, has a number of simulations running in the above image). The fourth column shows the average load 

on each node. Typically, the load is equal to the number of processors used so if 8 cores are in use on a node, the load 

is likely to be 8.00 for Fluent simulations (this number varies for other software packages running on the machine).  
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16) Type clear and press Enter (this clears the screen) → Change the directory (a folder) to room and list the files in 

the directory: In the terminal type cd room → Press Enter → type ls → Press Enter:  

 

 
 

Note: cd means change directory and ls means list the files in the directory. These are both types of Linux commands. 

men-comp2 uses the Linux operating system instead of Windows and so you need to use a small number of these and 

other commands to navigate directories and run/manage simulations. You should also notice that the list of files 

(shown in green) are those you placed in the directory room in previous steps. 

 

17) Submit the job (simulation) to men-comp2 to run the simulation: In the terminal type qsub job.sh → Press Enter:  

 
 

The command qsub submits the job submission script (job.sh) to the queue. You will see a message in the console 

saying: Your job 1234 (“room-sim”) has been submitted, where 1234 will be your job-ID number which in the case 

shown here is 2947. Note: If you need to delete your job for whatever reason (e.g. specifying incorrect case file name), 

in the terminal type: qdel 1234 (where 1234 is the job-ID). After a few minutes, the job will be deleted.  

 

18) Show the status of any of your jobs in the queue: In the terminal type qstat → Press Enter: 

 

 
 

You will now see your job in the queue. From left to right the columns show: 

• job-ID: This is the job identification number which is unique to each simulation. 

• prior: The priority of your job (this priority level reduces as you submit more and more jobs so if you submit 

multiple jobs, then your jobs will have smaller priority than somebody who hasn’t submitted many. 

• name: The name of your job (specified in your submission script job.sh). 

• user: Your username. 

• state: The state of the job (r = job running; qw = queue waiting; tr = job is transitioning from qw to r). 

• submit/start at: This shows the date and time that you submitted your job. 

• queue: This shows which node you are running on in the queue. 

• slots: This shows how many cores (processors) you have requested (this was set to 8 in job.sh) 
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19) Show the list of files in your directory: In the terminal type ls → Press Enter:  

 

 
 

Note how the number of files has increased compared to step (17). A cleanup file has appeared but this will vanish 

when the simulation is complete (if it doesn’t you can delete it after the simulation has ended). You will see that two 

new files have appeared and the one of interest to you is the output file which has the form: job-name.o1234 where 

job-name is room-sim in this case and 1234 is the job-ID number which is 2947 for the example shown. Obviously your 

job-ID will be different.  

 

If your job is waiting in the queue (status = qw) then these extra files will not be visible; they only appear when the 

simulation actually starts. When the machine is busy, you may have to wait for resources to become available for your 

simulation to run.  

 

20) View the tail (bottom) of the output file to observe the simulation progress:  In the terminal type tail –f room-

sim.o1234 where 1234 is your job-ID → Press Enter:  

 

 
 

The tail –f command shows the live output from the simulation. As you are remotely accessing men-comp2, you can 

monitor the simulation progress with this command and judge how it is progressing from the residual levels and any 

solution monitors that you may have set up. The output file will update periodically so if it looks like the screen has 

frozen, be patient and the file will be updated. This simulation should take approximately 4 minutes. You will also 

receive emails when each simulation starts and ends.  

 

21) Once the simulation has finished, exit the tail –f command: On the keyboard press Ctrl + C: 
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22) List the files in the directory with date stamp information:  In the terminal type ls –lt  → Press Enter:  

 

 
 

This command lists the files in order of which one was saved most recently. You will see that the output file is the most 

recent one, with the simulation data file slightly older. This confirms that the simulation file was written just before 

the end of the output file, which is consistent with the list of commands you have used in the input file.  

 

23) Check your disk space quota:  In the terminal type quota –v  → Press Enter:  

 

 
 

This shows how much data you have stored on men-comp2 (blocks), what your quota is (quota) and the absolute limit 

(limit). Your quota will typically be 1Gb or 2Gb and if you go over this, your simulations may not work because there 

will be insufficient disk space to save the data files and/or output files. If you exceed quota, and you are under limit 

then you have 7 days to remove files to free up disk space, before files are automatically deleted.  

 

24) Now that your simulation is complete, log out of the terminal: On the keyboard press Ctrl + D (You will need to 

open MobaXterm again if you wish to run other simulations). 

 

25) From the network drive created in step (2), copy the simulation data file, room.dat.gz and the output file, room-

sim.o1234 (where 1234 is your job-ID) to your Tutorials folder on the N drive or wherever you are saving your files.  

 

26) Open the output file in Notepad++ or Wordpad: (see next page) 



MECH5770M  Tutorial Handbook 

Written by Dr Carl Gilkeson © School of Mechanical of Engineering, University of Leeds, 2020. All rights reserved.                               204 
 

 

The output file contains everything Fluent has 

done in the simulation. This is the same as the 

information you see in the Console or TUI 

when you open Fluent interactively. In cases 

where simulations fail, the output file will 

often contain clues of what happened and 

why e.g. divergence detected. It is good 

practice to put each new simulation in its own 

directory to avoid potential problems of 

having too many files.  

 

27) On your PC, open Fluent in 3ddp serial 

mode (i.e. one processor). 

 

28) Read in the case and data files, 

room.cas.gz and room.dat.gz. 
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29) Using the Sweep Surface tool which is in the Task Page (In the Tree → Results → Double click Graphics), create a 

vertical plane at x=2.1m which is in the centre of the room (recall Tutorial 8 which shows you how to do this).    

 

30) Change the background colour to black (recall step 5 in Tutorial 6). 

 

31) Display filled contours of Species… and Relative Humidity on the plane you have just created. Change the Scale to 

range from 30-50% relative humidity. To do this turn off Auto range and enter the values 30 and 50 for Min and 

Max values respectively. Also show the mesh outline and you may need to turn off the lights on the top ribbon, 

under the Viewing tab: 
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You will notice that the relative humidity is less than the ambient value of 50% around the cylinder. This may seem 

counter intuitive because the cylinder is producing moisture using the source term for water vapour (h2o) created 

in Tutorial 14. However, the key to this observation is in the definition of relative humidity. Quantifying moisture 

content in the air using relative humidity is always done relative to the saturation value at a given temperature, 

so absolute variations in humidity are unaccounted for with this quantity. Hence low relative humidity values at 

high temperature may exhibit greater water content per unit volume of air than for high relative humidity at a 

lower temperature. This can clearly be seen on a psychrometric chart as will be shown in Lecture slides 10.  

 

32) On the same plane as in the previous step, display contours of Species… and Mass fraction of h2o. Change the 

Scale to range from 0.007 to 0.008 (Recall from Tutorial 14 that 0.007 is the ambient mass fraction of water 

determined by your inlet and outlet boundary conditions).   

 

 
 

This is a better way of showing the moisture content in the air; the moisture source term is increasing the mass 

fraction of water near the cylinder and where air movement is limited.  
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33) Create a Pathlines plot, releasing points from the inlet with the number of Steps = 5000, Path Skip = 5, colour the 

pathlines by Velocity Magnitude using coarse-cylinders, show the mesh outline and turn lights on: 
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34) Display the residuals: On the top ribbon → Postprocessing → Plots → Residuals… → Plot: 

 

 
 

You should notice that the simulation hasn’t actually converged yet, however, the short simulation you carried out 

shows you how to set up HPC simulations which is the main purpose of this tutorial. You are now able to run 

simulations for longer by increasing the number of iterations in the input file. Furthermore, you will notice that 

the residual plot has extra residuals for energy (temperature) and h2o (water species). 

 

Another important point is that the near-wall mesh requirements for suitable y+ values has been neglected in this 

indoor airflow problem. This is perfectly valid because the near-wall effects are not important in this situation, the 

bulk airflow patterns are of more interest and these occur within the main air volume i.e. not near walls. If you 

were concerned with particle deposition on walls, then the near-wall mesh requirement would be important, 

requiring attention.  

 

35) Save the case file and close Fluent. 

 

Tutorial 15 Summary:  

You have:  

• Mapped a network drive to the High Performance Computer (HPC), men-comp2. 

• Logged into men-comp2 using MobaXterm. 

• Modified a generic job submission script to specify HPC resource requirements. 

• Created an input script which contains all the simulation commands. 

• Submitted a job to men-comp2 and monitored the simulation output. 

• Carried out some brief post-processing having copied the data file back from men-comp2 to your PC locally.  

 

End of Tutorial 15 
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